Closed Bug 979597 Opened 7 years ago Closed 6 years ago

Android 2.3 testAboutHomeVisibility | The current HomePager panel is TOP_SITES - got 0, expected 1

Categories

(Firefox for Android :: Testing, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 33

People

(Reporter: gbrown, Assigned: gbrown)

References

Details

https://tbpl.mozilla.org/php/getParsedLog.php?id=34517457&tree=Ash&full=1#error17

15:46:47     INFO -  1 INFO TEST-START | testAboutHomeVisibility
15:46:47     INFO -  2 INFO TEST-PASS | testAboutHomeVisibility | Given message occurred for registered event: {"type":"Gecko:Ready"} - Gecko:Ready should equal Gecko:Ready
15:46:47     INFO -  EventExpecter: no longer listening for Gecko:Ready
15:46:47     INFO -  3 INFO TEST-PASS | testAboutHomeVisibility | The toolbar is not in the editing state - 
15:46:47     INFO -  4 INFO TEST-PASS | testAboutHomeVisibility | The Toolbar title is  -  should equal 
15:46:47     INFO -  5 INFO TEST-PASS | testAboutHomeVisibility | The HomePager is visible - 0 should equal 0
15:46:47     INFO -  6 INFO TEST-PASS | testAboutHomeVisibility | The HomePager is visible - 0 should equal 0
15:46:47     INFO -  7 INFO TEST-PASS | testAboutHomeVisibility | The current HomePager panel is TOP_SITES - 1 should equal 1
15:46:47     INFO -  8 INFO TEST-PASS | testAboutHomeVisibility | url is not null - /robocop/robocop_blank_01.html should not equal null
15:46:47     INFO -  9 INFO TEST-PASS | testAboutHomeVisibility | url is not null - /robocop/robocop_blank_01.html should not equal null
15:46:47     INFO -  10 INFO TEST-PASS | testAboutHomeVisibility | The toolbar is not in the editing state - 
15:46:47     INFO -  11 INFO TEST-PASS | testAboutHomeVisibility | Waiting for Toolbar to enter editing mode. - 
15:46:47     INFO -  12 INFO TEST-PASS | testAboutHomeVisibility | Waiting for UrlEditText to be input method target. - 
15:46:47     INFO -  13 INFO TEST-PASS | testAboutHomeVisibility | url is not null - http://mochi.test:8888/tests/robocop/robocop_blank_01.html should not equal null
15:46:47     INFO -  14 INFO TEST-PASS | testAboutHomeVisibility | The toolbar is in the editing state - 
15:46:47     INFO -  15 INFO TEST-PASS | testAboutHomeVisibility | The UrlEditText is the input method target - 
15:46:47     INFO -  16 INFO TEST-PASS | testAboutHomeVisibility | The toolbar is in the editing state - 
15:46:47     INFO -  17 INFO TEST-PASS | testAboutHomeVisibility | initiatingAction is not null - org.mozilla.gecko.tests.components.ToolbarComponent$2@405be740 should not equal null
15:46:47     INFO -  ToolbarTitleTextChangeVerifier: stored title, "".
15:46:47     INFO -  EventExpecter: no longer listening for DOMContentLoaded
15:46:47     INFO -  EventExpecter: no longer listening for DOMTitleChanged
15:46:47     INFO -  ToolbarTitleTextChangeVerifier: state changed to title, "Browser Blank Page 01".
15:46:47     INFO -  ToolbarTitleTextChangeVerifier: was satisfied.
15:46:47     INFO -  18 INFO TEST-PASS | testAboutHomeVisibility | Waiting for Toolbar to exit editing mode. - 
15:46:47     INFO -  19 INFO TEST-PASS | testAboutHomeVisibility | The toolbar is not in the editing state - 
15:46:47     INFO -  20 INFO TEST-PASS | testAboutHomeVisibility | The Toolbar title is Browser Blank Page 01 - Browser Blank Page 01 should equal Browser Blank Page 01
15:46:47     INFO -  21 INFO TEST-PASS | testAboutHomeVisibility | The HomePager is not visible - 
15:46:47     INFO -  22 INFO TEST-PASS | testAboutHomeVisibility | url is not null - /robocop/robocop_blank_02.html should not equal null
15:46:47     INFO -  23 INFO TEST-PASS | testAboutHomeVisibility | url is not null - /robocop/robocop_blank_02.html should not equal null
15:46:47     INFO -  24 INFO TEST-PASS | testAboutHomeVisibility | The toolbar is not in the editing state - 
15:46:47     INFO -  25 INFO TEST-PASS | testAboutHomeVisibility | Waiting for Toolbar to enter editing mode. - 
15:46:47     INFO -  26 INFO TEST-PASS | testAboutHomeVisibility | Waiting for UrlEditText to be input method target. - 
15:46:47     INFO -  27 INFO TEST-PASS | testAboutHomeVisibility | url is not null - http://mochi.test:8888/tests/robocop/robocop_blank_02.html should not equal null
15:46:47     INFO -  28 INFO TEST-PASS | testAboutHomeVisibility | The toolbar is in the editing state - 
15:46:47     INFO -  29 INFO TEST-PASS | testAboutHomeVisibility | The UrlEditText is the input method target - 
15:46:47     INFO -  30 INFO TEST-PASS | testAboutHomeVisibility | The toolbar is in the editing state - 
15:46:47     INFO -  31 INFO TEST-PASS | testAboutHomeVisibility | initiatingAction is not null - org.mozilla.gecko.tests.components.ToolbarComponent$2@406845d0 should not equal null
15:46:47     INFO -  ToolbarTitleTextChangeVerifier: stored title, "Browser Blank Page 01".
15:46:47     INFO -  32 INFO TEST-PASS | testAboutHomeVisibility | Given message occurred for registered event: {"type":"DOMTitleChanged","title":"Browser Blank Page 02","tabID":0} - DOMTitleChanged should equal DOMTitleChanged
15:46:47     INFO -  33 INFO TEST-PASS | testAboutHomeVisibility | Given message occurred for registered event: {"errorType":"","bgColor":"transparent","type":"DOMContentLoaded","tabID":0} - DOMContentLoaded should equal DOMContentLoaded
15:46:47     INFO -  EventExpecter: no longer listening for DOMContentLoaded
15:46:47     INFO -  EventExpecter: no longer listening for DOMTitleChanged
15:46:47     INFO -  ToolbarTitleTextChangeVerifier: state changed to title, "Browser Blank Page 02".
15:46:47     INFO -  ToolbarTitleTextChangeVerifier: was satisfied.
15:46:47     INFO -  34 INFO TEST-PASS | testAboutHomeVisibility | Waiting for Toolbar to exit editing mode. - 
15:46:47     INFO -  35 INFO TEST-PASS | testAboutHomeVisibility | The toolbar is not in the editing state - 
15:46:47     INFO -  36 INFO TEST-PASS | testAboutHomeVisibility | The Toolbar title is Browser Blank Page 02 - Browser Blank Page 02 should equal Browser Blank Page 02
15:46:47     INFO -  37 INFO TEST-PASS | testAboutHomeVisibility | The HomePager is not visible - 
15:46:47     INFO -  38 INFO TEST-PASS | testAboutHomeVisibility | The toolbar is not in the editing state - 
15:46:47     INFO -  39 INFO TEST-PASS | testAboutHomeVisibility | Waiting for Toolbar to enter editing mode. - 
15:46:47     INFO -  40 INFO TEST-PASS | testAboutHomeVisibility | Waiting for UrlEditText to be input method target. - 
15:46:47     INFO -  41 INFO TEST-PASS | testAboutHomeVisibility | The HomePager is visible - 0 should equal 0
15:46:47     INFO -  42 INFO TEST-PASS | testAboutHomeVisibility | The HomePager is visible - 0 should equal 0
15:46:47     INFO -  43 INFO TEST-UNEXPECTED-FAIL | testAboutHomeVisibility | The current HomePager panel is TOP_SITES - got 0, expected 1
15:46:47     INFO -  44 INFO TEST-END | testAboutHomeVisibility | finished in 74025ms
15:46:47     INFO -  45 INFO TEST-START | Shutdown
15:46:47     INFO -  46 INFO Passed: 41
15:46:47  WARNING -  47 INFO Failed: 1
15:46:47  WARNING -  One or more unittests failed.
15:46:47     INFO -  48 INFO Todo: 0
15:46:47     INFO -  49 INFO SimpleTest FINISHED
15:46:47     INFO -  INFO | automation.py | Application ran for: 0:01:39.070185



Like bug 974306?
https://hg.mozilla.org/integration/mozilla-inbound/rev/fd05954707e8
Whiteboard: [leave open] [test disabled on Android 2.3]
Blocks: 979921
No longer blocks: 967704
(In reply to Geoff Brown [:gbrown] from comment #0)
> Like bug 974306?

bug comment 0 failed at the start of the test, rather than on a later invocation of the HomePager (i.e. [1]). Both end up on the HomePanel of index 0 (i.e. HISTORY).

It could be related, but I don't have any clues as to the cause.

[1]: https://mxr.mozilla.org/mozilla-central/source/mobile/android/base/tests/testAboutHomeVisibility.java?rev=1d2fa2d09f5b#33
I can no longer reproduce this. Re-enabled:

https://hg.mozilla.org/integration/mozilla-inbound/rev/ce98430da0ab
Assignee: snorp → gbrown
Whiteboard: [leave open] [test disabled on Android 2.3]
https://hg.mozilla.org/mozilla-central/rev/ce98430da0ab
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 33
See Also: → 1105887
You need to log in before you can comment on or make changes to this bug.