Create/manage *Server Side* Virtual Folders on dovecot server

RESOLVED DUPLICATE of bug 439047

Status

defect
RESOLVED DUPLICATE of bug 439047
6 years ago
5 years ago

People

(Reporter: tanstaafl, Unassigned)

Tracking

24 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20140212131424

Steps to reproduce:

Created a virtual folder with Thunderbird


Actual results:

It was created, but only locally


Expected results:

Thunderbird should recognize that Dovecot is the backend IMAP Server and create a server side 'Virtual Mailbox' instead of a local virtual folder.

Obviously this feature would only be relevant for IMAP servers that have dovecot as the backend, but that number is growing on a daily basis, and I do believe that dovecot is in a majority position already.

There should be a way to 'test' whether or not the server supports this feature.

I love the *concept* of virtual folders, and played with them for some time a few years ago, but doing it locally just doesn't work (well, it works, but it isn't practical because the virtual folders don't show up anywhere else) on an IMAP server.

Implementing this as a server side feature (requiring dovecot as the server backend) would actually make this feature something that people would simply use.

I can even see a use case for a config option to *only* allow creation of server-side virtual folders (ie, no 'real' folders') - or just a default, with the dialog allowing the user to check a box to make it a real folder at creation time.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 439047
You need to log in before you can comment on or make changes to this bug.