Must log in twice or more to Earthlink nntp server

VERIFIED DUPLICATE of bug 36816

Status

MailNews Core
Networking: NNTP
VERIFIED DUPLICATE of bug 36816
17 years ago
9 years ago

People

(Reporter: Jason Goodman, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
This may be a Networking - News bug, or it may be an evangelism bug.

Bug setup:
Account setup in MailNews for news.earthlink.net.  Subscribed to two newsgroups:
sci.space.tech and sci.space.science.

Reproducing the bug:1) Start MailNews
2) Enter IMAP password.
3) Enter News username (goodsmit@earthlink.net)
4) Enter News password.
5) Open first newsgroup (sci.space.tech), read some news.
6) Compose a reply, hit "send".
7) Enter News username.
8) Enter News password.
9) Open second newsgroup (sci.space.science).
10) Enter News username.
11) Enter News password.

Reproducibility:
I seem to always need to enter username/password the first time you reply to a
message.  I *sometimes* am asked for username/password for the second newsgroup.

Expected results:
As I recall, NS4 required only one login at the beginning of the News session. 
I shouldn't have to type in my password multiple times.

Caveats:
Earthlink's news server could have some sort of timeout feature, which could
explain some of this behavior.  But it only takes me a few minutes to type in
and send a reply, after reading a message, and why does it seem to happen so
much more often with Mozilla than NS4?
Build ID: 2001083108
Blocks: 98033
Jason, can you post an NNTP log, please?  This would help out a great, since I
don't have credentials to test Earthlink myself. Refer, if you would, to
http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap for
instructions, substituting NNTP for IMAP, thanks!
Okay, Seth told me briefly what's going on with this.  It has to do with the URI
scheme, and the way we're sending/storing the user/name pass for the news URI to
the password manager.  It needs to be more robust, and do it per server (I hope
I got that right.)  
Status: UNCONFIRMED → NEW
Ever confirmed: true
*** Bug 96896 has been marked as a duplicate of this bug. ***
*** Bug 101635 has been marked as a duplicate of this bug. ***
See this logfile http://bugzilla.mozilla.org/showattachment.cgi?attach_id=50400
from bug 78356.
Created attachment 52680 [details] [diff] [review]
start of a hack, but I need to modify nsIWalletService.idl to finish this.

Comment 7

16 years ago
Partial patch looks good so far.

*** This bug has been marked as a duplicate of 36816 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
verified dup - I copied the patch link and relevant information into the older bug.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.