Closed Bug 980839 Opened 6 years ago Closed 6 years ago

Panel UI doesn't prompt for reauth when restarting after password change

Categories

(Firefox :: Sync, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 + verified
firefox30 + verified

People

(Reporter: ttaubert, Assigned: ttaubert)

References

Details

Attachments

(1 file)

The tools menu's menuitem from bug 976683 changes only because updateUI() is called when the menu popup opens. We don't do the same for the panel UI and I'd rather have a notification that notifies us about LOGIN_FAILED_LOGIN_REJECTED.
Component: Tracking → Sync
Product: Core → Firefox
QA Contact: chofmann
Mark, do you think we should add a notification here? Where would be the best place to do that?
(In reply to Tim Taubert [:ttaubert] from comment #1)
> Mark, do you think we should add a notification here? Where would be the
> best place to do that?
Flags: needinfo?(mhammond)
It seems a bit of a shame to have a very-long-lived observer just to change the state of a closed panel that may not be opened again.  Is there no way to update this as the panel opens?

If not, I guess we'd want to leverage the existing weave:service:login:error notification, and maybe create a new one to indicate success.
Flags: needinfo?(mhammond)
Issue for adding back this notification: Bug 981172
Depends on: 981172
The notification that was added back in bug 981172 definitely fixes the issue. The new notification we listen for that this patch adds makes us do the same as the SyncUI code. It basically lets re-check state when xps.ready switches to true.
Attachment #8388900 - Flags: review?(mhammond)
Attachment #8388900 - Flags: review?(mhammond) → review+
Comment on attachment 8388900 [details] [diff] [review]
0001-Bug-980839-Panel-UI-doesn-t-prompt-for-reauth-when-r.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): ?
User impact if declined: Panel UI doesn't reflect correct state when starting up with a login failure.
Testing completed (on m-c, etc.): Almost on m-c.
Risk to taking this patch (and alternatives if risky): Super-low risk.
String or IDL/UUID changes made by this patch: None.
Attachment #8388900 - Flags: approval-mozilla-aurora?
Comment on attachment 8388900 [details] [diff] [review]
0001-Bug-980839-Panel-UI-doesn-t-prompt-for-reauth-when-r.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): ?
User impact if declined: Panel UI doesn't reflect correct state when starting up with a login failure.
Testing completed (on m-c, etc.): Almost on m-c.
Risk to taking this patch (and alternatives if risky): Super-low risk.
String or IDL/UUID changes made by this patch: None.
Attachment #8388900 - Flags: approval-mozilla-aurora?
Attachment #8388900 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/470a1e4e9ac5
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
Attachment #8388900 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Keywords: verifyme
I was able to confirm the fix for this bug on Firefox 29 (Build ID: 20140421221237) and Aurora 30 2014-04-24 (Build ID: 20140424004002) using:
 * Windows 7 64-bit [1],
 * Ubuntu 14.04 LTS 32-bit [2],
 * Mac OS X 10.9 [3].

1. Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
2. Mozilla/5.0 (X11; Linux i686; rv:29.0) Gecko/20100101 Firefox/29.0
3. Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:29.0) Gecko/20100101 Firefox/29.0
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.