Closed Bug 980879 Opened 7 years ago Closed 7 years ago

[Australis] Navigation buttons in urlbar overlapping search bar when resizing a window when on verified identity site

Categories

(Firefox :: Theme, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 --- fixed
firefox30 --- verified

People

(Reporter: bogdan_maris, Assigned: Dolske)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:P3+])

Attachments

(2 files)

Reproducible on the latest Aurora (BuildID: 20140306004001).
Reproducible on the latest Nightly (BuildID: 20140306030201): 
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20130205 Firefox/21.0


Steps to reproduce:
1. Start Firefox.
2. Open the menu and click Customize.
3. Drag/Drop about 10 tools into the main Toolbar.
4. Exit Customization.
5. Visit https://www.mozilla.org/en-US/firefox/central/ 
6. Shrink Firefox slowly from left or right side.

Expected results: Tools are thrown in More Tools dropdown and no layout issues are seen.

Actual results: Retry and dropdown from URL bar are overlapping other elements from right.


Notes:
1. This issues reproduces on Windows, Ubuntu and Mac OS X.
2. This issue is a regression - did not reproduce on Nightly from 2013-12-19 (20131219030202). Will investigate further on this direction.
3. Screenshot showing the issue.
4. This only happens with a website that has its Identity verified.
Blocks: 897160
This doesn't reproduce with about:home, but it does with e.g. addons.mozilla.org.
Summary: [Australis] Navigation buttons overlapping icons from toolbar → [Australis] Navigation buttons in urlbar overlapping search bar when resizing a window when on verified identity site
Whiteboard: [Australis:P3+]
Oddly this also seems to require the Search Box to be in the navbar (anywhere, doesn't need to be next to the urlbar). Without it I can't reproduce this.
...no, scratch that, it just seems to need a bunch of icons in the navbar. I can still reproduce if I replace the search box with a few more icons. O_o
Attached patch Patch v.1Splinter Review
Seems to fix the problem for me.

In an earlier version of this patch (which Jared saw) I modified our security UI to also set an attribute on urlbar-container, and had the CSS changes here conditional on that attribute. But then I realized that makes the URL bar changes sizes as you browse different sites, which seems dumb. :/
Assignee: nobody → dolske
Attachment #8387835 - Flags: review?(jaws)
Comment on attachment 8387835 [details] [diff] [review]
Patch v.1

Review of attachment 8387835 [details] [diff] [review]:
-----------------------------------------------------------------

I'll buy that for a dollar.
Attachment #8387835 - Flags: review?(jaws) → review+
https://hg.mozilla.org/integration/fx-team/rev/363beb46bd10
Whiteboard: [Australis:P3+] → [Australis:P3+][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/363beb46bd10
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3+][fixed-in-fx-team] → [Australis:P3+]
Target Milestone: --- → Firefox 30
Verified as fixed on Windows 7 64bit, Mac OS X 10.8.5 and Ubuntu 13.10 64bit using latest Nightly.

I noticed on Mac OS X that if I resize the window enough, the 'Search Bar' is not hidden under 'More Tools...' >> icon. Windows and Ubuntu does not have the same problem. Is this intended behavior?
Status: RESOLVED → VERIFIED
Flags: needinfo?(dolske)
(In reply to Bogdan Maris, QA [:bogdan_maris] from comment #8)
> Verified as fixed on Windows 7 64bit, Mac OS X 10.8.5 and Ubuntu 13.10 64bit
> using latest Nightly.
> 
> I noticed on Mac OS X that if I resize the window enough, the 'Search Bar'
> is not hidden under 'More Tools...' >> icon. Windows and Ubuntu does not
> have the same problem. Is this intended behavior?

No, and I can reproduce this as well. The bookmarks star button is also getting half-overlapped by the chevron and doesn't reliably end up in the overflow menu, either (but does sometimes...).

I don't know why this is, I expect it has to do with sizing of buttons and timing and other sadness. :-(
Should I log a new bug for that or do we reopen this one?
Flags: needinfo?(dolske)
(In reply to Bogdan Maris, QA [:bogdan_maris] from comment #10)
> Should I log a new bug for that or do we reopen this one?

I was going to ask dolske that... generally new bugs are preferred but I don't know if we'd want to consider just backing this out instead. IMO the new issue is worse than the original one, but that might just be me.
Flags: needinfo?(dolske)
From discussion earlier today: new bug please.
Flags: needinfo?(dolske)
(In reply to Justin Dolske [:Dolske] from comment #12)
> From discussion earlier today: new bug please.

Logged bug 983562 on that.
Comment on attachment 8387835 [details] [diff] [review]
Patch v.1

Now that the new bug is fixed, asking for uplift here:

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis / bug 897160 / bug 956260
User impact if declined: small windows cause uncomfortable glitches with search bar / url bar, and the search bar overflows sooner than might be necessary
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): this made bug 983562 more visible, which was fixed by bug 983632 which I'll ask for approval on in the next few minutes
String or IDL/UUID changes made by this patch: none
Attachment #8387835 - Flags: approval-mozilla-aurora?
Attachment #8387835 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Marking as "verified" on firefox 30, based on comment 8.
You need to log in before you can comment on or make changes to this bug.