Closed Bug 981364 Opened 9 years ago Closed 5 years ago

Include Sinhalese Font in Firefox OS

Categories

(Firefox OS Graveyard :: General, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: arky, Unassigned)

References

Details

Attachments

(8 files, 3 obsolete files)

Attached file LKLUG Font
Please include Sinhalese fonts in Firefox OS. Attaching LKLUG fonts with license information.
Attached file copyright information
Blocks: 980681
No longer blocks: 980681
Blocks: 980681
Gerv: can we accept a GPLv2-licensed font for inclusion in Firefox OS?
Flags: needinfo?(gerv)
The license doesn't have the font exception. https://en.wikipedia.org/wiki/GPL_font_exception . Therefore, the FSF at least would suggest there's a risk that some uses of the font would cause the resulting document to be under the GPL.

Is this a "system" font, as in "installed at the OS level" (does B2G have that concept?)? 

Our historical position is that we interpret people licensing fonts solely under the GPL as saying that they only want them to be shipped as part of GPLed software - so not, e.g. with Firefox. Although we've not shipped an OS before, so it depends what we mean by "part of"...

Gerv
Flags: needinfo?(gerv)
(In reply to Gervase Markham [:gerv] from comment #3)

> Is this a "system" font, as in "installed at the OS level" (does B2G have
> that concept?)? 

Yes, in the same sense as the fonts shipped with e.g. an Android device - installed into /system/fonts, and available to all software running on the device.
I'm not sure what to do here. Getting LKLUG to add the font exception, or explain why they chose not to do that, would add some clarity. arky: are you in touch with them?

Otherwise, I'd want a real lawyer to tell us what it means to ship a font under the GPL without the exception. If we go that path, please assign this bug to one :-)

Gerv
(In reply to Gervase Markham [:gerv] from comment #5)
> I'm not sure what to do here. Getting LKLUG to add the font exception, or
> explain why they chose not to do that, would add some clarity. arky: are you
> in touch with them?
> 
Let me check if they could remedy this situation.
(In reply to Gervase Markham [:gerv] from comment #5)
> I'm not sure what to do here. Getting LKLUG to add the font exception, or
> explain why they chose not to do that, would add some clarity. arky: are you
> in touch with them?
> 

Looping in Danishka of our Sri Lankan community. 

Gerv, Can you advise what do we need to ask the font developers.
I'd prefer to handle such communications if possible; history suggests that it's much easier than trying to explain to someone else what needs to be asked. But it all may be moot if all the developers cannot be found. So let's wait to hear what Danishka says or knows about LKLUG and about the origin of this font.

Gerv
Well this is the default Sinhala font ship with all linux distributions but recently ICT Agency of Sri Lanka released Bashitha [1] font but still not available in major distributions.

[1] http://www.siyabas.lk/files/Bhashitha_Linux.zip
Danishka: that file doesn't appear to have any licensing information in it. Do you know if there is information anywhere on the web about the license that Bashitha is under?

Do you have the ability to contact the authors of the LKLUG fonts?

Does anyone know where the official distribution point of those fonts is?

Gerv
The LKLUG font appears to originate at the Sinhala sourceforge project; see http://sinhala.cvs.sourceforge.net/viewvc/sinhala/sinhala/fonts/. However, it hasn't been touched in several years, so I'm not sure how active the authors/maintainers are at present.

The Bhashitha font (and others from various sources -- including Microsoft fonts that are -not- freely licensed) are distributed from the ICT Agency of Sri Lanka site, see http://www.locallanguages.lk/sinhala_unicode_converters (English version of the siyabas.lk site). However, no licensing details are offered, AFAICS.
OK, I think we need to go with plan B in comment 5 - check with a real lawyer.

Jishnu: the question is: "can we ship fonts licensed under the straight GPL with Firefox OS, and use them in the Firefox OS UI, without licensing problems?" Can you assign this to the correct person on the legal team?

Gerv
Flags: needinfo?(jmenon)
(In reply to arky [:arky] from comment #13)
> Created attachment 8400642 [details]
> Sri Bhashitha Font
> 
> SriBhashitha Font for testing 

In the font file itself, the copyright field says:

  © Information and Communication Technology Agency of Sri Lanka.

and the license field says:

  SriBhashitha by ICT Agency of Sri Lanka (ICTA) is licensed under a Creative Commons Attribution 4.0 International License.
  Based on a work at www.icta.lk.
  Ref: http://creativecommons.org/ns
  
Gerv: is this adequate for us to consider using this font?

*However*, regardless of the license offered by ICTA, I am concerned about the provenance of this SriBhashitha font. On inspection it looks very much as though the Latin glyphs included in it have been copied from Times New Roman, and as such it seems likely that it is already in violation of someone else's license.
Well spotted, Jonathan. That's not awesome.

Can we build an alternate version of the font using glyphs from a TNR-metrics-compatible free font? How much work would that be? 

Is it possible to communicate with the actual font authors or with ICTA to ask them about this?

Are we concerned that if this has been done, there's no way to trust the provenance of the Sinhalese characters?

Gerv
Ouch! Thanks for spotting that Jonathan. :(
Attached file Sri Bhashitha Font (Version 21) (obsolete) —
Here is new version of the font without any Latin glyphs. It seems that the 
font developers failed to remove the Times New Roman glyphs after testing.
Attachment #8400642 - Attachment is obsolete: true
Attachment #8403066 - Flags: review?(jfkthame)
Hi arky,

It's great that we got this sorted out :-) What would be even more awesome would be to get the font file you just attached up on the original site, with a clear statement of licensing in the web page. So I hope we can work on that.

But in the mean time, there's no reason I know of we can't go ahead and integrate this font. jkew?

Gerv
Thanks for looking into this, :arky.

There are a couple more issues that I would like to see fixed before we integrate this:

(a) I notice that all the "common" punctuation characters have been stripped out, in addition to the actual Latin letters. That's probably a good thing, as they were most likely copied from Times; but the font really should include standard punctuation marks, etc., that may be used in conjunction with Sinhalese text. (These could be copied from a suitable freely-licensed font.) Even the <space> character is currently missing, which we expect to be present in every font.

(b) The SriBhashitha font is actually a combination of two fonts that it looks like they originally created separately, one for Sinhalese and one Tamil. However, we already have a Tamil font in FirefoxOS (currently, Lohit Tamil), so it would be preferable to have only the Sinhalese part of this font. If we want to add a second Tamil typeface, that should be a separate decision that we consider in its own right - we'd also need to decide which one becomes the default, etc. But let's keep this bug just about adding support for Sinhala.

If the ICTA can be persuaded to deal with these points, that'd be great; alternatively, I guess we could fork the font and do it ourselves, but I'd prefer to avoid that if possible.
Jonathan, Gerv I'll follow this up.
Comment on attachment 8388156 [details]
LKLUG Font

LK LUG is the default one that comes with Linux localized versions. But I think there may be some restrictions with that font licensing.
(In reply to lahiru.lahirumadusanka from comment #21)
> Comment on attachment 8388156 [details]
> LKLUG Font
> 
> LK LUG is the default one that comes with Linux localized versions. But I
> think there may be some restrictions with that font licensing.

If you read the initial comments in this bug, you'll see that the LKLUG font was discussed already. AFAIK, we have not had a firm answer at this point regarding whether we could use it in Firefox OS (see comment 12).
Here is an quick update. I am following up this with various people involved in developing Sinhalese font. They are currently working on addressing the problems raised in this bug. 

Thanks for your patience.
(In reply to Jonathan Kew (:jfkthame) from comment #22)
> (In reply to lahiru.lahirumadusanka from comment #21)
> > Comment on attachment 8388156 [details]
> > LKLUG Font
> > 
> > LK LUG is the default one that comes with Linux localized versions. But I
> > think there may be some restrictions with that font licensing.
> 
> If you read the initial comments in this bug, you'll see that the LKLUG font
> was discussed already. AFAIK, we have not had a firm answer at this point
> regarding whether we could use it in Firefox OS (see comment 12).

Yes. I've read the comments. Just commented to express my idea on using LKLUG. I prefer to create a firefox font for this deploy based on some restriction free font
Comment on attachment 8403066 [details]
Sri Bhashitha Font (Version 21)

Clearing r? for now, awaiting an updated version of the font.
Attachment #8403066 - Flags: review?(jfkthame)
Attached file BhashitaScreen.ttf (obsolete) —
Attaching new Bhashitha font for technical review. Thanks.
Attachment #8403066 - Attachment is obsolete: true
Attachment #8417025 - Flags: review?(jfkthame)
Flags: needinfo?(jmenon)
Comment on attachment 8417025 [details]
BhashitaScreen.ttf

I still have some concerns about the technical aspects of this font; there are issues that I think should be fixed before we ship it in Firefox OS.

Character U+0025 (percent sign) is mapped to a Sinhalese glyph. This is probably not a good idea; if there's a need for a specific "Sinhalese percent sign", it should be encoded in its own right, not substituted for the Latin-script one. But it looks like this glyph is actually a ligated form of a couple of others, anyway, which suggests perhaps it should not be encoded directly at all; it should be accessed via the appropriate character sequence.

Many contextual forms are encoded in the Private Use Area starting at U+E000. These forms should *not* be encoded at all; they should be accessed only through the OpenType layout tables (GSUB features) in the font.

The GSUB and GPOS tables include a language system with the unrecognised tag "zz01", in addition to the expected default language system; and they include numerous features with tags "zz01", "zz02", etc. Why are these present? If they're left over from something like testing individual lookups (e.g. within a font development tool), they should be removed before the font is actually shipped.
Attachment #8417025 - Flags: review?(jfkthame) → review-
Duplicate of this bug: 1008022
Attaching corrected version of Bhashita font. 

Notes from font developer: "Now the same BhashitaScreen.ttf  corrected for
1. % -U0025
2. Removed private unicodes
3. The features removed (just by shipping the font)"
Attachment #8417025 - Attachment is obsolete: true
Attachment #8419954 - Flags: review?(jfkthame)
Gerv: the license field in the BhashitaScreen font file says:

"Bhashita by ICT Agency of Sri Lanka (ICTA) is licenced under a Creative Commons Attribution 4.0 International License."

Is this OK for inclusion in FirefoxOS? How would we handle the "attribution" requirement in this case?
Flags: needinfo?(gerv)
Duplicate of this bug: 1012577
ICTA has developed a standard-based Sinhala font, භාෂිත, which renders correctly and meets the conditions given in SLS 1134 for Level 2 font and Level 3 fonts. The Bhashitha font is given free for use. The Bhashitha font glyphs are aesthetically correct. The rules are free to font developers.
This is a critical issue. Without Sinhala font, we can't read any Sinhala script and/or Translations. Please add one of this fonts to /system/fonts/
(In reply to Gervase Markham [:gerv] from comment #18)
> Hi arky,
> 
> It's great that we got this sorted out :-) What would be even more awesome
> would be to get the font file you just attached up on the original site,
> with a clear statement of licensing in the web page. So I hope we can work
> on that.
> 
> But in the mean time, there's no reason I know of we can't go ahead and
> integrate this font. jkew?
> 
> Gerv

On the FTU language screen came up I scrolled through the list and check it out. I found the language just above Slovenian (https://bug980681.bugzilla.mozilla.org/attachment.cgi?id=8387269) is missing and it's Sinhala.  When I select it, I noticed that button text and other text turns to boxes as well so this must be a missing font problem. Please consider this matter as urgent.
Thanks!
Attached file [PR] add Sinhala font
This PR should add the Bhashita font to moztt, so that we can render Sinhala properly. Untested as yet.

Gerv: <ping> re the question of how we should handle the Attribution requirement of a CC-BY-licensed font for B2G. The PR here puts a brief README into the moztt repository along with the font file, but that won't end up in the product...
Attachment #8425452 - Flags: review?(mwu)
Comment on attachment 8419954 [details]
BhashitaScreen-Corrected.ttf

arky: thanks for following up on this, and getting the newer font versions. With the most recent version, I don't see any critical blocking issues, so we could try including it and see how things go.

I do have a further item of feedback for the font developer: there's a general problem with the construction glyph outlines, in that they use far too many points, and are sometimes rather irregular. It looks to me as though they may have originated as auto-traced outlines from a high-res scan, or perhaps been converted from some other drawing format.

So there's a lot of "cleanup" that could be done to eliminate points and to smooth out minor glitches in the outlines. This will significantly reduce the size of the font, and the glyphs will render more efficiently and cleanly.
Attachment #8419954 - Flags: review?(jfkthame)
To illustrate what I mean about "cleaning up" the glyph outlines, this screenshot shows a glyph from the current .ttf file (left) and a cleaned-up version (right) that eliminates many of the redundant outline points.

(The right-hand version of the outline is still not perfect; a few clearly-redundant points are still present, but FontForge's automatic tools didn't fix them all. So some hand-editing could improve the glyph further, but this is already much improved over the original.)
Comment on attachment 8425452 [details] [review]
[PR] add Sinhala font

I think we need a woff version of the font if you're going to put it in that part of the font list. Alternately put it in the list of uncompressed fonts.
Attachment #8425452 - Flags: review?(mwu)
Duh, of course! I'll add that and re-flag for review shortly.
Comment on attachment 8425452 [details] [review]
[PR] add Sinhala font

Added .woff file to the PR.
Attachment #8425452 - Flags: review?(mwu)
Comment on attachment 8425452 [details] [review]
[PR] add Sinhala font

r-me, though I suspect we should wait for an answer on licensing before merging..
Attachment #8425452 - Flags: review?(mwu) → review+
Thanks, I am going to follow-up with the font developers for updated licensing information.
Good question on the BY requirement.

We should probably put something in the Firefox OS equivalent of about:license. File a licensing bug on me.

Gerv
Flags: needinfo?(gerv)
Depends on: 1015257
Yes, I figured we should do something like that, but don't know how/where it's maintained. Filed bug 1015257.
(In reply to Jonathan Kew (:jfkthame) from comment #30)
> Gerv: the license field in the BhashitaScreen font file says:
> 
> "Bhashita by ICT Agency of Sri Lanka (ICTA) is licenced under a Creative
> Commons Attribution 4.0 International License."
> 
> Is this OK for inclusion in FirefoxOS? How would we handle the "attribution"
> requirement in this case?

Seeing how Creative Commons themselves recommend against using their licenses for software (in our case here font software): http://wiki.creativecommons.org/Frequently_Asked_Questions#Can_I_use_a_Creative_Commons_license_for_software.3F I would strongly recommend using a well-established software license instead like MIT (or better yet OFL).

Using a content license for font software leads to lots of unexpected scenarios that will make things more painful (and not just the unwiedly Attribution requirements compared to other fonts). For the sake of clarity, compabitibility for other fonts and easier maintainership of future font fixes and updates advocating using a software license instead would be much better. 

Thanks for all the great work on this!
I agree that CC-BY is not ideal for fonts, and that the OFL (even though it has a few sub-optimal bits, Nicolas :-), is better. Is a change of license even possible, though? 

If not, I think it's OK to ship this with Firefox OS. The Attribution requirement can be adequately met using the about:license equivalent. (If anyone disagrees with this, do say.)

Gerv
IMHO it's worth interacting with upstream and advocating for a change to their preferred software license. 

This will also make the OpenType code reusable separately under better terms.

I think we have to keep longer-term maintainership in mind and push for compatible terms for all the fonts in FirefoxOS.

Opening the door to CC-licensed fonts and all the possible combinations of CC licenses doesn't sound like such a good idea to me.
Arky: are you in contact with the font developers? Can you arrange a conversation between me and them so I can talk about the OFL (Open Font License)?

Gerv
Arky can you please look into this? Thanks
Flags: needinfo?(hitmanarky)
Gervase,

You meant font developers of Bhashita font?
Danishka: yes, I believe we are considering using Bhashita, and that it's licensed under CC-BY. If so, we want to ask if alternative terms are available. If I've misread this bug, please do tell me.

Gerv
Hi All,

1) I'm one of the LKLUG upstream maintainers. There are a number of problems with the glyphs and we have been trying to replace it with a better FOSS licensed font for many years.

2) Has Mozilla spoken to a legal expert and has there been any indications of a problem shipping a CC-BY licensed font?

3) It took us ~2 years to get Bhashitha to be licensed under a FOSS compatible license. Please do not assume it would be quicker for ICTA to change the license compared to Mozilla getting appropriate legal advice.

4) The Debian project considers Creative Commons Attribution Share-Alike (CC-BY-SA) v4.0 to be compatible with DFSG: https://wiki.debian.org/DFSGLicenses#Creative_Commons_Attribution_Share-Alike_.28CC-BY-SA.29_v4.0

cya,
#
Delphine, Gerv, Danishka: Let's continue the discussion in the original email thread. Some of the stakeholders are not on bugzilla.
Duplicate of this bug: 1040294
We are working with the Sinhalese font developer to resolve the font license issues.
Flags: needinfo?(hitmanarky)
Hi Arky, Just want to confirm, the only action item waiting on ICTA is to state on the ICTA website that it is satisfied with the attribution in a README file?
(In reply to Harshula from comment #56)
> Hi Arky, Just want to confirm, the only action item waiting on ICTA is to
> state on the ICTA website that it is satisfied with the attribution in a
> README file?

Gerv, What's the next step here? Thanks.
Flags: needinfo?(gerv)
We can start integrating the font now, but we need to keep an eye out and make sure the ICTA website and/or the font distribution states their interpretation of the attribution requirement.

We also need to make sure that we distribute a README which meets the requirement.

Gerv
Flags: needinfo?(gerv)
Any update on this?
arky: who are you asking for info from? (I don't see any actions for me here...)

Gerv
(In reply to Gervase Markham [:gerv] from comment #60)
> arky: who are you asking for info from? (I don't see any actions for me
> here...)
>
My bad! This bug has been open for so long that I don't even know whom to ask.  Anyway what is the next steps in resolving this bug. Anyone?.
Comment on attachment 8425452 [details] [review]
[PR] add Sinhala font

Gerv, does this pull request satisfy the license requirements? Can we land it?
Attachment #8425452 - Flags: review?(gerv)
(In reply to Michael Wu [:mwu] from comment #62)
> Gerv, does this pull request satisfy the license requirements? Can we land
> it?

As long as that README gets actually shipped on devices, yes. Although note the line comment I made on the PR.

Gerv
That README is not shipped on device. However, it's part of the font's metadata.

As for the cc license URL, that's the one that comes with the font.
(In reply to Michael Wu [:mwu] from comment #64)
> That README is not shipped on device. However, it's part of the font's
> metadata.

Well, did they say they were OK with a credit in metadata? Looked to me like they wanted a README.
 
> As for the cc license URL, that's the one that comes with the font.

Well that's broken, then :-(

Gerv
Gerv, see bug 1015257. I thought we'd be adding this to whatever the FxOS equivalent of about:license is...
I have this sense of going round in circles. 

What I've asked for, and what I hope the Sri Lankan ICT agency is going to provide, is details on a public web page of what exactly they consider to be the obligations of the attribution requirement. Then we can read them and do them (or decide they are too complicated and look for something else). So when I am asked:

> Gerv, does this pull request satisfy the license requirements?

I should be able to read their web page and use my common sense.

Does that web page exist yet? If not, can whoever is talking to the Sri Lankan ICT agency on our behalf please get them to put it up?

If not a web page, then details in the README which comes with the font would do, at a pinch.

Gerv
I'll try to talk to the Sri Lankan ICT agency again and remind them to put it up. Meanwhile if you can do with the README that would be swell.
Flags: needinfo?(hitmanarky)
Let me put this another way. Where am I supposed to currently look to see their statement about what is acceptable? "Gerv's private email stash" isn't really an acceptable answer.

> Meanwhile if you can do with the README that would be swell.

I don't know what you mean by that. Perhaps you misunderstood my last paragraph in comment 67? I was saying that, at a pinch, it would be OK for the Sri Lankan ICT agency to make their intentions clear in a README, although I'd prefer a public web page.

Gerv
Thanks for clearing that up. Let me see if I can make that happen.
Flags: needinfo?(hitmanarky)
Comment on attachment 8425452 [details] [review]
[PR] add Sinhala font

Please re-request review when we have a clear public statement about the scope of the attribution requirement for this font.

Gerv
Attachment #8425452 - Flags: review?(gerv)
Comment on attachment 8425452 [details] [review]
[PR] add Sinhala font

ICTA team provides the page about BhashitaScreen license information. 

http://www.icta.lk/programmes/pli-development/104-local-languages-initiative-/625-unicode-compliant-local-language-fonts.html?lang=en

Does this meet the attribution requirement?
Attachment #8425452 - Flags: review+ → review?(gerv)
Comment on attachment 8425452 [details] [review]
[PR] add Sinhala font

http://www.icta.lk/programmes/pli-development/104-local-languages-initiative-/625-unicode-compliant-local-language-fonts.html?lang=en documents that they interpret "Attribution" as simply requiring notification if the fonts are changed. We don't plan to change them AFAIK.

We should still have a README in source control by the font with licensing info, but it doesn't have to ship if that's difficult.

Let's get this done :-)

Gerv
Attachment #8425452 - Flags: review?(gerv) → review+
(In reply to Gervase Markham [:gerv] from comment #73)
>
> Let's get this done :-)

Awesome! Thanks Gerv :)
Duplicate of this bug: 1089635
Duplicate of this bug: 1088776
I have tested installing some of the fonts that are already available to download at http://www.locallanguages.lk/sinhala_unicode_converters

Some of the fonts are hard to read. Most suitable font was Malithi web. (On my perspective)
We can't use Malithi Web font due to font license issue but we can request to Bashitha Font developer to make necessary changes in future.
Danishka informed me on this :) So we have this https://github.com/mooniak/nidahas-fm-abhaya under OFL. Is OFL compatible with Mozilla licenses? 

If Abhaya works you can right away add it, Otherwise we will have around 20 good Sinhala released under OFL by this May, we can do a new font that works better with Fira Sans. I have a friend who would work on this.

Where should I start the discussion for a new font design? Im thinking a something similar to attached image work on FF.
OFL is fine.

Gerv
Attached image Homescreen
Sample images of Sinhalese NidahasFM Abhaya font on Firefox OS
Attachment #8571882 - Attachment description: 2015-03-02-15-35-01.png → Homescreen
Another sinhala font is under development by us which will ship under OFL. Development here https://github.com/mooniak/ayanna-narrow. This will support both Sinhala and Tamil and style would better match with Fira Sans. I will post here once it is out.
And Abhaya is going through major refactoring at the moment and will be seeing a new release in next two months. You can keep the GitHub repo as the upstream for this. Is there is a need for specific adjustments just let us know in the issues page.
The Latest release of Abhaya is named Abhaya Libre and can be found here. https://github.com/mooniak/abhaya-libre-font/releases/tag/1.030

What is the next step for adding this font? Send a PR here https://github.com/mozilla-b2g/moztt ?
Hi Pathum - not sure of what next steps are in this particular case. Maybe :timdream can help with this, or at least redirect you? thanks
Flags: needinfo?(timdream)
(In reply to Pathum Egodawatta from comment #84)
> The Latest release of Abhaya is named Abhaya Libre and can be found here.
> https://github.com/mooniak/abhaya-libre-font/releases/tag/1.030
> 
> What is the next step for adding this font? Send a PR here
> https://github.com/mozilla-b2g/moztt ?

Yes - please send a PR. I recommend looking at the current PR as an example to see what needs to be changed.
Flags: needinfo?(timdream)
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.