Closed Bug 983745 Opened 6 years ago Closed 6 years ago

Windows Jumplist favicons are distorted (squished vertically, showing graphical glitch on bottom half)

Categories

(Core :: Widget: Win32, defect)

x86_64
Windows 8.1
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla31
Tracking Status
firefox29 --- unaffected
firefox30 --- fixed
firefox31 --- verified

People

(Reporter: jaws, Assigned: bbondy)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Attached image Screenshot of bug
Just noticed today in the March 14, 2014 Nightly build. See attached image.

The favicon looks to be squished vertically and repeated three times horizontally. The bottom half of the favicon has some negative/inverted looking graphic.
Summary: Windows Jumplist favicons are distored (squished vertically, showing graphical glitch on bottom half) → Windows Jumplist favicons are distorted (squished vertically, showing graphical glitch on bottom half)
QA Contact: netzen
I can reproduce this on my laptop in both Aurora and Nightly but not Beta. 
I *think* only in high DPI as well.
Attached patch Fix - rev1.Splinter Review
Hi Tim,

So the story here is that a long time ago we used EncodeAndScaleImage functionality when encoding of icons was on the main thread, but eventually encoding data was moved off the main thread.  There's no functionality as of right now for encoding a buffer of data which you must pass resized (You can't pass an image container that was created on a diff thread).

So the best thing here is to encode the icon at the same size and let windows resize.
Assignee: nobody → netzen
Attachment #8402154 - Flags: review?(tabraldes)
Attachment #8402154 - Flags: review?(tabraldes) → review+
Blocks: 993302
Is there a side effect that you're particularly concerned about jwatt? I was going to actually request that this be uplifted to aurora and beta.
(I think it happens on beta as well, I just didn't reproduce it there)
Blocks: 870529
I'm not sure what you mean. I've not expressed any concern about this patch in this bug. I've only requested we track for Aurora, which would seem like an indication of support. :)

In bug 993302 I do wonder whether we should perhaps keep the scaling behavior, but I think it's fine to just do that on Trunk, if at all.
Yep sorry, I meant to ask if you had any concern with the me tracking for beta as well, that perhaps you knew about within the blocking bug, but it sounded wrong :)
The patch will be different for beta, but no, I've no concerns about that.
I just noticed that I was thinking a different bug caused the problem than you.
You mentioned in the other bug that it was bug 981430.
I was thinking bug 870529
The fix for bug 870529 landed landed almost a year ago, whereas the fix for bug 981430 landed just less than a month ago.

Jared, do you have any insight into whether this is an old or recent problem? (I'm rebuilding my Windows VM ATM so can't test.)
Flags: needinfo?(jaws)
https://hg.mozilla.org/mozilla-central/rev/cecf52b88021
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
(In reply to Jonathan Watt [:jwatt] from comment #11)
> The fix for bug 870529 landed landed almost a year ago, whereas the fix for
> bug 981430 landed just less than a month ago.
> 
> Jared, do you have any insight into whether this is an old or recent
> problem? (I'm rebuilding my Windows VM ATM so can't test.)

I tried to run a mozregression search for this but I don't see any jumplists in any of the builds that it gave me between 2012-01-01 and 2014-02-09. Maybe we only show jumplists for installed builds instead of unpackaged builds?
Flags: needinfo?(jaws)
I think only installed builds yes.  It has to do with a property set on the icon that sets its app user model id.
Comment on attachment 8402154 [details] [diff] [review]
Fix - rev1.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 870529 or bug 981430
User impact if declined: broken jumplist icons
Testing completed (on m-c, etc.): been on m-c a day or two
Risk to taking this patch (and alternatives if risky): should be low
String or IDL/UUID changes made by this patch: none
Attachment #8402154 - Flags: approval-mozilla-aurora?
Attachment #8402154 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0

Verified on Firefox 31 beta 7, build ID: 20140703154127 using a Microsoft Surface Pro 2 device.
There are no graphic glitches displayed in the favicons anymore.
You need to log in before you can comment on or make changes to this bug.