Closed Bug 98577 Opened 19 years ago Closed 17 years ago

Mail does not open on startup

Categories

(SeaMonkey :: MailNews: Message Display, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 58523
mozilla1.4alpha

People

(Reporter: bobj, Assigned: sspitzer)

References

Details

Attachments

(1 file)

Running commerical 2001090503 on US Win95
U-A: Mozilla/5.0 (Windows; U; Win95; en-US; rv:0.9.3+) Gecko/20010905
Netscape6/6.1b1

I have the pref (Edit|Preferences|Appearance) set to open up Netscape Mail
on start.  Running 6.1RTM, this works.  Running the 9/5 build, only the browser
window opens and I need to manually open Mail.
Is this bug alive? I confirm the same problem on RH Linux 7.2, fresh build
2002040410. I know the problem is there for a long time already. It is not only
about mail and news but about the whole thing. The setting in preferences seems
to be ignored. whatever you select the browser is started. (BTW: you can even
select _nothing_ with current GUI).

As this looks pretty simple to implement we should at least remove this option
in prefs temporarily if it does not work.It's simply a shame...

And the last thing: I do not thing this is a MailNews problem at all, but I have
no sufficient privileges to change it. The same with OS.
I'll have to check the next time I install a new build, but what
I've seen since I filed to original bug, is that often (always?)
when I install a new build, the first time I start up, the mail
window would not open.  But after I quit this first time, from then
on the mail window when I start the browser.
In my case (under linux as above) mail window will not open regardless how many
times you start mozilla after install.
Mozilla 1.0 Seamonkey Build
Linux RedHat 7.2

I have multiple profiles. If I set preferences to "Start Mail & Navigator")
Profile Manager will fire up and start both Mail & Navigator after choosing the
profile.
If I start with "mozilla -P myprofile" only Navigator will start.
Using "mozilla -P myprofile -mail -navigator" only starts Navigator also.
Something has been changed (at least on Linux - BTW perhaps the bug needs an OS
change). On my Linux (RH7.3) mail is opened properly if set in preferences and
mozilla is run from command line (with no options and default profile). The
build is oldish: 2002061108 (Mozilla 1.1a). I have no time currently to test all
combination (with different options, fresh install, several runs, etc), but
suggestion is that it works for me. Can anybody check on their setup?

The key is the "no options", and it doesn't matter which profile.
On hp-ux and linux if any option ( -P profile or -ProfileManager or
-SelectProfile or -height 900) is specified on the command line,
any changes made to Preferences > Appearance > display are ignored.
Following was reported by HP against NS6, but it is Mozilla also:

===============================================================
CR:  JAGae09831
Headline: NS 6 command-line options break user startup preferences
 Added 020222 by SLIVKOFF,CHARLES A

Running Netscape 6 with any of its valid arguments causes the user
startup preferences to be ignored.

In ~/.mozilla/$USER/somename.slt/prefs.js, the following are found:

user_pref("general.startup.aim", false);
user_pref("general.startup.browser", false);
user_pref("general.startup.mail", true);

Starting NS 6 with no options results in the mail window being opened.

Using any other arguments to NS 6, the browser window is displayed.

If "-mail" is passed as $1, then the mail window will display. If it is $2
 (or higher), 2 mail windows are displayed.

This behavior has also been observed using Mozilla 0.9.5 on Red Hat Linux.
===============================================================

Adding myself to the cc list.
I'm seeing slightly different behavior than previously reported.  If both the
arguements "-mail" and "-navigator" are passed, I'm getting the mail window
instead of the navigator window M.J.G. reported.

Also, I have tried directly running the mozilla-bin, instead of the startup
script, this also results in only one window opening.
I have a change in my tree that addresses this bug, I currently have a conflict
with another change so I will add the change to the bug once it is corrected. 
My change has only been tested on HPUX, but should work for all platforms except
Mac, which shouldn't be changed at all from current behavior.

One more thing, the "-navigator" command line option that was mentioned in this
bug, isn't a supported feature in Mozilla.  Which explains why "-mail
-navigator" would only open a mail window.  Since the "-navigator" option is
ignored.
*** Bug 165676 has been marked as a duplicate of this bug. ***
I've added my proposed fix for this bug as an attachment.
accepting.  I'll look at this for 1.2beta.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.2beta
*** Bug 169934 has been marked as a duplicate of this bug. ***
moving out to 1.3 beta
Target Milestone: mozilla1.2beta → mozilla1.3beta
Comment on attachment 97655 [details] [diff] [review]
Proposed fix for bug #98577

you can't hard code the list of apps.
Attachment #97655 - Flags: review-
I believe this is a dupe of bug 58523
OS: Windows 95 → All
Hardware: PC → All
*** Bug 184371 has been marked as a duplicate of this bug. ***
I also strognly believe this is a dupe of bug 58523
sliding out to 1.4 alpha, not a 1.3 blocker
Target Milestone: mozilla1.3beta → mozilla1.4alpha
this is a dupe and it's in the wrong component, IMHO. there is a patch here, but
it doesn't look like it's good, so I'm duping this... hope Seth doesn't mind
(Seth - if you want to fix this command line issue, you can always grab the
other bug :)

*** This bug has been marked as a duplicate of 58523 ***
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.