Closed Bug 985855 Opened 6 years ago Closed 6 years ago

[Keyboard UX update][User Story] Update multi-touch typing behavior

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect, P1)

x86
Gonk (Firefox OS)
defect

Tracking

(feature-b2g:2.1, b2g-v2.1 verified)

VERIFIED FIXED
2.0 S6 (18july)
feature-b2g 2.1
Tracking Status
b2g-v2.1 --- verified

People

(Reporter: bhuang, Assigned: timdream)

References

Details

(Keywords: feature, Whiteboard: [ucid:SystemPlatform56, ft:system-platform][p=3][2.1-feature-qa+])

Attachments

(1 file)

As a user, I want the keyboard to be able to handle multiple touched keys at once, in order to increase typing speed.

Acceptance:
Press and hold on a letter, the hint on the letter should appear.
While pressing the first letter, tap and hold a second letter.  The first letter should be typed in the input field, while the second hint shows up.
Release both keys, the second letter should enters in the input field.

Refer to p.14 of UX spec in bug 983043
Whiteboard: [ucid:SystemPlatform56, 1.5, ft:system-platform]
See bug 983043 for the UX spec update.
Whiteboard: [ucid:SystemPlatform56, 1.5, ft:system-platform] → [ucid:SystemPlatform56, 2.0, ft:system-platform]
Whiteboard: [ucid:SystemPlatform56, 2.0, ft:system-platform] → [ucid:SystemPlatform56, ft:system-platform]
Spec should be https://bug983043.bugzilla.mozilla.org/attachment.cgi?id=8435583#15

I can do this after bug 1025520.
Assignee: nobody → timdream
Depends on: 1025520
I'm pretty sure that the keyboard does currently support multi-touch, at least if you're typing fast enough that the alternative character menus do not appear. This was fixed over a year ago. If it is broken now that is a regression.

It might be that the current implementation is based on the order the keys are released in, not the order they are pressed in.
(In reply to David Flanagan [:djf] from comment #4)
> It might be that the current implementation is based on the order the keys
> are released in, not the order they are pressed in.

Yes, therefore my interpretation of this bug is to simply fix the behavior described above.
Summary: [Keyboard UX update][User Story] Multi touch behavior when typing → [Keyboard UX update][User Story] Update multi-touch typing behavior
Note to myself: talk to UX in person on the spec detail and compare behavior with other platforms.
Also, need to figure out when the feedback should took place.
Confirm with Omega offline on the desired behavior. He reaffirmed that UX would like to change the event process sequence stated. I think I can make this change on top of bug 1029356 and before bug 1035062, in ActiveTargetsManager.
Status: NEW → ASSIGNED
Whiteboard: [ucid:SystemPlatform56, ft:system-platform] → [ucid:SystemPlatform56, ft:system-platform][p=3]
Target Milestone: --- → 2.0 S6 (18july)
This is now ready for review although it's currently on top of bug 1029356.

The patch actually roll back the API implemented in bug 1029356 a bit because I was maintaining a one-to-one relation between presses and active targets, but that has to be broken with the new feature in this bug.
Attachment #8452100 - Flags: review?(rlu)
feature-b2g: --- → 2.1
Keywords: feature
Comment on attachment 8452100 [details] [review]
Github: https://github.com/mozilla-b2g/gaia/pull/21473

Hi Tim,

I did not see any change in apps/keyboard/js/keyboard/alternatives_char_menu_manager.js, but seems the interface of show() function has changed?

Other parts should be ok, but I just want to double confirm, so clear the review flag so I'll get notified.

Thanks.
Attachment #8452100 - Flags: review?(rlu)
Priority: -- → P1
Comment on attachment 8452100 [details] [review]
Github: https://github.com/mozilla-b2g/gaia/pull/21473

It was lost, not sure why. Thanks for catching that.
Attachment #8452100 - Flags: review?(rlu)
Comment on attachment 8452100 [details] [review]
Github: https://github.com/mozilla-b2g/gaia/pull/21473

Then, this looks good to me, r+.
Thank you.
Attachment #8452100 - Flags: review?(rlu) → review+
master: https://github.com/mozilla-b2g/gaia/commit/27f64f0f415a6014c11a13d667d70b13365fe265
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
QA Whiteboard: [COM=SystemPlatform]
Component: Gaia::Keyboard → Gaia::Homescreen
I don't see why this issue concerns the Homescreen. Can you detail the reason Gerry?
Flags: needinfo?(gchang)
Hi Johan,
This is a mis-typing error when updating QA Whiteboard. Change back to Gaia::Keyboard.
Component: Gaia::Homescreen → Gaia::Keyboard
Flags: needinfo?(gchang)
QA Whiteboard: [COM=SystemPlatform] → [COM=SystemPlatform][2.1-feature-qa+]
QA Contact: gchang
QA Whiteboard: [COM=SystemPlatform][2.1-feature-qa+] → [COM=SystemPlatform]
Whiteboard: [ucid:SystemPlatform56, ft:system-platform][p=3] → [ucid:SystemPlatform56, ft:system-platform][p=3][2.1-feature-qa+]
Verified @ 
Gaia      1934a2297ffc0d90424cd9cd3294c4a8c74a7333
Gecko     https://hg.mozilla.org/mozilla-central/rev/18901d4f3edd
BuildID   20140825160203
Version   34.0a1

and the test results is on
https://moztrap.mozilla.org/results/cases/?filter-run=5113
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.