Closed Bug 1025520 Opened 7 years ago Closed 7 years ago

Move touch event handling away from keyboard.js

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

x86
macOS
defect
Not set
normal

Tracking

(feature-b2g:2.1)

RESOLVED FIXED
2.0 S5 (4july)
feature-b2g 2.1

People

(Reporter: timdream, Assigned: timdream)

References

Details

(Whiteboard: [p=5])

Attachments

(2 files)

+++ This bug was initially created as a clone of Bug #1023729 +++

The on* functions (the touch/mouse event listeners) currently lives in keyboard.js as global functions. They should be collected to another module and cover with tests.

After this bug we should be deliver proper fix to bug 1013570 by implementing a queue to handle these events there. See bug 1015541 comment 2 for discussion.

I however not really sure we could do that in this one bug or split that to another dependent bug. A separate patch is probably better in terms of keeping the tree safe (making sure regression is identifiable between builds by QA, for example.)
Assignee: nobody → timdream
Status: NEW → ASSIGNED
Whiteboard: [p=3]
Target Milestone: --- → 2.0 S4 (20june)
Duplicate of this bug: 1027002
Comment on attachment 8442592 [details] [review]
mozilla-b2g:master PR#20724

We should start the review process first.
Attachment #8442592 - Flags: review?(rlu)
So Gu actually found a logic error; here is the test run of updated patch

https://tbpl.mozilla.org/?tree=Gaia-Try&rev=789899901972400b554e364d684dd8dd4311ebb2
BTW, it wasn't caught by manual test because the touch identifiers sent by the test are incremental, while on the actual device it is literally the nth finger on the screen.
Target Milestone: 2.0 S4 (20june) → 2.0 S5 (4july)
Comment on attachment 8442592 [details] [review]
mozilla-b2g:master PR#20724

Sorry for the delay, I have just started to look at this patch.
Comment on attachment 8442592 [details] [review]
mozilla-b2g:master PR#20724

r=me with some comments/nits addressed.
Thank you.
Attachment #8442592 - Flags: review?(rlu) → review+
I will land this bug tomorrow when bug 1023730 finally sits safely in master.
feature-b2g: --- → 2.1
You need to log in before you can comment on or make changes to this bug.