Closed Bug 985892 Opened 6 years ago Closed 2 years ago

Enable UICC Secure Element on Nexus 5

Categories

(Firefox OS Graveyard :: NFC, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(tracking-b2g:backlog)

RESOLVED WONTFIX
2.2 S6 (20feb)
tracking-b2g backlog

People

(Reporter: allstars.chh, Unassigned)

References

Details

Attachments

(4 files, 1 obsolete file)

I manage to enable UICC SE on Nexus 5, however I need to modify libnfc-nci, and update the conf files for NFC.

Will update my patch here, but still need to discuss this as the effort for maintaining libnfc-nci.
Attached file libnfc-brcm.conf
conf file for libnfc-nci
conf file for the NFC chipset on Nexus 5.
With some TODO comments for the TLV.
oh, from halimpl/bcm2079x/hal/hal/nfc_hal_dm_cfg.c
p_nfc_hal_config already has supported UICC0 and UICC1 by default
so I don't even have to modify libnfc-nci

Just updating the conf should be fine.
Attachment #8394052 - Attachment is obsolete: true
blocking-b2g: --- → backlog
Blocks: b2g-nfcd
No longer blocks: b2g-nfc
Duplicate of this bug: 1130944
not actively working on this.
Assignee: allstars.chh → nobody
Assignee: nobody → dlee
QA Whiteboard: [COM=NFC]
Attachment #8561916 - Flags: review?(allstars.chh) → review+
Attachment #8561918 - Flags: review?(allstars.chh) → review+
blocking-b2g: backlog → ---
Assignee: dlee → nobody
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.