Closed Bug 986213 Opened 8 years ago Closed 8 years ago

Schedule (mostly) B2G tests on Mozilla-B2g28-v1.3t

Categories

(Release Engineering :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jgriffin, Assigned: ahal)

References

Details

Attachments

(2 files, 3 obsolete files)

B2G engineering would like the regular set of B2G builds/tests (so this means emulator[-ics] and B2G desktop builds and all their associated tests) scheduled on the Mozilla-B2g28-v1.3t branch, along with linux-only desktop tests (no Windows or OSX).

Ahal mentioned he could likely take this.
Actually releng might need to own this after all since it involves scheduling builds and tests for the first time which happens outside of b2g_config.py. I'll still take a quick look before passing it on though.
I assume this won't change the sheriffing status of this tree.
Attached patch Schedule tests on b2g28_v1_3t (obsolete) — Splinter Review
Attachment #8394979 - Flags: review?
Comment on attachment 8394979 [details] [diff] [review]
Schedule tests on b2g28_v1_3t

Hey Armen, we're trying to get tests running on b2g28_v1_3t. So far I have this patch, but as I learned from bug 973063 scheduling tests for the first time can be more complicated than it first appears.

Looks like I also need to do something like:
https://bugzilla.mozilla.org/page.cgi?id=splinter.html&bug=973063&attachment=8377796

But not even sure what repo that is. I'll poke around some more.
Attachment #8394979 - Attachment is patch: true
Attachment #8394979 - Attachment mime type: message/rfc822 → text/plain
Attachment #8394979 - Flags: review? → review?(armenzg)
Oh, found it:
http://mxr.mozilla.org/build/source/tools/buildfarm/maintenance/production-masters.json

Maybe I don't need to touch it after all. Please let me know if there's anything I need to do other than the attached patch.
Comment on attachment 8394979 [details] [diff] [review]
Schedule tests on b2g28_v1_3t

Yep, this won't schedule new builds.. updated patch coming.
Attachment #8394979 - Flags: review?(armenzg)
Attached patch Schedule tests on b2g28_v1_3t (obsolete) — Splinter Review
I think this is good. But please pay extra careful attention to it since I may have missed something. For the most part I just copied the configs for b2g28_v1_3.
Assignee: nobody → ahalberstadt
Attachment #8394979 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #8394995 - Flags: review?(armenzg)
Also to note, I didn't schedule linux builds (just linux64), localizer builds (whatever those are) or any of the device builds (other than tarako) since I assume we don' care about them. Please let me know if we actually do care about any of those.
Comment on attachment 8394995 [details] [diff] [review]
Schedule tests on b2g28_v1_3t

Review of attachment 8394995 [details] [diff] [review]:
-----------------------------------------------------------------

::: mozilla/config.py
@@ +1961,5 @@
> +BRANCHES['mozilla-b2g28_v1_3t']['enable_l10n'] = False
> +BRANCHES['mozilla-b2g28_v1_3t']['enable_l10n_onchange'] = False
> +BRANCHES['mozilla-b2g28_v1_3t']['l10nNightlyUpdate'] = False
> +BRANCHES['mozilla-b2g28_v1_3t']['l10n_platforms'] = ['linux', 'linux64', 'win32',
> +                                                'macosx64']

Oh, this might cause problems because 'linux', 'win32' and 'macosx64' aren't in 'platforms'. Not sure though, so just calling it out for now.
Attached patch Schedule tests on b2g28_v1_3t (obsolete) — Splinter Review
Unbitrot previous patch
Attachment #8394995 - Attachment is obsolete: true
Attachment #8394995 - Flags: review?(armenzg)
Attachment #8394999 - Flags: review?(armenzg)
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #2)
> I assume this won't change the sheriffing status of this tree.

That's correct; we plan on leaving this tree unsheriffed.
Attached patch add v1_3t testsSplinter Review
Having to modify mozilla/build_localconfig.py was very very unexpected.
I hope I can make time to fix our configs in the next couple of quarters.

I will paste the differing builders.
Attachment #8394999 - Attachment is obsolete: true
Attachment #8394999 - Flags: review?(armenzg)
Attachment #8395882 - Flags: review?(aki)
Attached file differences.txt
Attachment #8395883 - Flags: feedback?(jgriffin)
Attachment #8395883 - Flags: feedback?(aki)
Attachment #8395883 - Flags: feedback?(ahalberstadt)
Comment on attachment 8395883 [details]
differences.txt

This looks like what I'd expect.
Attachment #8395883 - Flags: feedback?(jgriffin) → feedback+
Comment on attachment 8395882 [details] [diff] [review]
add v1_3t tests

This patch is failing test-masters.sh all over.

I think you have to copy+edit this block:
http://hg.mozilla.org/build/buildbot-configs/file/20e53905a90f/mozilla/production_config.py#l132

Possibly these additional two blocks as well:
http://hg.mozilla.org/build/buildbot-configs/file/20e53905a90f/mozilla/preproduction_config.py#l81
http://hg.mozilla.org/build/buildbot-configs/file/20e53905a90f/mozilla/staging_config.py#l109

r=me if you get those in and it passes test-masters.sh.
Attachment #8395882 - Flags: review?(aki) → review+
Comment on attachment 8395883 [details]
differences.txt

I'd love to see the non-eng tarako nightlies, but we can leave that for bug 956631.
Attachment #8395883 - Flags: feedback?(aki) → feedback+
Comment on attachment 8395882 [details] [diff] [review]
add v1_3t tests

Gotta love our configs.

Landed with fix:
https://hg.mozilla.org/build/buildbot-configs/rev/44ae0dc8eda8
Attachment #8395882 - Attachment description: ahal.diff → add v1_3t tests
Attachment #8395882 - Flags: checked-in+
Comment on attachment 8395883 [details]
differences.txt

Yep, looks about right, thanks!
Attachment #8395883 - Flags: feedback?(ahalberstadt) → feedback+
in production
just sanity checking:

should http://mxr.mozilla.org/build/source/buildbot-configs/mozilla/config.py#2043 be pointing at https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t ?

I noticed that in mozilla-tests world we point to 'mozilla-b2g28_v1_3t': http://mxr.mozilla.org/build/source/buildbot-configs/mozilla-tests/config.py#1792

Just wanted to double check that we are not scheduling/polling and cloning the wrong branch. Ignore me if all is well.
Flags: needinfo?(armenzg)
Thanks Jordan.
I landed a typo fix:
https://hg.mozilla.org/build/buildbot-configs/rev/96060de0e6e4
Flags: needinfo?(armenzg)
Depends on: 988424
Depends on: 988425
Patch in c#21 is now live
I'm calling this done.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.