Closed Bug 991460 Opened 6 years ago Closed 6 years ago

[User Story] Adding App to Smart Collection in Vertical Homescreen

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect, P1)

x86
macOS
defect

Tracking

(feature-b2g:2.0, tracking-b2g:backlog, b2g-v2.0 verified, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.0 S4 (20june)
feature-b2g 2.0
tracking-b2g backlog
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: pdol, Assigned: cwiiis)

References

Details

(Keywords: feature, Whiteboard: [ucid:System184, ft:systemsfe, 2.0],[p=4][2.0-flame-test-run-2])

User Story

As a user, I want to be able to add an app to a Smart Collection from my vertical homescreen to match the functionality that I have with the existing homescreen.

Acceptance Criteria:
1. I can add an app to a Smart Collection on my homescreen which causes the Smart Collection to display app when opened.
2. Functionality matches 1.4 functionality to add apps to Smart Collections.
3. Smart Collection app addition interaction and visuals match UX spec.

Attachments

(2 files, 4 obsolete files)

No description provided.
User Story: (updated)
blocking-b2g: --- → backlog
Whiteboard: [ucid:System184], [ft:systemsfe] → [ucid:System184, ft:systemsfe, 2.0]
Whiteboard: [ucid:System184, ft:systemsfe, 2.0] → [ucid:System184, ft:systemsfe, 2.0],[p=4]
feature-b2g: --- → 2.0
Flags: in-moztrap?(jlorenzo)
Priority: -- → P1
Target Milestone: --- → 2.0 S3 (6june)
Target Milestone: 2.0 S3 (6june) → 2.0 S4 (20june)
feature-b2g: 2.0 → 2.1
feature-b2g: 2.1 → 2.0
Blocks: collection-app
No longer blocks: vertical-homescreen
QA Whiteboard: [VH-FL-blocking+][VH-FC-blocking+]
QA Whiteboard: [VH-FL-blocking+][VH-FC-blocking+] → [VH-FL-blocking+][VH-FC-blocking+][QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Whiteboard: [ucid:System184, ft:systemsfe, 2.0],[p=4] → [ucid:System184, ft:systemsfe, 2.0],[p=4][2.0-flame-test-run-2]
QA Whiteboard: [VH-FL-blocking+][VH-FC-blocking+][QAnalyst-Triage?] → [VH-FL-blocking+][VH-FC-blocking+][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
QA Whiteboard: [VH-FL-blocking+][VH-FC-blocking+][QAnalyst-Triage+] → [VH-FL-blocking+][VH-FC-blocking+][QAnalyst-Triage+][lead-review+]
Looking at this.
Status: NEW → ASSIGNED
QA Contact: chrislord.net
Assignee: nobody → chrislord.net
QA Contact: chrislord.net
Things to consider for follow-up:

- Style (we likely want something similar to original home, I just picked any random thing for now)
- Updating icons?
- UX wrt dropping and rearranging (copied intended behaviour from original homescreen)
Attachment #8442968 - Flags: review?(kgrandon)
Comment on attachment 8442968 [details] [review]
Allow adding apps to collections in verticalhome

This looks really good, but I can't quite leave the R+ until we rebase this and get the linters/tests passing. I'm not sure if I will get to this before you wake, but let me know if you need help with anything.
Attachment #8442968 - Flags: review?(kgrandon)
Attached file Rebased PR (obsolete) —
Here's your commit, rebased. Few problems with tests and stuff, investigating now. Ping me if you're around on IRC so we don't duplicate work :)
Hi, 

Here are the "add" to smart collection icons in all screen sizes. Let me know if you need anything else. Cheers
This is the rebased/altered PR + animations that UX wanted.
Attachment #8442968 - Attachment is obsolete: true
Attachment #8443832 - Flags: review?(kgrandon)
Is this pointing to my PR? I think I'd like to land the basic functionality, then follow it up with the polish.
Copy/paste error, sorry - this is rebased on your branch too.
Attachment #8443832 - Attachment is obsolete: true
Attachment #8443832 - Flags: review?(kgrandon)
Attachment #8443838 - Flags: review?(kgrandon)
Comment on attachment 8443838 [details] [review]
Allow adding apps to collections in verticalhome + animation

I would like to play it safe for FL and get the feature in, let's file a new bug for the animation as it's visual polish that is new.

(Normally I would love to take this, but we are running out of time and tryserver is being slow)
Attachment #8443838 - Attachment is obsolete: true
Attachment #8443838 - Flags: review?(kgrandon)
Attached file Pull request
Attachment #8443416 - Attachment is obsolete: true
Attachment #8443839 - Flags: review+
Landed: https://github.com/mozilla-b2g/gaia/commit/7af168d5743b7928ac4fe09f09fff808da51de2e

Chris - let's put the animation polish work into another bug. Thanks.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Comment on attachment 8443839 [details] [review]
Pull request

Needed for the vertical homescreen.
Attachment #8443839 - Flags: approval-gaia-v2.0?(bbajaj)
Attachment #8443839 - Flags: approval-gaia-v2.0?(bbajaj) → approval-gaia-v2.0+
Flags: needinfo?(jlorenzo)
Keywords: verifyme
Blocks: 1028860
Verified with: Certified, hosted, privileged and failed to download apps. Smart Collections cannot be added added into another.

Smart Collections does not load anymore when you add a browser bookmark into it. See bug 1028971 for details.
Status: RESOLVED → VERIFIED
Flags: needinfo?(jlorenzo)
This issue is verified on Flame 2.2 and the Flame 2.1.

Result: Able to add an app to a Smart Collection on the homescreen which causes the Smart Collection to display app when opened. Also a saved browser icon/link on the homescreen can be added to the Smart Collection.

Flame 2.2

Device: Flame 2.2  (319mb)(Kitkat Base)(Shallow Flash)
Build ID: 20141125040209
Gaia: 824a61cccec4c69be9a86ad5cb629a1f61fa142f
Gecko: acde07cb4e4d
Version: 36.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Flame 2.1 

Device: Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141126001202
Gaia: db2e84860f5a7cc334464618c6ea9e92ff82e9dd
Gecko: 211eae88f119
Version: 34.0 (2.1) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [VH-FL-blocking+][VH-FC-blocking+][QAnalyst-Triage+][lead-review+] → [VH-FL-blocking+][VH-FC-blocking+][QAnalyst-Triage?][lead-review+]
Flags: needinfo?(ktucker)
Keywords: verifyme
This issue is also verified on Flame 2.0 

Result: Able to add an app to a Smart Collection on the homescreen which causes the Smart Collection to display app when opened. Also a saved browser icon/link on the homescreen can be added to the Smart Collection.

Flame 2.0

Device: Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash)
Build ID: 20141126000203
Gaia: f9d6e3d83c3922e9399a6c27f5ce4cdd27bdfd05
Gecko: 45112935086f
Version: 32.0 (2.0)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [VH-FL-blocking+][VH-FC-blocking+][QAnalyst-Triage?][lead-review+] → [VH-FL-blocking+][VH-FC-blocking+][QAnalyst-Triage+][lead-review+]
Flags: needinfo?(ktucker)
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.