Closed Bug 991509 Opened 6 years ago Closed 6 years ago

Adding Tamil input method for B2G

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3T+, b2g-v1.3T fixed, b2g-v1.4 fixed, b2g-v2.0 fixed)

RESOLVED FIXED
1.4 S6 (25apr)
blocking-b2g 1.3T+
Tracking Status
b2g-v1.3T --- fixed
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: lchang, Assigned: lchang)

References

Details

Attachments

(5 files, 2 obsolete files)

There is no input method supporting Tamil language now so let's add one for B2G.
Is this one of the languages that we are going to release for?
Flags: needinfo?(styang)
Flags: needinfo?(lchang)
1.3T+, this is one of the target language
blocking-b2g: 1.3T? → 1.3T+
Flags: needinfo?(styang)
Luke, do you mind updating the latest on this? when do you think you can land? Thanks
Before developing this input method, I've studied a lot about the Tamil keyboard layout. Every layouts, however, developed by different guys are all inconsistent so that I can't find a general one.

Since it appears that there is no standard layout of Tamil software keyboard, I'm asking Arvin offline for a layout spec which they already used in other devices and waiting for his response.
Flags: needinfo?(lchang)
hi luke, please visit ftp to get the pac and tools metioned in the email,thanks.
Whiteboard: eta: 4/18
Depends on: 993353
Attached image Tamil Keyboard Screenshot (WIP) (obsolete) —
Hi Arvin,

I've made a WIP version of Tamil Keyboard but I have two questions that need your help.

1. Is it correct that put the "?", "!" and "@" mark on the second panel? (these three marks have already appeared on the default symbol panel when you click "?123" button.)

2. When using English keyboard, we can click "ABC" button on the symbol panel and let us back to the alphabet panel. In Tamil case, however, I have no idea what label the Tamil language users will expect it on this kind of button.
Flags: needinfo?(arvin.zhang)
Hi Luke,

1、It seems ambiguous to place the 'Caps Lock' key in the tamil keyboard for Tamil is not a case-sensitive language as far as i know. So, the keyboard of the WIP version should be modified and the reference version of android is a fairly good example(tamil_keyboard_android_one.png). How do you think?

2、We could adopt a simple icon rather than a certain string to indicate the operation returning to alphabet panel from symbol panel. Please refer to the icon in tamil_keyboard_android_two.png.

please have a check.
Flags: needinfo?(arvin.zhang)
Hi Arvin, I can explain why I use this design in WIP version first.

1. In general, the "Shift" key on the software keyboard panel means not only "uppercase" but also "use the symbol in the upper row". This behavior is the same as using "shift + 1" to input "!" with hardware keyboard. I guess people won't feel ambiguous.

2. In tamil case, I studied lots of implementations and found most of them (including iOS7) also use "shift" key to switch its panel (just like its real hardware keyboard design) [a].

3. The design in attachment 8403958 [details] uses "long press" or "choose from candidate panel" to input the characters shown in the upper row. With this implementation, we need put two symbol in one key. I guess it might be not easy for users to see each symbol clearly especially on a low-resolution screen. (e.g. I personally can't distinguish some symbols in the upper row in attachment 8403958 [details])

Maybe we can discuss offline later.

[a] the implementations of Tamil Software Keyboard with Shift key:
    http://www.branah.com/tamil
    http://www.google.com/inputtools/try/ (need to choose Tamil manually)
    http://imgur.com/ZSBQJmb (iOS 7)
    http://tamil.indiatyping.com/index.php/tamil-keyboard
(In reply to Luke Chang [:lchang] from comment #10)
> Hi Arvin, I can explain why I use this design in WIP version first.
> 
> 1. In general, the "Shift" key on the software keyboard panel means not only
> "uppercase" but also "use the symbol in the upper row". This behavior is the
> same as using "shift + 1" to input "!" with hardware keyboard. I guess
> people won't feel ambiguous.
> 
> 2. In tamil case, I studied lots of implementations and found most of them
> (including iOS7) also use "shift" key to switch its panel (just like its
> real hardware keyboard design) [a].
> 
> 3. The design in attachment 8403958 [details] uses "long press" or "choose
> from candidate panel" to input the characters shown in the upper row. With
> this implementation, we need put two symbol in one key. I guess it might be
> not easy for users to see each symbol clearly especially on a low-resolution
> screen. (e.g. I personally can't distinguish some symbols in the upper row
> in attachment 8403958 [details])
> 
> Maybe we can discuss offline later.
> 
> [a] the implementations of Tamil Software Keyboard with Shift key:
>     http://www.branah.com/tamil
>     http://www.google.com/inputtools/try/ (need to choose Tamil manually)
>     http://imgur.com/ZSBQJmb (iOS 7)
>     http://tamil.indiatyping.com/index.php/tamil-keyboard

Dear Luke,

Sorry to my late reply. After a discussion with our language expert and manager, the final conclusion is to maintain the layout of your WIP version. Please continue the process of development without putting multiple characters in one key.
Attached file Pull Request 18221
Hi Rudy,

This patch is base on the screenshot in attachment 8403859 [details]. Could you please help to review it. Thank you?
Attachment #8405311 - Flags: review?(rlu)
Comment on attachment 8405311 [details] [review]
Pull Request 18221

r+, except for one comment on the size of the key to switch back to basic layout, i.e. this key:
https://github.com/mozilla-b2g/gaia/pull/18221/files#diff-e662478bb984014cfa0fbd02c685badeR6
It seems a little bit too small.

Luke,

Thanks for adding Tamil support.
Attachment #8405311 - Flags: review?(rlu) → review+
Attached image Tamil Screenshot (obsolete) —
Screenshots of the final version base on Noto Sans font.
Attachment #8403859 - Attachment is obsolete: true
Comment on attachment 8406615 [details]
Tamil Screenshot

Hi Arvin, could you help to review this layout? Thanks.
Flags: needinfo?(arvin.zhang)
review OK.

And I really appreciate the effort you all made for this issue.
Flags: needinfo?(arvin.zhang)
Depends on: 987496
Attached image Tamil Screenshot
Thanks for Wilfred's feedback. I changed the label of the toggle button in the symbol panel.
Attachment #8406615 - Attachment is obsolete: true
travis passed:
https://travis-ci.org/mozilla-b2g/gaia/builds/23101238

merged in gaia master:
https://github.com/mozilla-b2g/gaia/commit/631c2bb6c02c52af04459366839460b5f2d2b827
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Copied from bug 987496 comment 33:

"I'm afraid we are going to need a 1.3t specific fix for this. In bug 920431, we landed some changes to keyboard customizations that this patch relies on. Unfortunately, I don't know enough about keyboard layouts to fix this myself. ni?'ing patch author and Rudy Lu to figure out best way forward.

Guys, do we need to uplift bug 920431 in order to land this, or land a customized fix for 1.3t that doesn't need these changes?"
Flags: needinfo?(rlu)
Flags: needinfo?(lchang)
Luke,

As our discussion, please send another patch by directly modifying
shared/resources/keyboard_layouts.json

Thanks.
Flags: needinfo?(rlu)
Rudy, another patch needs your help. Thanks.

Note that this patch depends on the imEngine "india" in bug 987496
Attachment #8408017 - Flags: review?(rlu)
Flags: needinfo?(lchang)
Comment on attachment 8408017 [details] [review]
Pull Request 18405 for v1.3t

r=me as well.
Thanks.
Attachment #8408017 - Flags: review?(rlu) → review+
Hi,

Thanks for enabling/developing the Tamil Keyboard layout for Firefox OS.

But, How come this bug was not brought to Mozilla Tamil Team attention ?

We are here to help.

Mozilla-Tamil Team: https://wiki.mozilla.org/L10n:Teams:ta

Thanks
Arun
Flags: needinfo?(lchang)
Many thanks. We'll definitely need your help if there are any further questions about the Tamil input method. This bug was filed due to partner's request so we looked for partner's feedback first at that time.
Flags: needinfo?(lchang)
Duplicate of this bug: tamil-keyboard
Comment on attachment 8405311 [details] [review]
Pull Request 18221

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Feature request (see bug 987496 comment 42)
[User impact] if declined: There would be no Tamil input support on Dolphin
[Testing completed]: Travis Passed
[Risk to taking this patch] (and alternatives if risky): not at all, since Tamil input method is optional at build time
[String changes made]: none
Attachment #8405311 - Flags: approval-gaia-v1.4?(praghunath)
Attachment #8405311 - Flags: approval-gaia-v1.4?(praghunath) → approval-gaia-v1.4+
Whiteboard: eta: 4/18
Target Milestone: --- → 1.4 S6 (25apr)
Depends on: punjabi-keyboard
No longer depends on: punjabi-keyboard
You need to log in before you can comment on or make changes to this bug.