Closed Bug 987496 Opened 6 years ago Closed 6 years ago

Adding Hindi Input Method for B2G

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

defect
Not set

Tracking

(blocking-b2g:1.3T+, b2g-v1.3T fixed, b2g-v1.4 fixed, b2g-v2.0 fixed)

RESOLVED FIXED
1.4 S5 (11apr)
blocking-b2g 1.3T+
Tracking Status
b2g-v1.3T --- fixed
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: Swarnava, Assigned: lchang)

References

Details

Attachments

(8 files)

Steps to reproduce:

Tried to type in Hindi (hi, indic language).


Actual results:

No Input Method supporting Hindi was found.


Expected results:

I should have had a keyboard supporting Bangla characters popped up!
See Also: → 947686
@karunakar Can you please add a patch for review. 

Recent work Hindi Inscript keyboard form Mozilla Hindi L10N work week: 
https://github.com/geekgod/gaia/blob/master/apps/keyboard/js/layouts/hi.js
pull request - https://github.com/mozilla-b2g/gaia/pull/17484
Attached file PR for Hindi keyboard
Jan, can you take a look at this?
Attachment #8397669 - Flags: review?(janjongboom)
blocking-b2g: --- → 1.3T?
Comment on attachment 8397669 [details] [review]
PR for Hindi keyboard

Hi, thanks for the initial work. There is an autocorrect file referenced that is not included in the commit. Is there any correction file and does it work with Hindi? Autocorrect was made to work for Latin languages. Also the 'imEngine' is set to Latin, which is not correct I think.
Attachment #8397669 - Flags: review?(janjongboom) → review-
triage: 1.3T+ for tarako release needs. Assign to Luke as he's working on it
Assignee: nobody → lchang
blocking-b2g: 1.3T? → 1.3T+
Attached file Pull Request 17845
Hi Rudy,
Could you please help to review this patch? Thanks.

Hi James,
Since we're not Hindi language users, could you find someone who is familiar with Hindi language can help us to verify this input method in layouts, characters, and so on? Thanks a lot.
Attachment #8399930 - Flags: review?(rlu)
Flags: needinfo?(james.zhang)
Attached image Screenshot
A screenshot might be helpful to understand this input method.
(In reply to Luke Chang [:lchang] from comment #6)
> Created attachment 8399932 [details]
> Screenshot
> 
> A screenshot might be helpful to understand this input method.

Looping in Hindi L10N team for feedback
Comment on attachment 8399930 [details] [review]
Pull Request 17845

Hi Luke,

Thanks for the patch.
Generally, it looks good to me, but need your help to do some little tweaks,
 1. It seems some character would be too large to fit in the key block, which might need some CSS tweaks to smaller the font.
    You may borrow buri from me to do the test, which could show the fonts correctly.
 2. We need to add this keyboard layout as one of the default layout for Hindi langugage.
https://github.com/mozilla-b2g/gaia/blob/master/build/config/keyboard-layouts.json
Attachment #8399930 - Flags: review?(rlu)
Comment on attachment 8399932 [details]
Screenshot

Hi Rajesh,

Could you please give some feedback on Luke's work?
Thank you.

Arky,

I think Rajesh is what you intended to consult for feebback, right?
Please correct me if I take anything wrong.
Thank you.
Attachment #8399932 - Flags: feedback?(rajeshkajha)
Flags: needinfo?(hitmanarky)
(In reply to Luke Chang [:lchang] from comment #5)
> Created attachment 8399930 [details] [review]
> Pull Request 17845
> 
> Hi Rudy,
> Could you please help to review this patch? Thanks.
> 
> Hi James,
> Since we're not Hindi language users, could you find someone who is familiar
> with Hindi language can help us to verify this input method in layouts,
> characters, and so on? Thanks a lot.

Arvin, please ask android owner to review it.
Flags: needinfo?(james.zhang) → needinfo?(arvin.zhang)
Comment on attachment 8399932 [details]
Screenshot

Looks fine as for inscript layout. will try it out and give my feedback in a day.
(In reply to Jan Jongboom [:janjongboom] from comment #3)
> Comment on attachment 8397669 [details] [review]
> PR for Hindi keyboard
> 
> Hi, thanks for the initial work. There is an autocorrect file referenced
> that is not included in the commit. Is there any correction file and does it
> work with Hindi? Autocorrect was made to work for Latin languages. Also the
> 'imEngine' is set to Latin, which is not correct I think.

this was actually based on old keyboard so not completed with other files.  Will modify accordingly.
Comment on attachment 8399930 [details] [review]
Pull Request 17845

Hi Rudy,

I've addressed those tweaks so set review back. Thank you.
Attachment #8399930 - Flags: review?(rlu)
Comment on attachment 8399930 [details] [review]
Pull Request 17845

Looks good, r=me.

Luke, thanks for this work.
Attachment #8399930 - Flags: review?(rlu) → review+
Attached image reviewresult.png
pls pay attention to the reviewresult.png which shows the main different of hindi kayboard between the android and ffos.
Flags: needinfo?(arvin.zhang)
Attached file android-hindi.tar.gz
The attachment android-hindi.tar.gz contains four shortscreen matched the ones of ffos-hindi(Screenshot commited by Luke Chang).
Hi Arvin,

Thanks for your feedback. 

The first 6 differences you marked in "reviewresult.png" are most likely caused by font diversity. Could you give me the Unicode of those characters so that I can verify and fix them accordingly?

The "ALT" button is follow our UX design and is consistent with most other input methods in B2G. However, I will address it if "?१२३" and "=\<" are more reasonable to Hindi language users.
Hi Luke,

By the way, please check the glyph of the characters combined with the one contains dotted circle(e.g. the character on the screen after we type 6th character and 1st one of the first line),we need to keep all glyphs justly proportioned.

The Unicode of those characters will be provided as soon as i can.
Hi Luke,

The attachment is the unicode set of characters you need.

Besides, i think the glyph of 0x093c must be modified for the point and the dotted circle almost overlapped together.
HI  ,

Hindi layout seems to be ok .
only things to be corrected is

https://bug987496.bugzilla.mozilla.org/attachment.cgi?id=8401225
As per the suggestion of Chandrakant I am suggesting the use of enhanced Inscript keyboard layout
http://malayalam.kerala.gov.in/images/8/80/Qwerty_enhancedinscriptkeyboardlayout.pdf
(This document contains the information on layouts of all languages)
(In reply to Aniket Deshpande from comment #21)
> As per the suggestion of Chandrakant I am suggesting the use of enhanced
> Inscript keyboard layout

Thanks, Can you file a separate bug to track development of enhanced Inscript keyboard layout.
Flags: needinfo?(hitmanarky)
+1  arky ,

 i would also suggest for a differetn bug for other indic languages for better tracking.
(In reply to helloarvin from comment #19)
> Hi Luke,
> The attachment is the unicode set of characters you need.
> Besides, i think the glyph of 0x093c must be modified for the point and the
> dotted circle almost overlapped together.

Hi Arvin,

I've confirmed that all the unicode are the same as what you provided. That means it's just a font issue. However, fonts are system-level component which depends on what fonts you pre-install in your devices. The screenshot I attached is based on the default Devanagari font in B2G. You may need to install another Devanagari font by yourself to meet your needs.
Whiteboard: eta: 4/11
I've refined my patch and will land it first. I agree with arky on filing another bug for enhanced InScript keyboard layout. Thanks for all your feedback.
(In reply to Luke Chang [:lchang] from comment #24)
> (In reply to helloarvin from comment #19)
> > Hi Luke,
> > The attachment is the unicode set of characters you need.
> > Besides, i think the glyph of 0x093c must be modified for the point and the
> > dotted circle almost overlapped together.
> 
> Hi Arvin,
> 
> I've confirmed that all the unicode are the same as what you provided. That
> means it's just a font issue. However, fonts are system-level component
> which depends on what fonts you pre-install in your devices. The screenshot
> I attached is based on the default Devanagari font in B2G. You may need to
> install another Devanagari font by yourself to meet your needs.

Hi Luke,
  According to the discussion of the kick-off meeting yesterday, i have sent the path of all the ttf files via email, please check it, thanks.
Depends on: 993353
Hi Arvin,

I've filed a bug above for this font changing issue. Let's track there.

Besides, In attachment 8401225 [details], you marked 3 symbols: "²", "³" and "¢". The "¢" sign is also a font issue so we won't fix it at this bug. The remainder seems need to be replaced but I'm not sure which symbols you prefer to replace with.
Status: NEW → ASSIGNED
Flags: needinfo?(arvin.zhang)
Hi Luke,

In my opinion, to spell and display exactly of hindi language should be our major concern currently. As for universal symbols,i would like to retain the unique feature of B2G rather than rigidly layout. The reason for "²" and "³" in attachment 8401225 [details] is that i was a little confused with showing the two numbers in the fourth keyboard, and placing the two number into a pure numeric keyboard may be more better.
Flags: needinfo?(arvin.zhang)
Arvin, thanks for your feedback. The layout will be landed as-is after Noto Sans fonts (bug 993353) are landed.
any update Luke?
Flags: needinfo?(lchang)
Hi James,

The fonts (bug 993353) has been landed yesterday. I'm adjusting the UX accordingly and will land it later today.
Flags: needinfo?(lchang)
travis passed:
https://travis-ci.org/mozilla-b2g/gaia/builds/23006607

merged in gaia master:
https://github.com/mozilla-b2g/gaia/commit/1c51a940abbcdc4a396d6a95c130533fb0d6f3fc
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Blocks: 991509
I'm afraid we are going to need a 1.3t specific fix for this. In bug 920431, we landed some changes to keyboard customizations that this patch relies on. Unfortunately, I don't know enough about keyboard layouts to fix this myself. ni?'ing patch author and Rudy Lu to figure out best way forward.

Guys, do we need to uplift bug 920431 in order to land this, or land a customized fix for 1.3t that doesn't need these changes?
Flags: needinfo?(rlu)
Flags: needinfo?(lchang)
As bug991509 comment20, need a separate patch for v1.3t.
Flags: needinfo?(rlu)
Rudy, could you help review this again? Thanks!
Attachment #8407981 - Flags: review?(rlu)
Flags: needinfo?(lchang)
Comment on attachment 8407981 [details] [review]
Pull Request 18401 for v1.3t

r=me.

Luke, thanks.
Attachment #8407981 - Flags: review?(rlu) → review+
Hindi is missing from v1.4 build, is it necessary for v1.4?
Flags: needinfo?(lchang)
Just my 2 cents: looking at our internal schedule, it seems we should have Hindi input method for 1.4
And I confirm that we don't have it on 1.4
NI :bajaj so she can weigh in here about this
Flags: needinfo?(bbajaj)
Flags: needinfo?(lchang) → needinfo?(arvin.zhang)
Hi Arvin and Wayne,

Per comment 38 and comment 39, do we need Hindi in v1.4?
Flags: needinfo?(wchang)
Hi all,

I think we'd better merge Hindi into v1.4 according to the current requirement on Hindi IME of tarako customers.

Thanks a lot.
Flags: needinfo?(arvin.zhang)
Hi Luke,

Yes please request for 1.4 uplift approval for Hindi and also Tamil.
Please note https://bugzilla.mozilla.org/show_bug.cgi?id=1029934 may need correction/uplift again.
Flags: needinfo?(wchang)
Comment on attachment 8399930 [details] [review]
Pull Request 17845

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Feature request (see comment 41)
[User impact] if declined: There would be no Hindi input support on Dolphin
[Testing completed]: Travis Passed
[Risk to taking this patch] (and alternatives if risky): not at all, since Hindi input method is optional at build time
[String changes made]: none
Attachment #8399930 - Flags: approval-gaia-v1.4?(praghunath)
Attachment #8399930 - Flags: approval-gaia-v1.4?(praghunath) → approval-gaia-v1.4+
Flags: needinfo?(bbajaj)
(In reply to Delphine Lebédel [:delphine - please need info] from comment #39)
> Just my 2 cents: looking at our internal schedule, it seems we should have
> Hindi input method for 1.4
> And I confirm that we don't have it on 1.4
> NI :bajaj so she can weigh in here about this

yes, a+ed the patch. Please make sure to verify on 1.4 once this lands.
v1.4: https://github.com/mozilla-b2g/gaia/commit/5587baf1eab05f5a9b3e5718cff719043b91a5bb
Whiteboard: eta: 4/11
Target Milestone: --- → 1.4 S5 (11apr)
Hi Ryan,

Sorry for backing it out. We've already changed the "keyboard" path in v1.4 so we may need to uplift the patch from master branch (attachment 8399930 [details] [review]) instead of v1.3t branch (attachment 8407981 [details] [review]).

I'll take the further job. Thanks.
Flags: needinfo?(ryanvm)
This v1.4 patch is blocked by bug 1034210. I'll merge it once bug 1034210 is uplifted.
OK, in the future, try to check these things ahead of time :)
Flags: needinfo?(ryanvm)
Sorry, in a brain-dead moment, I merged this PR. I reverted it after realizing the error. Needinfo? me when bug 1034210 has approval and I can take care of landing both. Sorry for the churn :(
Luke, it's probably going to be best if you handle the uplifts on this, bug 1034210, and bug 991509. Thanks!
Flags: needinfo?(lchang)
No problem. I'll take care of these. Thanks.
Flags: needinfo?(lchang)
No longer blocks: punjabi-keyboard
Attachment #8399932 - Flags: feedback?(rajeshkajha) → feedback-
You need to log in before you can comment on or make changes to this bug.