Closed Bug 992404 Opened 10 years ago Closed 10 years ago

Turn off payments for Tarako until we are ready

Categories

(Marketplace Graveyard :: Payments/Refunds, defect, P1)

2014-Q2
x86
macOS
defect

Tracking

(Not tracked)

VERIFIED FIXED
2014-05-13

People

(Reporter: andy+bugzilla, Assigned: kumar)

References

Details

(Whiteboard: [qa+])

Attachments

(2 files)

For various reasons, payments on Tarako aren't going to happen. There will need to be fixes that needs to happen on multiple things. Unfortunately, because I don't think there's anyway to feature detect Tarako and we'll need to user agent sniff this.

Assigning to Kumar because he did this for Android, cc'ing in cvan because he has a phone and knows the user agent string.
This suspense is killing me. cvan, what is it?! http://people.mozilla.com/~kmcmillan/ua.html
Flags: needinfo?(cvan)
Summary: Turn of payments for Tarako until we are ready → Turn off payments for Tarako until we are ready
Blocks: 986187
No longer blocks: tarako-marketplace
I don't have a phone. I kindly gave it to Krupa.

Bug 987450 has changed the UA to be 28.1.

You're welcome =)
Flags: needinfo?(cvan)
Ya, cvan was nice enough to lend it to me. I can help if needed.
Can you tell me what the UA is from a browser on Tarako? You can find it with this URL http://people.mozilla.com/~kmcmillan/ua.html
Flags: needinfo?(krupa.mozbugs)
Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox 28.0
Flags: needinfo?(krupa.mozbugs)
mmm, this is going to be tricky
(In reply to Kumar McMillan [:kumar] (needinfo for quickness) from comment #6)
> mmm, this is going to be tricky

Ping fabrice. Krupa's probably on an out-of-date build.
Priority: -- → P1
On dev as of https://github.com/mozilla/webpay/commit/562710b68c51b3441f829201c92c35a8d600268e

Krupa, can you re-test with the latest Tarako build? If payments aren't disabled, let me know what the UA string is again.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Whiteboard: [qa+]
I can still get to the MT auth screen on my tarako device.

UA: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0
Build Identifier: 2014050614003
Git commit info: 2014-05-06 07:46:22
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
on IRC, krupa sent me the commit info: https://git.mozilla.org/?p=releases/gaia.git;a=commitdiff;h=aef737f4

This is Gaia but on the 1.3t branch which seems like it should have the 28.1 UA. Hmmm.
git commit info screenshot: http://cl.ly/image/3U313V01343l
Attached image platform says 28.png
per screenshot in comment #13, the Platform Version is 28.1 in Settings but the UA string says 28.0 ... o_0
Depends on: 1006831
Depends on: 1006830
No longer depends on: 1006831
Krupa, bug 1006830 landed in the 1.3t branch yesterday so you can probably grab today's build to test with
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Flags: needinfo?(krupa.mozbugs)
Resolution: --- → FIXED
Target Milestone: 2014-04-15 → 2014-05-13
verified fixed. See post-fix screenshot.
Flags: needinfo?(krupa.mozbugs)
Attached image post-fix screenshot
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: