Closed Bug 993518 Opened 6 years ago Closed 6 years ago

[B2G][Tarako]When in a phone call, the proximity sensor does not turn off the screen

Categories

(Firefox OS Graveyard :: Vendcom, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3T+, b2g-v1.3 unaffected, b2g-v1.3T affected)

RESOLVED DUPLICATE of bug 1000523
blocking-b2g 1.3T+
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.3T --- affected

People

(Reporter: astole, Assigned: jason.liu)

References

()

Details

(Whiteboard: [POVB][calibration issue])

Attachments

(1 file)

Attached file logcat
When in a phone call, the proximity sensor doesn't activate and the screen stays on even when the phone is held up to the user's ear

Repro Steps:
1) Update a Tarako to BuildID: 20140408004001
2) Open the dialer app
3) Make a phone call and cover the proximity sensor

Actual:
The proximity sensor does not disable the screen

Expected:
The proximity sensor should disable the screen

1.3 Environmental Variables:
Device: Tarako 1.3 MOZ
BuildID: 20140408004001
Gaia: 643f3e6676cbb89c62708a9f7cbef2edc795a552
Gecko: b850e0f09e61
Version: 28.1
Firmware Version: sp8810

Repro frequency: 3/3, 100%
See attached: logcat, video
This issue does not occur on the Buri v1.3

Environmental Variables:
Device: Buri v1.3 Mozilla RIL
BuildID: 20140408004002
Gaia: 0a7a50129995f080c1df4d807a2334701701e8ed
Gecko: e3fca8c23e1d
Version: 28.0
Firmware Version: V1.2-device.cfg
Something like this not working is a power consumption concern, right? Because we'll consume way too much power during a call unnecessarily if the screen remains on when it shouldn't be.
Flags: needinfo?(nhirata.bugzilla)
(In reply to Jason Smith [:jsmith] from comment #2)
> Something like this not working is a power consumption concern, right?
> Because we'll consume way too much power during a call unnecessarily if the
> screen remains on when it shouldn't be.

John clarified in person that's the motivation for what the proximity sensor does. Which means I'm pretty sure this is going to be a really big problem with power if we're leaving the screen on.
blocking-b2g: --- → 1.3T?
Flags: needinfo?(nhirata.bugzilla)
viral, can you check the log if it's enough. Or should the kernel log be necessary to follow up?
Flags: needinfo?(vwang)
Flags: needinfo?(james.zhang)
Hi James:
 Could you please have p-sensor driver RD to check why there is no any event coming up via "/dev/input/event2"?

It looks like to me P-sensor was requested properly, but no event reported.
Please correct me if anything is wrong.

Thanks!!
Shawn


// Call in progress
04-09 10:20:56.130  2027  2027 D Sensors : taos ---Proximity::TAOS_IOCTL_PROX_ON=== err=0
// Call end
04-09 10:20:56.960  2027  2027 D Sensors : taos ---Proximity::TAOS_IOCTL_PROX_OFF=== err=0


$ adb shell getevent
add device 1: /dev/input/event5
  name:     "light sensor"
add device 2: /dev/input/event4
  name:     "headset-keyboard"
add device 3: /dev/input/event3
  name:     "accelerometer"
add device 4: /dev/input/event0
  name:     "sprd-keypad"
add device 5: /dev/input/event2
  name:     "rohm_proximity"
add device 6: /dev/input/event1
  name:     "ms-msg21xx"
Is comment 5 implying this is a vendor bug?
Component: Gaia → Vendcom
Loop Lianxiang
Assignee: nobody → lianxiang.zhou
Flags: needinfo?(james.zhang) → needinfo?(lianxiang.zhou)
Flags: needinfo?(vwang)
triage: 1.3T+ for broken feature. [POVB]
blocking-b2g: 1.3T? → 1.3T+
Whiteboard: [POVB]
On our lastest version, I test the case, pass.
Maybe we need close enough to make the sensor work well.

The proximity sensor and the light sensor are two in one chip, And the device is "device 1:/dev/input/event5".

We will get the light event when we set "settings->Display->Adjust automatically":
/dev/input/event5: EV_ABS       ABS_MISC             00000033
/dev/input/event5: EV_SYN       SYN_REPORT           00000000

And we will git the proximity event when we make a phone call:
/dev/input/event5: EV_ABS       ABS_DISTANCE         00000000
/dev/input/event5: EV_SYN       SYN_REPORT           00000000
/dev/input/event5: EV_ABS       ABS_DISTANCE         00000001
/dev/input/event5: EV_SYN       SYN_REPORT           00000000

By the way, the "/dev/input/event2" was register by a disable driver for other proximity sensor. We will clean these code later.
Flags: needinfo?(lianxiang.zhou)
You mean we should open light sensor then proximity sensor can work.
Shawn, who's gaia light sensor owner? We should discuss here.
Flags: needinfo?(sku)
Flags: needinfo?(ttsai)
Zhou Liangxiang: Do you mean the fix in kernel is ready? Furthermore, p-sensor calibration is necessary.
Can you give the distance range to activate p-sensor in the phone call?
Can you also paste the commit number and date of the kernel fix, so this issue can be changed to resolve-fix.
Flags: needinfo?(ttsai) → needinfo?(lianxiang.zhou)
Hi James:
 Even light sensor and p-sensor share the same HW chip, there are still two different sensor data will be reported.

light sensor will report "values[0]: Atmospheric pressure in hPa (millibar)"
and
p-sensor will report "values[0]: Proximity sensor distance measured in centimeters"

The two values are not the same, and have different purpose.
We should not mess things up.


[1] http://developer.android.com/reference/android/hardware/SensorEvent.html
Flags: needinfo?(sku)
Whiteboard: [POVB] → [POVB][calibration issue]
This issue also occurs on the Open_C device on the master build.

2.0 Environmental Variables:
Device: Open_C 2.0 MOZ
BuildID: 20140423040203
Gaia: d8904c5af6152f5d647a93a0c31227171ddecd87
Gecko: ac376a4e8174
Version: 31.0a1
Firmware Version: P821A10-ENG_20140410
That is not the same bug as this issue - this is a tarako specific bug. Please file a new bug for this issue.
Flags: needinfo?(astole)
Filed a separate bug for Open_C device per comment 14.

Bug 1000523
Flags: needinfo?(astole)
HiAndrew: do you have another tarako to double check this issue? Tarako proximity sensor has no calibration in factory, so I wonder if this is a specific tarako device issue.
Flags: needinfo?(astole)
We only need confirm light sensor works, our OEM customer will adjust its param. Thanks.
I don't think it's block issue.
We only need confirm light and proximity sensor works, our OEM customer will adjust its param. Thanks.
I don't think it's block issue.
You can discuss with our PM in daily meeting if you have any concern.
Assignee: lianxiang.zhou → jason.liu
Keywords: qawanted
(In reply to thomas tsai from comment #16)
> HiAndrew: do you have another tarako to double check this issue? Tarako
> proximity sensor has no calibration in factory, so I wonder if this is a
> specific tarako device issue.

Turns out the root cause of the problem is a Gaia bug, already present on 1.3. bug 1000523 has a fix.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(astole)
Resolution: --- → DUPLICATE
Duplicate of bug: 1000523
Keywords: qawanted
Flags: needinfo?(lianxiang.zhou)
You need to log in before you can comment on or make changes to this bug.