Closed Bug 994282 Opened 6 years ago Closed 6 years ago

Video playback has a clipped area. Linux.

Categories

(Core :: Audio/Video, defect)

x86_64
Linux
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla31

People

(Reporter: hub, Assigned: mattwoodrow)

References

Details

Attachments

(2 files)

Go to, for example https://air.mozilla.org/webrtc-meet-up-francophone-paris/ using m-c on Linux (no problem with Nightly on Mac)

Play the video. The playback region is clipped.

See screenshot.
The poster image is fine.

Also I don't have Flash.
Also Youtube works fine.
I'm getting this as well (FX Nightly 2014-05-15 / Fedora 20)

I don't see any clipping unless I hover the mouse on and off a page or chrome element that has some kind of css hover attribute.

I have gstreamer preffed off.
I see this too, but on Mac nightly, and the video that is shown is in the top left. Also discovered that it works fine on my secondary monitor, but not on the retina display. HiDPI issue ?
This seems to only happen when the <video> has a border-radius. It looks like we're applying a mask that's offset from the video, by the same offset of the video to the window.
Bisected to:

changeset:   176455:433b95e605bf
user:        Matt Woodrow <mwoodrow@mozilla.com>
date:        Tue Apr 01 12:02:09 2014 +0800
summary:     Bug 989858 - Part 3: Convert BasicImageLayer. r=roc
Flags: needinfo?(matt.woodrow)
Assignee: nobody → matt.woodrow
Attachment #8410699 - Flags: review?(roc)
Flags: needinfo?(matt.woodrow)
(In reply to Nick Thomas [:nthomas] (PTO Apr 17-27 PST) from comment #4)
> I see this too, but on Mac nightly, and the video that is shown is in the
> top left. Also discovered that it works fine on my secondary monitor, but
> not on the retina display. HiDPI issue ?

This suggests that you're not getting hardware acceleration. Did you disable it on purpose?
Comment on attachment 8410699 [details] [diff] [review]
Put transforms in the right order

Review of attachment 8410699 [details] [diff] [review]:
-----------------------------------------------------------------

reftest?
Attachment #8410699 - Flags: review?(roc) → review+
https://hg.mozilla.org/mozilla-central/rev/3be5a3af4e6a
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla31
Depends on: 1005071
(In reply to Matt Woodrow (:mattwoodrow) from comment #8)
> This suggests that you're not getting hardware acceleration. Did you disable
> it on purpose?

Possibly in response to some issue a long time ago, layers.offmainthreadcomposition.enabled was set to false.
Duplicate of this bug: 996093
Reproduced the issue on Nighlty from 2014-04-09.
Verified on Firefox 31 Beta 3 (Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 - BuildID: 20140619131915). 

The video is no longer clipped, but the controls are clipped and flicker when fading away. This is tracked separately in bug 1028237.
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.