Closed Bug 996421 Opened 6 years ago Closed 6 years ago

[B2G] [RIL] [Tarako] assign options to Buf.newParcel() in sendDialRequest() otherwise options.number is missing in the response handler

Categories

(Firefox OS Graveyard :: RIL, defect)

x86_64
Linux
defect
Not set

Tracking

(blocking-b2g:1.3T+, b2g-v1.3T fixed, b2g-v1.4 unaffected, b2g-v2.0 unaffected)

RESOLVED FIXED
1.4 S6 (25apr)
blocking-b2g 1.3T+
Tracking Status
b2g-v1.3T --- fixed
b2g-v1.4 --- unaffected
b2g-v2.0 --- unaffected

People

(Reporter: hsinyi, Assigned: hsinyi)

References

Details

(Whiteboard: [p=2])

Attachments

(2 files, 2 obsolete files)

This is a followup of bug 990467.
(In reply to Hsin-Yi Tsai  [:hsinyi] from comment #0)
> This is a followup of bug 990467.

This issue doesn't exist in m-c because the handling has already been there [1].

[1] http://dxr.mozilla.org/mozilla-central/source/dom/system/gonk/ril_worker.js?from=ril_worker.js&case=true#1502
blocking-b2g: --- → 1.3T?
Summary: [B2G] [RIL] assign options to Buf.newParcel() in sendDialRequest() otherwise options.number is missing in the response handler → [B2G] [RIL] [Tarako] assign options to Buf.newParcel() in sendDialRequest() otherwise options.number is missing in the response handler
Assignee: nobody → htsai
Whiteboard: [p=2]
Target Milestone: --- → 1.4 S6 (25apr)
Attached patch part 1 - fix (obsolete) — Splinter Review
Current test cases cannot capture this issue. I am working on a new case.
triage: this is a blocker for Bug 990003. 1.3T+
blocking-b2g: 1.3T? → 1.3T+
Attached patch part2 - test case (obsolete) — Splinter Review
Without part 1 and considering a case that 1st telephony instance makes out a call. Then, 2nd telephony instance is created after the call was made but modem hasn't notified gecko CLCC. 2nd telephony gets a call from enumeration result while the call number is empty.

Part 1 fixes the issue and this test verifies the fix. However, please note that this case is heavily on timing to be able to capture the existing failure. For example, if 2nd telephony isn't created before CLCC, then a correct call number is gotten. But no matter how, this test shouldn't fail!
Comment on attachment 8406631 [details] [diff] [review]
part 1 - fix

Review of attachment 8406631 [details] [diff] [review]:
-----------------------------------------------------------------

Assign options to Buf.newParcel() in sendDialRequest(), otherwise options.number is missing in the handler of REQUEST_DIAL.
Attachment #8406631 - Flags: review?(vyang)
Comment on attachment 8406756 [details] [diff] [review]
part2 - test case

Review of attachment 8406756 [details] [diff] [review]:
-----------------------------------------------------------------

Hi Vicamo,

Please see comment 5 for explanation. This bug is only for v1.3t. Though I think we should make m-c have this test as well, I am not planning to land this on m-c at this bug. I will file another bug for completing test coverage.
Attachment #8406756 - Flags: review?(vyang)
Comment on attachment 8406631 [details] [diff] [review]
part 1 - fix

Review of attachment 8406631 [details] [diff] [review]:
-----------------------------------------------------------------

r=me
Attachment #8406631 - Flags: review?(vyang) → review+
Attachment #8406756 - Flags: review?(vyang) → review+
Keywords: checkin-needed
correct some nits.
Attachment #8406756 - Attachment is obsolete: true
Duplicate of this bug: 997036
You need to log in before you can comment on or make changes to this bug.