Closed Bug 996960 Opened 6 years ago Closed 6 years ago

Add new RTL languages to locales.nsi - Uyghur ug and Urdu ur

Categories

(Toolkit :: NSIS Installer, defect)

x86_64
Windows 8.1
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla31
Tracking Status
firefox28 --- unaffected
firefox29 + fixed
firefox30 --- fixed
firefox31 --- fixed
firefox-esr24 --- unaffected

People

(Reporter: rstrong, Assigned: rstrong)

References

Details

(Keywords: rtl, Whiteboard: [stubv2=])

Attachments

(1 file)

Attached patch patch rev1Splinter Review
Ehsan, would you mind reviewing this? Thanks!
Assignee: nobody → robert.strong.bugs
Status: NEW → ASSIGNED
Attachment #8407242 - Flags: review?(ehsan)
Attachment #8407242 - Flags: review?(ehsan) → review+
CCing Simon and Pike to keep them in the loop.  We have two places to update when adding a new RTL locale.
Keywords: rtl
Comment on attachment 8407242 [details] [diff] [review]
patch rev1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): This file was missed when adding the Urdu and Uyghur RTL locales.
User impact if declined: Urdu locale will not have a right to left installer or stub installer
Testing completed (on m-c, etc.): tested locally
Risk to taking this patch (and alternatives if risky): Extremely minimal
String or IDL/UUID changes made by this patch: None
Attachment #8407242 - Flags: approval-mozilla-beta?
Attachment #8407242 - Flags: approval-mozilla-aurora?
Blocks: 958577, 680255
Attachment #8407242 - Flags: approval-mozilla-beta?
Attachment #8407242 - Flags: approval-mozilla-beta+
Attachment #8407242 - Flags: approval-mozilla-aurora?
Attachment #8407242 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/ae585238d9a8
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
There are no ug or ur builds for Firefox 31 beta 1-4. 

I've found Aurora 32.0a2 ur builds and the installer (and stub) properly displays from right to left.
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.