Closed Bug 998086 Opened 6 years ago Closed 2 years ago

[B2G][Tarako][Gallery] The X in the upper left corner of the multi-edit screen highlights with a blue box insconsistently.

Categories

(Firefox OS Graveyard :: Gaia::Gallery, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:-, b2g-v1.3 unaffected, b2g-v1.3T affected)

RESOLVED WONTFIX
blocking-b2g -
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.3T --- affected

People

(Reporter: jmitchell, Unassigned)

References

Details

(Whiteboard: [tarako-bug-bash-1.3T])

Attachments

(3 files)

Attached file logcat.txt
Description:
When you enter the gallery there is an icon on the bottom right to enter a multi select / edit tool. When you select that sometimes the X in the upper left corner will highlight with a blue box around it. Selecting a photo will always cause the X to highlight if it was not already. Entering the share menu and backing out will cause the X to reset to not highlighted; then pressing anywhere on the screen will cause it to highlight again.

Repro Steps:
1) Update a Tarako to BuildID: 20140417004002
2) Select Gallery
3) Select Multi Edit
4) Select on the screen (if the X is not highlighted already)
5) Select share
6) Select Cancel
7) Select anywhere on the screen
Actual:
The X gets a blue highlight box around it.
Expected:
The blue highlight will only appear when the user is pressing on the X

1.3T Environmental Variables:
Device: Tarako 1.3T MOZ
BuildID: 20140417004002
Gaia: a8d2d399f2939f4845abaa0df57abab241a2c782
Gecko: d97dad54cb61
Version: 28.1
Firmware Version: SP6821

Repro frequency: 100%
See attached: GalleryX.mp4, logcat.txt, Firewatch_GalleryX.txt

This does NOT occur on the 1.3 Buri
1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140417004003
Gaia: 11d027ec28d8e8f09c76b35661222499e124abc8
Gecko: 69851ef3849c
Version: 28.0
Firmware Version: V1.2-device-cfg
Attached video GalleryX.mp4
Attached file firewatch_GalleryX.txt
Whiteboard: [tarako-bug-bash-1.3T] → [tarako-bug-bash-1.3T]
blocking-b2g: --- → 1.3T?
hi David, do you mind providing some input on this bug? is this a regression? Thanks
Flags: needinfo?(dflanagan)
This seems like a minor polish bug and not a blocker to consider at this point. So removing the nomination.
blocking-b2g: 1.3T? → -
Joe,

I don't know what is going on here. The bug also occurs when you edit an image and then tap one of the buttons at the bottom of the screen. For some reason, though, when Gallery is used for a pick activity, it does not have this problem.  And the bug also affects the Video app, following the same STR as for Gallery.

The gallery and video apps don't take any explicit action to highlight those buttons. It is all done with the building blocks, and those use CSS :active, I think.  There have been a lot of bugs recently involving :active, and I don't really understand any of them.

Note that if you press and hold the power button and select "Enable APZ for Apps" (presumably only an option in engineering builds) then if you kill and restart the gallery (or video) you'll see that the button no longer highlights when you tap on photos. But now it highlights when you scroll.

I'm going to take this as a sign that this is not a gaia bug but something deeper in the stack. I'm not sure what component it should be part of, but it is not specific to Gallery.

Given that this is not just a minor polish bug for one app, I'm requesting a regression window for it, and resetting the 1.3T? flag. If it turns out to be a recent regression then we might want to block on getting it fixed.  If it is something we've been living with in 1.3T all along and have only noticed it now, then it is probably safe to ignore as a non-blocker.
I'm going to take that as a sign that this is not a gaia-level bug.
blocking-b2g: - → 1.3T?
Flags: needinfo?(dflanagan)
QA Contact: jmitchell
Regression window unavailable as this issue occurs in the oldest build we have access to

Environmental Variables:
Device: Tarako 1.3T
BuildID: 20140414111336
Gaia: 23488b1a45221c17e6a32fdd4c9d0fdbdcf2d021
Gecko: 72055108f470
Version: 28.1
Firmware Version: sp6821a-gonk-4.0-5-12
We were seeing the inconsistent highlight issue when tapping buttons on camera too and this bug is tracking it: https://bugzilla.mozilla.org/show_bug.cgi?id=995532
(In reply to David Flanagan [:djf] from comment #5)

> Note that if you press and hold the power button and select "Enable APZ for
> Apps" (presumably only an option in engineering builds) then if you kill and
> restart the gallery (or video) you'll see that the button no longer
> highlights when you tap on photos. But now it highlights when you scroll.

APZC has been switched off.
Just a reminder .
At this stage, only critical bugs are going into 1.3T
blocking-b2g: 1.3T? → -
(In reply to Hema Koka [:hema] from comment #9)
> At this stage, only critical bugs are going into 1.3T

I don't think so.
From https://bugzilla.mozilla.org/show_bug.cgi?id=999352#c15
We know there are at least two apps having this bug. And the bug didn't exist before.

So it's not a simple gaia bug. maybe something is wrong in gecko.
And we need find out the reason before we meet more similar bugs.
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.