Closed Bug 998427 Opened 6 years ago Closed 6 years ago

Don't Ask Again option for Add Application (registerProtocolHandler)

Categories

(Firefox :: File Handling, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 668577

People

(Reporter: gingerbread_man, Unassigned)

Details

This is basically the desktop equivalent of bug 668577.

Yahoo! Mail recently started prompting people to add it as a mailto protocol handler when the inbox is opened. Probably because of bug 513780 and bug 428905. The problem is twofold:

1. People don't understand the prompt. From what I can gather, they think "Add Application" refers to software program, or an add-on.

2. Since they don't click the Add Application button, they get the prompt again each time the inbox is opened. They get annoyed and pin the blame for this on Firefox. So this bug report requests a "Don't Ask Again" option to deal with that.
https://support.mozilla.org/questions/994658
https://support.mozilla.org/questions/994725
https://support.mozilla.org/questions/994965
http://forums.mozillazine.org/viewtopic.php?f=38&t=2819927

3. For Yahoo! specifically, I suggested replacing the defective "Yahoo! Mail" entry currently built into Firefox with the one Yahoo! prompts to add. If the protocol handler entry already exists, users wouldn't get the prompt.
Bug 513780, comment 19
Status: UNCONFIRMED → NEW
Ever confirmed: true
I have this notification too, and it's annoying as hell. Moreover, I clicked to add it (which I didn't want at first to prevent it appearing again)), and now I still got a notification telling me "yahoo app is already added for mailto".
Flags: firefox-backlog+
Just to add more info:

It seems that it is Yahoo! mail (when using FF (28.0) on 2 different XP machines) and does not show up in ie. When I look at Tools|Options|Applications|mailto I have "use Microsoft Outlook (default)" as my default setting - Which is preferred on that computer.

On the other one, I did not check to see what it was before, but I had clicked to use Yahoo! as the default (which is preferred for that computer). The popup status bar is persistent every time you refresh or go to the next mail message on the Outlook machine. Clicking the "x" to get rid of the message is temporary. Clearing the cache/cookies also had no permanent effect. It does not pop up on the Yahoo! preferred machine any more.

I'm thinking that it is an issue with Yahoo! mail rather than FF. But who knows.
Having the "Add Application" button without an alternative "Never show this request again" button is plain IDIOTIC. Why on earth didn't you implement a "Never show THIS request again" option in the first place, you bunch of morons???
oh, and by the way, you should also have a "reset all user answers" somewhere in the "options" settings. Morons.
This problem also occurs with the Comcast email server, and is equally annoying.
I think this is actually be handled by bug 668577 (which seems to be about desktop for me).
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 668577
You need to log in before you can comment on or make changes to this bug.