Closed Bug 37862 (zws) Opened 20 years ago Closed 19 years ago

zero-width space not treated as whitespace character

Categories

(Core :: Layout, defect, P3)

x86
All
defect

Tracking

()

VERIFIED FIXED
Future

People

(Reporter: bugzilla, Assigned: shanjian)

References

()

Details

(Keywords: html4, regression)

Attachments

(2 files)

By §9.1 of the HTML 4.0 spec, zero-width space (​) is a whitespace 
character. It marks word boundaries in languages which do not have spaces 
between words.

Build M15 and nightly build 2000042208 don't layout as if this were so. Mozilla 
does not wrap lines which contain only zero-width spaces.
It does work in Win32 2000042208 after all. Mea culpa.
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
Blocks: robin's
Works for me:
Platform: PC
OS: Windows 98
Mozilla Build: 2000101214 M18 Trunk Build

Marking as Verified.
Status: RESOLVED → VERIFIED
The error appears again in 6.0 PR3 and nightly build 20001012 for 32-bit Windows. Reopening.
Status: VERIFIED → UNCONFIRMED
Keywords: html4
Resolution: WORKSFORME → ---
Attached file Test case
Confirmed on Linux; setting OS to All.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 98 → All
Keywords: correctness
This bug needs a new owner, since troy isn't working on moz any more.
Reassigning to default layout owner.
Assignee: troy → clayton
Changing component to HTML element
Component: Layout → HTML Element
QA Contact: petersen → lorca
changing to buster
Assignee: clayton → buster
erik owns text/word breaking issues
Assignee: buster → erik
Marking this as a regression (which it was), and nominating for Mozilla1.0 as a
polish/conformance issue.
Assignee: erik → shanjian
Target Milestone: --- → Future
This is a bug in our line breaker. We should debug the lwbrk . Reassign to 
shanjian but mark it as Future. 
Status: NEW → ASSIGNED
Attached patch proposed patchSplinter Review
While you're here, shouldn't you add form-feed 0x000C as well?  See
http://www.w3.org/TR/html4/struct/text.html#h-9.1
will do. 0x000C will be appended to white space judge statement.
sr=erik
r=ftang
Reassigning QA Contact for all open and unverified bugs previously under Lorca's
care to Gerardo as per phone conversation this morning.
QA Contact: lorca → gerardok
fix checked in.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago19 years ago
Resolution: --- → FIXED
Works in Win32 nightly 2001013120. Verifying.
Status: RESOLVED → VERIFIED
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout
Alias: zws
You need to log in before you can comment on or make changes to this bug.