show better error message when attempting to print without a default printer installed

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
17 years ago
7 years ago

People

(Reporter: amyy, Unassigned)

Tracking

(Blocks: 1 bug, {useless-UI})

Trunk
Future
useless-UI
Points:
---
Dependency tree / graph
Bug Flags:
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Build: 09-17 Branch build on Mac 9.1-US
       09-14 Branch build on Mac9.1-Japanese

Steps to reproduce:
1. Launch brower.
2. File | Print, or Click the "Printer" icon next to "Search" button.

Actual result:
Nothing happens.

Expect result:
A print dialog will pops-up.

Comment 1

17 years ago
Does this work on N6.1?
Keywords: nsbranch
(Reporter)

Comment 2

17 years ago
I just re-installed my Mac to Mac9.1 recently.  I was using Mac9.0 before which
has no problem.

So there is a little wrong with my previous description:
I have no printer set up, that why it doesn't work.
However, even I haven't had a printer set up with my machine, I should get a
warning/error message dialog tells me about that, not just do nothing instead. 
IE will has a message dialog pops-up.

Change the summary.
Summary: "Print" doesn't work on Mac 9.1 → When there is no printer set up on a Mac9.1 system, "Print" will do nothing
Marking nsbranch-. It should fly a dialog as Yuying Long suggests but this is
not sufficient to mark it nsbranch+.
Keywords: nsbranch → nsbranch-

Comment 4

17 years ago
`The document could not be printed, because no printer is selected. Use the 
Chooser to select a printer, and try again.'
(Reporter)

Comment 5

17 years ago
The problem here is: if I don't have printer seleted, I should get an error
message tells me about that, not just doing nothing.

Comment 6

17 years ago
Is there any way to return |NS_ERROR_GFX_PRINTER_NO_PRINTER_AVAILABLE| to the
underlying code ? If |YES| - then the new print error dialog would catch this
issue and notify the user... :-)

Updated

17 years ago
Target Milestone: --- → mozilla0.9.9

Updated

17 years ago
Target Milestone: mozilla0.9.9 → mozilla1.0.1

Updated

17 years ago
Blocks: 107067

Updated

17 years ago
Keywords: nsbranch-

Updated

17 years ago
Blocks: 103711

Updated

17 years ago
No longer blocks: 107067

Comment 7

17 years ago
Changed summary to correct description.
Summary: When there is no printer set up on a Mac9.1 system, "Print" will do nothing → When there is noWhen a printer is not choosen... an error dialog needs to be brought up

Comment 8

17 years ago
Summary was bogus.

mpt: can you please explain why we should
A. show an error dialog if you do file>print when you have no default printer
instead of
B. show printer setup
or
C. disable file>print
Summary: When there is noWhen a printer is not choosen... an error dialog needs to be brought up → show an error when printing without a default printer

Comment 9

17 years ago
The expected behavior is to do something. Just pop up an error and say "sorry,
can't print," or "sorry, can't print, but would you like to install a printer?"
Either one.

Updated

17 years ago
Blocks: 125824

Comment 10

17 years ago
A. Because that's what every other program does.
B. Because there aren't any printers to set up.
C. Because (if you have a printer connected, but not installed etc) it wouldn't be
   at all obvious why the item was disabled.
Keywords: useless-UI

Updated

16 years ago
Blocks: 146685

Comment 11

16 years ago
I was testing bug 167459 (printing without a selected printer), and I saw a
dialog with the words "show error when no printer selected" or something
similar.  However, due to bug 167459, I crashed immediately. Maybe this is
already solved ?

I haven't found back the error-text in the source-code, so I don't know where
it's coming from. Build 2002122708 on Mac OS 9.2.2.

Updated

16 years ago
No longer blocks: 146685

Comment 12

16 years ago
*** Bug 146685 has been marked as a duplicate of this bug. ***

Comment 13

16 years ago
All/all.
OS: Mac System 9.x → All
Hardware: Macintosh → All
Summary: show an error when printing without a default printer → show an error when attempting to print without a default printer
Is it still a bug ? (sorry, all my PCs have printers)
Target Milestone: mozilla1.0.1 → ---
Is it still a bug ? (sorry, all my PCs have printers)

Comment 16

16 years ago
timeless asked me to test this on Mac OS X.

So I erased all my printers.

In build 2003061008 on Mac OS X (1.5 trunk) if I do File->Print or use the
Toolbar Print Button I get the Print dialog with the legend "No Printer
Selected" for the current Printer.

This would seem to be working fine on OS X. Needs testing on other platforms.

Updated

16 years ago
Priority: -- → P3
Target Milestone: --- → Future

Comment 17

15 years ago
Today's windows build gives "An unknown error occurred while printing." which is
no good. Same on SeaMonkey (browser and mail) and Thunderbird and Firefox. 

Expected on windows: 
"Before you can perform printer-related tasks such as page setup or printing a
document, you need to install a printer. Do you want to install a printer now?"
and launch the print setup wizard if the user selects OK.

Comment 18

15 years ago
*** Bug 230478 has been marked as a duplicate of this bug. ***

Comment 19

14 years ago
yeah when no printer is available on the system there's a error.
shouldn't we fix this for 0.10 or latest for 1.0? --> blocking
Flags: blocking-aviary1.0?

Comment 21

14 years ago
out of time for aviary 1.0 and bumping up against the UI freeze for
localization.  reniminate in the next few days if a patch appears.

Comment 22

14 years ago
shutting down for UI/localization freeze very soon.  This bug has no patch.  If
a patch appears in the next few days there still is chance. 
Flags: blocking-aviary1.0? → blocking-aviary1.0-

Comment 23

13 years ago
*** Bug 225218 has been marked as a duplicate of this bug. ***

Comment 24

13 years ago
fixed by Bug 227283?

Comment 25

13 years ago
*** Bug 174963 has been marked as a duplicate of this bug. ***

Comment 26

13 years ago
(In reply to comment #17)
> Today's windows build gives "An unknown error occurred while printing." which
> is
> no good. Same on SeaMonkey (browser and mail) and Thunderbird and Firefox. 
> 
> Expected on windows: 
> "Before you can perform printer-related tasks such as page setup or printing a
> document, you need to install a printer. Do you want to install a printer now?"
> and launch the print setup wizard if the user selects OK.

Asa, does Bug 227283 meet your expectations from comment 17?  Were you suggesting a check for printers at installation time.

Powlin, Peter, can you state what products you're commenting about and whether 
only Firefox addressed the issue (bug 227283)?
Assignee: dcone → printing
Depends on: 227283
QA Contact: sujay
Summary: show an error when attempting to print without a default printer → show better error message when attempting to print without a default printer installed

Comment 27

13 years ago
Marking WFM. Since Bug 227283 was fixed on 2004-08-25 the message is now 
  "There was a problem printing. No printer could be found."
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.