Closed Bug 1001729 Opened 6 years ago Closed 6 years ago

[B2G][Tarako][Dialer]Calling a number not on the FDN whitelist results in an incorrect message

Categories

(Firefox OS Graveyard :: Vendcom, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3T+, b2g-v1.3 unaffected, b2g-v1.3T affected)

RESOLVED WORKSFORME
blocking-b2g 1.3T+
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.3T --- affected

People

(Reporter: JMercado, Assigned: ming.li)

References

Details

(Keywords: regression, Whiteboard: [tarako-exploratory][POVB])

Attachments

(5 files)

Description:
The user will receive a missed call message when calling a number that is not on the FDN whitelist.  A missed call will also show in the call log.

Repro Steps:
1) Update a Tarako to BuildID: 20140423014003
2) Go to Settings > Call Settings > Enable FDN
3) Open Dialer > Make a call
4) Note the missed call notification and that a missed call is shown in the call log.

Actual:
A missed call notification occurs and a missed call is added to the call log.

Expected:
The user is shown an error indicating that the dialed number is not on the FDN whitelist.

1.3T Environmental Variables:
Device: Tarako 1.3T MOZ
BuildID: 20140423014003
Gaia: 9aa9b04049f0291b124c50e0f9c3ce0e1f547725
Gecko: 5dc3e5ec4178
Version: 28.1
Firmware Version: sp6821

Repro frequency: 100%
See attached: video, logcat, firewatch
This issue does not occur on 1.3 Buri

1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140423024002
Gaia: fb2b8e25e8095a5db49b5eb68c74b49f180605d4
Gecko: da2500909f91
Version: 28.0
Firmware Version: sp6821

The user recieves a message that the number is not a whitelisted number for the FDN.
blocking-b2g: --- → 1.3T?
Definitely a regression, but just to double check:

Can we check to see if this reproduces on trunk?
Keywords: qawanted, regression
Hi Sam,

Modem/rild reports the failCauseCode as 65535 but the expected is 241 (FDN_BLOCKED). Could you please check on the partner side? Thanks.

== log snippet ==
1220 04-28 16:58:52.746 D/RIL     (   95): get Channel ID '1'$
1221 04-28 16:58:52.746 D/AT      (   95): Channel1: AT> AT+CLCC$
1222 04-28 16:58:52.746 D/AT      (   95): Channel1: AT< OK$
1223 04-28 16:58:52.746 D/RILC    (   95): [0122]< GET_CURRENT_CALLS }$
1224 04-28 16:58:52.746 D/RIL     (   95): put Channel ID '1'$
1225 04-28 16:58:52.746 I/RILC    (   95): -->CommandThread [464] free one command$
1226 04-28 16:58:52.746 I/RILC    (   95): enter processCommandsCallback$
1227 04-28 16:58:52.746 I/RILC    (   95): PCC  alloc one command p_record$
1228 04-28 16:58:52.746 D/RILC    (   95): PCB request code 18 token 123$
1229 04-28 16:58:52.746 D/RILC    (   95): [0123]> LAST_CALL_FAIL_CAUSE $
1230 04-28 16:58:52.746 D/RIL     (   95): onRequest: LAST_CALL_FAIL_CAUSE sState=4$
1231 04-28 16:58:52.746 D/RIL     (   95): channel1 state: '0' $
1232 04-28 16:58:52.746 D/RIL     (   95): get Channel ID '1'$
1233 04-28 16:58:52.746 D/RILC    (   95): [0123]< LAST_CALL_FAIL_CAUSE {65535}$
Flags: needinfo?(sam.hua)
triage: 1.3T+, POVB
ni? james
blocking-b2g: 1.3T? → 1.3T+
Flags: needinfo?(james.zhang)
Whiteboard: [tarako-exploratory] → [tarako-exploratory][POVB]
Loop Ming.Li.
Assignee: nobody → ming.li
Flags: needinfo?(james.zhang)
Status: NEW → ASSIGNED
Component: Gaia::Dialer → Vendcom
Look into the log , we got a 'ECEER:241' , but rilc didn't handle this unsolresponse.

D/AT      (   96): Channel1: AT> ATD18621517497;
D/AT      (   96): Channel0: AT< +ECEER: 241
D/AT      (   96): Channel1: AT< +CME ERROR: 21


I remember that on 7710 device we should get a "CEND" msg ,with the fail cause.
i will update the libreference-ril_sp.so to workaround this bug
Now i can get the right fail cause  ,and the FDN blocked tips is showed .
But still there is a missed call message .

NI:htsai, pls help to look into this issue

D/RIL     (   97): requestDial isStkCall = 0
D/AT      (   97): Channel1: AT> ATD18621517497;
D/AT      (   97): Channel0: AT< +ECEER: 241
D/AT      (   97): Channel1: AT< +CME ERROR: 21
D/RILC    (   97): [0074]< DIAL fails by E_GENERIC_FAILURE
D/RIL     (   97): put Channel ID '1'
I/RILC    (   97): -->CommandThread [348] free one command
I/RILC    (   97): enter processCommandsCallback
I/RILC    (   97): PCC  alloc one command p_record
D/RILC    (   97): PCB request code 18 token 75
D/RILC    (   97): [0075]> LAST_CALL_FAIL_CAUSE 
D/RIL     (   97): onRequest: LAST_CALL_FAIL_CAUSE sState=4
D/RIL     (   97): channel1 state: '0' 
D/RIL     (   97): get Channel ID '1'
D/RILC    (   97): [0075]< LAST_CALL_FAIL_CAUSE {241}
Flags: needinfo?(htsai)
Hi Ming,

Has rild been updated already? I can get the updated one? If not ready yet, please provide me a log with gecko ril debugger enabled so that I can check if gecko handles the fail cause correctly. Thank you!
Flags: needinfo?(sam.hua) → needinfo?(ming.li)
Hi htsai , here is the log
Flags: needinfo?(ming.li)
Attachment #8414301 - Attachment mime type: text/x-vhdl → text/plain
Flags: needinfo?(htsai)
(In reply to Ming from comment #12)
> Created attachment 8414301 [details]
> log-success-get-fail-cause
> 
> Hi htsai , here is the log

Thanks for the log.

According to the log, gecko (RadioInterfaceLayer.js) indeed receives the right fail cause. Not sure why Dialer/CallScreen hasn't got the onerror event. Should investigate more. 

Also, the root cause could be the same as Bug 1001357?
See Also: → 1001357
the libreference_ril_sp.so for tarako  has already updated.

Hi htsai , shall we fix this bug or remove the povb flag?
Flags: needinfo?(htsai)
(In reply to Ming from comment #14)
> the libreference_ril_sp.so for tarako  has already updated.
> 
> Hi htsai , shall we fix this bug or remove the povb flag?

Ming, 

Thanks! Let me give it a try. I'll close this bug once I've verified it on the latest build.

In addition to this vendcom bug, there's a shortcoming resulting from rebasing a v1.3t patch. We need to address that to dispatch the right fail cause to gaia, and I am going to file a bug for that.
Flags: needinfo?(htsai)
Depends on: 1003745
(In reply to Hsin-Yi Tsai  [:hsinyi] from comment #15)
> (In reply to Ming from comment #14)
> > the libreference_ril_sp.so for tarako  has already updated.
> > 
> > Hi htsai , shall we fix this bug or remove the povb flag?
> 
> Ming, 
> 
> Thanks! Let me give it a try. I'll close this bug once I've verified it on
> the latest build.
> 
> In addition to this vendcom bug, there's a shortcoming resulting from
> rebasing a v1.3t patch. We need to address that to dispatch the right fail
> cause to gaia, and I am going to file a bug for that.

Ming,

I haven't seen a related change in git repo. Maybe it takes one more day for us to access?
Flags: needinfo?(ming.li)
(In reply to Hsin-Yi Tsai  [:hsinyi] from comment #16)
I'm not sure.Ni:james

commit : 70b4f1563adcc2734970652e77cb121d01c4c1ea
Flags: needinfo?(ming.li) → needinfo?(james.zhang)
Please wait for code auto sync.
Flags: needinfo?(james.zhang)
I can't reproduce this with Today's build. The call immediately ended upon tapping on the call button, and a message appeared explaining the reason (attaching the message screenshot).

Will still test against trunk to fulfill QA Wanted request.

Tested on:
Device: Tarako 1.3T MOZ
BuildID: 20140501014002
Gaia: d26a776beae0070b0032248a2ce482bbe6321a6d
Gecko: e90f4b655511
Version: 28.1
Firmware Version: sp6821a_gonk4.0_4-29
Attached image Buri master (no repro)
Issue is NOT reproducible on today's Buri master build. Attaching a screenshot of the message when attempting to dial a number not on the FDN list.

Tested on:
Device: Buri MOZ
BuildID: 20140501040203
Gaia: 8873166797fecfa65c0afa644d2ebcc7d7cb4ed3
Gecko: b227a707080f
Version: 32.0a1
Firmware Version: v1.2-device.cfg
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.