Dragging link over Personal Toolbar folder should not be restricted to two levels

RESOLVED FIXED

Status

SeaMonkey
Bookmarks & History
P5
normal
RESOLVED FIXED
16 years ago
13 years ago

People

(Reporter: Peter Lairo, Assigned: Pierre Chanial)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.4+) Gecko/20010918

Dragging URL or "grippy" over Personal Toolbar or sidebar bookmarks folder
(including subfolders) should open folders
(Reporter)

Comment 1

16 years ago
This should have been fixed in bug 53707, but since we're being VERY precise
about only fixing what was asked for ... here is another bug. ;)
Keywords: mozilla0.9.5, ui

Comment 2

16 years ago
Yeah, confirmed. Not opening subfolders is a problem. Folders on the PT should 
behave the same as the Bookmarks folder. They should open and allow you to 
place the dragged bookmark. 4xp. All/All.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: 4xp
OS: Windows 98 → All
Hardware: PC → All

Comment 3

16 years ago
The sidebar is a different case, because opening a menu and expanding a tree 
are very different things.  Also, there should be a delay for the tree, but not 
for the menu.  I've split the sidebar case off to bug 101446.

I think it's implicit that dragging the proxy icon should act like dragging a 
link, so I'm removing that from the summary.
Summary: Dragging URL or "grippy" over Personal Toolbar or sidebar bookmarks folder (including subfolders) should open folders → Dragging link over Personal Toolbar folder should open menu
Status: NEW → ASSIGNED
Target Milestone: --- → Future
Paul Chen is now taking Bookmarks bugs. For your convenience, you can filter 
email notifications caused by this by searching for 'ilikegoats'.

Assignee: ben → pchen
Status: ASSIGNED → NEW

Comment 5

16 years ago
Mass move Ben's bugs dumped on me marked future with p5 to get off my untriaged
radar. You can filter out this email by looking for "ironstomachaussie"
Priority: -- → P5

Comment 6

16 years ago
*** Bug 18052 has been marked as a duplicate of this bug. ***

Comment 7

16 years ago
*** Bug 114638 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 8

16 years ago
Adding Dean Tessman since he fixed bug 30861 and might be interested in helping
here. 

Personally, I think this bug is only marginally less important than bug 30861
(Pri=P3, TM=0.9.7) because once you've created a few (1-3) folders in the
personal toolbar, it becomes an (ever growing) primary location for frequently
used bookmarks ;)
Keywords: mozilla0.9.5 → mozilla0.9.7

Comment 9

16 years ago
Also, since the Personal Toolbar can be closed, the Bookmark menu item should
also open when a link is dragged over it.

Probably should be a separate bug.  

Comment 10

16 years ago
Created bug 114962.  See my comments above.

Comment 11

16 years ago
mass reassign of pchen bookmark bugs to ben
Assignee: pchen → ben
Draging a URL to the bookmarks folder on the personal toolbar does expand on w2k
with build 2002-1-20

Comment 13

16 years ago
I think this bug is about folders on the personal toolbar other than the
'bookmarks' folder.  They don't open.

Comment 14

16 years ago
See also bug 118141, should be able to drag bookmarks *from* personal toolbar 
folders.

Comment 15

15 years ago
remove self
Keywords: mozilla0.9.7
(Reporter)

Updated

15 years ago
Keywords: mozilla1.0
Summary: Dragging link over Personal Toolbar folder should open menu → Dragging link over Personal Toolbar folder should open menu (and submenus)
Target Milestone: Future → ---

Comment 16

15 years ago
Build 2002-04-03-03 WinMe
I made a new subfolder and tried to drop a proxy icon in it; the submenu with
Empty appeared but I couldn't drop the bookmark there. Then in Bookmark Manager
I moved the bookmark that got created above the subfolder into the subfolder.
Then I tried to drag another proxy icon into the subfolder and it did not open.
But menus right under "Personal Toolbar Folder" (i.e. represented as top-level
menus on the toolbar) do open fine for me. They do not close automatically,
however... (another bug)

Comment 17

15 years ago
adding self to cc list
(Assignee)

Updated

15 years ago
Blocks: 133604
(Assignee)

Comment 18

15 years ago
taking
Assignee: ben → pierrechanial
Summary: Dragging link over Personal Toolbar folder should open menu (and submenus) → Dragging link over Personal Toolbar folder should not be restricted to two levels
(Assignee)

Updated

15 years ago
Depends on: 139471
(Assignee)

Comment 19

15 years ago
fixed by the checkin of bug 139471
(windows and mac only)
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Assignee)

Comment 20

15 years ago
*** Bug 153594 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.