Join Chat dialog box won't close with Auto-join this Chat Room checked

RESOLVED FIXED in Thunderbird 32.0

Status

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: walts48, Assigned: clokep)

Tracking

30 Branch
Thunderbird 32.0
x86_64
Linux
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird31 fixed)

Details

(Whiteboard: [regression])

Attachments

(3 attachments, 1 obsolete attachment)

Posted file Screenshot (obsolete) —
Sign-on to a chat account
Click Join Chat
Enter a Channel name in the Join Chat dialog box
Place a check mark to enable 'Auto-join this Chat Room'
Click OK

Chat room is joined, but the Join Chat dialog box doesn't close
Posted image auto-join.png
2nd attempt at a visual
Attachment #8424015 - Attachment is obsolete: true
Are there any errors in the error console? Does this only happen when you check "Auto-join this Chat Room"?
Only happens when I check "Auto-Join this Chat Room", otherwise it closes.

No errors in the Error Console.

Thanks for removing my mistake.
Blocks: TB31found
I'm able to reproduce this on Daily.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [regression]
Looks like this needs to port https://hg.mozilla.org/comm-central/rev/ab630c829a4b I'm going to sync im & mail versions of this file.
Assignee: nobody → clokep
Status: NEW → ASSIGNED
Posted patch Patch v1Splinter Review
Porting the focusing of the conversation seemed like too big of a change for this bug, but the current diff is pretty small.
Attachment #8425941 - Flags: review?(aleth)
By the way this is a regression due to bug 920801, commit https://hg.mozilla.org/comm-central/rev/01a788d85004
Blocks: 920801
Attachment #8425941 - Flags: review?(aleth) → review+
Keywords: checkin-needed
Comment on attachment 8425941 [details] [diff] [review]
Patch v1

https://hg.mozilla.org/comm-central/rev/678a0897be2a

[Approval Request Comment]
Regression caused by (bug #): bug 920801 (https://hg.mozilla.org/comm-central/rev/01a788d85004)
User impact if declined: Unable to add chat rooms to the auto-join list from the "Join Chat" menu. Current aurora will be the next version of TB to go to the release channel.
Testing completed (on c-c, etc.): Committed to c-c, I've tested this by hand, we can let it bake on c-c and ask the reporter to ensure the bug is fixed though.
Risk to taking this patch (and alternatives if risky): I see this as pretty low risk, it's porting a change that has been in Instantbird since Oct. 14, 2013 (~7 months).
Attachment #8425941 - Flags: approval-comm-beta?
Attachment #8425941 - Flags: approval-comm-aurora?
Keywords: checkin-needed
Target Milestone: --- → Thunderbird 32.0
Attachment #8425941 - Flags: approval-comm-aurora? → approval-comm-aurora+
Comment on attachment 8425941 [details] [diff] [review]
Patch v1

This landed before the merge, so no need for a separate beta landing.
Attachment #8425941 - Flags: approval-comm-beta?
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.