[B2G][Calendar] Pressing the 'Cancel' button in the 'Remove Local Data' screen does not work.

VERIFIED FIXED in Firefox OS v2.0

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: dgomez, Assigned: mmedeiros)

Tracking

({regression})

unspecified
2.0 S3 (6june)
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v1.4 unaffected, b2g-v2.0 fixed)

Details

(Whiteboard: [2.0-flame-test-run-1])

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
Created attachment 8431055 [details]
Cancel_Error.jpeg

Description:
When a user launches the 'Calendar' app, press the drawer icon in the upper left hand corner of the month view, selects an account, followed by pressing 'Remove local data', and attempts to press the 'Cancel' button on the 'Remove account' screen, the 'Remove account' page will not close.

Repro Steps:
1) Update a Flame to BuildID: 20140529040201
2) Launch 'Calendar' app.
3) In month view, press the drawer icon in the upper left corner.
4) Press the gear icon on the bottom of the drop-down menu.
5) Select an email account.
6) Press 'Remove local data'.
7) Press 'Cancel' on the 'Remove account' page.
8) Observe results.

Actual:
The user will remain on the 'Remove account' page.
Expected:
The user will be taken back to the 'Account' page.

2.0 Environmental Variables:
Device: Flame 2.0
BuildID: 20140529040201
Gaia: 4142df90c71abdc1e3a87cd37dff1a22d5e38b34
Gecko: 1e712b724d17
Version: 32.0a1
Firmware Version: v10G-2
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Repro frequency: 6/6, 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/3713/
See attached: Cancel_Error.jpeg, Video: http://youtu.be/kdJ8ufNzToI
(Reporter)

Comment 1

4 years ago
Attaching video:
http://youtu.be/kdJ8ufNzToI
(Reporter)

Comment 2

4 years ago
Buri 2.0

This issue DOES occur on Buri 2.0

2.0 Environmental Variables:
Device: Buri 2.0 MOZ
BuildID: 20140529040201
Gaia: 4142df90c71abdc1e3a87cd37dff1a22d5e38b34
Gecko: 1e712b724d17
Version: 32.0a1
Firmware Version: v1.2-device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0



Open_C 2.0

This issue DOES occur on Open_C 2.0

2.0 Environmental Variables:
Device: Open_C 2.0
BuildID: 20140529040201
Gaia: 4142df90c71abdc1e3a87cd37dff1a22d5e38b34
Gecko: 1e712b724d17
Version: 32.0a1
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Flame 1.4

This issue DOES NOT occur on Flame 1.4

1.4F Environmental Variables:
Device: Flame 1.4F
BuildID: 20140529000204
Gaia: 7bc1c15c67661a0b8e35f18f15a9d03d1d2cfcd5
Gecko: 2181cac4d0fc
Version: 30.0
Firmware Version: v10G-2
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
(Reporter)

Comment 3

4 years ago
Could not provide logcat due to Bug 1010993.
Obvious blocker since the user doesn't have an ability to cancel a decision to delete an imported calendar.
blocking-b2g: --- → 2.0?
Keywords: regressionwindow-wanted

Updated

4 years ago
QA Contact: jharvey

Comment 5

4 years ago
Mozilla Inbound Regression Window

Last Working
Environmental Variables:
Device: Flame
BuildID: 20140526073014
Gaia: 6a391274cd436f8f0d1fad2db8c6b4805703259c
Gecko: 65fdc525834c
Version: 32.0a1
Firmware Version: v10g-2

First Broken
Environmental Variables:
Device: Flame
BuildID: 20140526103004
Gaia: 6a391274cd436f8f0d1fad2db8c6b4805703259c
Gecko: fdf86352fdb6
Version: 32.0a1
Firmware Version: v10g-2

The gaias are the same so this points to a gecko issue.

Gecko Pushlog: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=65fdc525834c&tochange=fdf86352fdb6
Keywords: regressionwindow-wanted
This needs a logcat - get it off of Open C.
Keywords: qawanted

Comment 7

4 years ago
Created attachment 8431885 [details]
logcat.txt

See attached logcat.txt

Updated

4 years ago
Keywords: qawanted
This looks like the problem:

05-30 17:27:36.329  1097  1097 E GeckoConsole: [JavaScript Error: "TypeError: window.back is not a function" {file: "app://calendar.gaiamobile.org/js/views/modify_account.js" line: 174}]
(In reply to Jason Smith [:jsmith] from comment #8)
> This looks like the problem:
> 
> 05-30 17:27:36.329  1097  1097 E GeckoConsole: [JavaScript Error:
> "TypeError: window.back is not a function" {file:
> "app://calendar.gaiamobile.org/js/views/modify_account.js" line: 174}]

Which implies that bug 789261 caused this regression. But I think this is because calendar needs to update the function call to match the WebIDL bindings in that patch.

Boris - What do need to change here per the IDL change in that patch?
Blocks: 789261
Flags: needinfo?(bzbarsky)
(Assignee)

Comment 10

4 years ago
did a quick search on the calendar app code base and it looks like we call `window.back()` in 3 places:

  js/views/create_account.js|86 col 7| window.back();
  js/views/event_base.js|73 col 7| window.back();
  js/views/modify_account.js|174 col 7| window.back();

if we replace those with `window.history.back()` (standard) they should work properly.
See Also: → bug 1017176, bug 1018351
(In reply to Miller Medeiros [:millermedeiros] from comment #10)
> did a quick search on the calendar app code base and it looks like we call
> `window.back()` in 3 places:
> 
>   js/views/create_account.js|86 col 7| window.back();
>   js/views/event_base.js|73 col 7| window.back();
>   js/views/modify_account.js|174 col 7| window.back();
> 
> if we replace those with `window.history.back()` (standard) they should work
> properly.

Curious - across Gaia, are there any other places where this is used? If so, we should get bugs on file for that.
Flags: needinfo?(bzbarsky)
Yeah, just use window.history.back() instead.  I didn't even think to check Gaia for use of this Gecko-only nonstandard thing, sorry.  :(
blocking-b2g: 2.0? → 2.0+

Updated

4 years ago
See Also: → bug 1018797
Duplicate of this bug: 1018797
(Assignee)

Comment 15

4 years ago
Created attachment 8432927 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/19905

this patch should fix all the back/cancel buttons
Attachment #8432927 - Flags: review?(gaye)
(Assignee)

Updated

4 years ago
Assignee: nobody → mmedeiros
Target Milestone: --- → 2.0 S3 (6june)
(Assignee)

Updated

4 years ago
Blocks: 1019717
(Assignee)

Comment 16

4 years ago
Comment on attachment 8432927 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/19905

decided to submit the patch to the meta bug since that will make it clearer that it fixes multiple bugs at once. sorry for the extra noise.
Attachment #8432927 - Attachment is obsolete: true
Attachment #8432927 - Flags: review?(gaye)
(Assignee)

Comment 17

4 years ago
landed into master: https://github.com/mozilla-b2g/gaia/commit/5fbba20cb5d8d640291c5e4061c1e26c0a6c4743
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
status-b2g-v2.0: affected → fixed
[Environment]
Gaia      8d865839d932bfbd5e157f376f74d8cb12bfdd51
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/1d4046a8cb6c
BuildID   20140610000223
Version   32.0a2
ro.build.version.incremental=94
ro.build.date=Tue May 20 09:29:20 CST 2014

[Result]
Pass
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.