The default bug view has changed. See this FAQ.

Clean up use cases of mozL10n.localize

RESOLVED FIXED

Status

Firefox OS
Gaia::L10n
P3
normal
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: gandalf, Unassigned, Mentored)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first bug])

User Story

Migrate all mozL10n.localize use cases to:

if no l10nArgs: node.setAttribute('data-l10n-id', l10nId);

if l10nArgs: navigator.mozL10n.setAttributes(node, l10nId, l10nArgs);
(Reporter)

Description

3 years ago
Once bug 992473 and bug 994519 are fixed, we should clean up uses of mozL10n.localize

There are 84 uses in gaia apps, and I suspect that most of them should stay, but they may have redundant code (that applies content to node etc.).
(Reporter)

Updated

3 years ago
Depends on: 994519, 992473
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 994519
(Reporter)

Comment 2

3 years ago
we want to split this work into two chunks:

 - add the updated API in bug 994519
 - convert the uses of localize and remove it in this bug.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 3

3 years ago
Marking as good first bug.

All we have to do here is find all uses of mozL10n.localize and replace them with mozL10n.setAttributes.
Mentor: gandalf@aviary.pl
Whiteboard: [good first bug]
Blocks: 999779
Priority: -- → P3
(Reporter)

Updated

3 years ago
Depends on: 1037637
(Reporter)

Updated

3 years ago
Depends on: 1041403
(Reporter)

Updated

3 years ago
Depends on: 1043615
(Reporter)

Updated

3 years ago
User Story: (updated)
(Reporter)

Updated

3 years ago
Depends on: 1047347
(Reporter)

Updated

3 years ago
Depends on: 1052136
I would like to work on this bug! can you assign this to me!
Depends on: 1057795

Updated

3 years ago
Depends on: 1057798
(Reporter)

Updated

3 years ago
Depends on: 1058985
(Reporter)

Updated

3 years ago
Depends on: 1073893
(Reporter)

Updated

3 years ago
Blocks: 1083840
(Reporter)

Comment 5

3 years ago
We're done with mozL10n.localize! Thanks everyone who has helped with patches and reviews :)
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
(Reporter)

Updated

2 years ago
Depends on: 1088364
You need to log in before you can comment on or make changes to this bug.