Closed Bug 1021000 Opened 6 years ago Closed 5 years ago

Notification icon slightly cut off at top left of screen

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
2.0 S4 (20june)
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: marcia, Assigned: kgrandon)

References

Details

(Whiteboard: [systemsfe])

User Story

+++ This bug was initially created as a clone of Bug #1020989 +++

Flame, while running:

Gaia   d2cfef555dabab415085e548ed44c48a99be5c32
SourceStamp 51b428be6213
BuildID 20140605040202
Version 32.0a1

STR:
1. Long press the home screen to invoke the pick activity to change the wallpaper
2. Observe the attached screenshot - the icon for wallpaper is not present.

Attachments

(2 files)

Attached image 2014-06-05-07-49-24.png
Flame, while running:

Gaia   d2cfef555dabab415085e548ed44c48a99be5c32
SourceStamp 51b428be6213
BuildID 20140605040202
Version 32.0a1

STR:
1. Size down the vertical homescreen so that the icons are smaller.
2. Observe the attached screenshot.

Expected: The notifications icon in the upper left hand corner would not be chopped off.
Component: Gaia::Homescreen → Gaia::System
Duplicate of this bug: 1021330
I don't think I'd call this is a regression since this is caused by enabling of the vertical homescreen.
Is it caused for vertical homescreen? I don't think so honestly, the vertical homescreen is rendered in the same place than old homescreen. And this place is completely independent from statusbar. 

(In reply to Jason Smith [:jsmith] from comment #2)
> I don't think I'd call this is a regression since this is caused by enabling
> of the vertical homescreen.
Duplicate of this bug: 1021455
QA Whiteboard: [VH-FL-blocking-]
Duplicate of this bug: 1021806
Duplicate of this bug: 1022426
Blocks: 1015336
No longer blocks: vertical-homescreen
The partners might not certify our product with that kind of bug.
QA Whiteboard: [VH-FL-blocking-] → [VH-FL-blocking-][VH-FC-blocking+]
Talked with jsmith. Partners won't block certification. Hence, this is not a blocker of Feature Complete.
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking+] → [VH-FL-blocking-][VH-FC-blocking-]
Duplicate of this bug: 1023563
Attached file Github pull request
Hey guys - I'm really not sure where this regressed, but I was wondering if either of you guys had time to review this. Thanks!
Attachment #8438858 - Flags: review?(timdream)
Attachment #8438858 - Flags: review?(etienne)
Suppose I will assign to myself, but someone can steal if my patch is terrible.
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Comment on attachment 8438858 [details] [review]
Github pull request

This bug is so trivial and the number of comments in the bug is really disproportional.
Attachment #8438858 - Flags: review?(timdream) → review+
Comment on attachment 8438858 [details] [review]
Github pull request

Thanks Tim..
Attachment #8438858 - Flags: review?(etienne)
https://github.com/mozilla-b2g/gaia/commit/1ffc834e5ced4eadf8bf0b603c8a052ec85e9a37
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8438858 [details] [review]
Github pull request

This is needed for the vertical homescreen. We've put forward a best effort to believe that this is safe for uplift and the tree will remain green.
Attachment #8438858 - Flags: approval-gaia-v2.0?(bbajaj)
Attachment #8438858 - Flags: approval-gaia-v2.0?(bbajaj) → approval-gaia-v2.0+
Verified on master. Notification icon is full again.
Status: RESOLVED → VERIFIED
Whiteboard: [systemsfe]
You need to log in before you can comment on or make changes to this bug.