ril.ecclist is an empty string after boot-up

VERIFIED FIXED in Firefox 33, Firefox OS v1.4

Status

Firefox OS
RIL
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: brg, Assigned: hsinyi)

Tracking

(Blocks: 1 bug)

unspecified
2.0 S5 (4july)
All
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:1.4+, firefox31 wontfix, firefox32 wontfix, firefox33 fixed, b2g-v1.4 fixed, b2g-v2.0 wontfix, b2g-v2.1 fixed)

Details

(Whiteboard: [perf-reviewed])

Attachments

(13 attachments, 6 obsolete attachments)

90.70 KB, patch
Details | Diff | Splinter Review
5.08 KB, patch
aknow
: review+
Details | Diff | Splinter Review
1.22 KB, patch
aknow
: review+
Details | Diff | Splinter Review
9.49 MB, video/mp4
Details
15.35 KB, patch
Details | Diff | Splinter Review
97.59 KB, patch
Details | Diff | Splinter Review
15.65 KB, patch
Details | Diff | Splinter Review
9.86 KB, patch
Details | Diff | Splinter Review
1.28 KB, patch
Details | Diff | Splinter Review
89.26 KB, patch
Details | Diff | Splinter Review
15.40 KB, patch
Details | Diff | Splinter Review
4.99 KB, patch
Details | Diff | Splinter Review
1.28 KB, patch
Details | Diff | Splinter Review
(Reporter)

Description

4 years ago
Not sure if the bug is to Gaia or Gecko.
Trying to make an emergency call without SIM card the emergency call is not done while it must be done.
The list of numbers that should be allow to make the emergency call without SIM card is: 
112, 911, 08, 000, 110, 118, 119, 999. 

STR:
Open dialer
Type 08 (or any other emergency number)
Press call key
Emergency call is not done

I have easily reproduce the bug with:
Hamachi - 2.0 Gecko: 1a316f5 - Gaia: deed49c
with 
[ril.ecclist]: [911,112,000,08,110,999,118,119]

Flame - 2.0 Gecko: a39cee4 - Gaia: 26d8fca
with: 
[ril.ecclist1]: [911,112,000,08,110,999,118,119]
[ril.ecclist]: [911,112,000,08,110,999,118,119]

Tested in 1.3 with hamachi:Gecko-a480d81.Gaia-e74f208 --> All the emergency calls are performed.
This is a blocker in certification.
similar to Bug 1005823 ?

Updated

4 years ago
Whiteboard: [perf-reviewed]

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+
Keywords: regression
NI :brg to confirm if this still happens post landing of fixes in https://bugzilla.mozilla.org/show_bug.cgi?id=1005823
Flags: needinfo?(brg)

Comment 3

4 years ago
Hi,
With hamachi 2.0 (06/16) build:
Gecko-3bfc06b
Gaia-5e14503

The bug is still reproducible, when calling to 08 with a device without SIM, it is shown: 'No network connection...' message instead of starting the emergency call.
Flags: needinfo?(brg)
I was hoping this could be a dup of bug 1005823 but according to comment 2 it isnt?

Anthony do you mind finding someone to take a look?

Thanks!
Flags: needinfo?(anthony)
(Assignee)

Comment 5

4 years ago
(In reply to Francisco Jordano [:arcturus] [:francisco] from comment #4)
> I was hoping this could be a dup of bug 1005823 but according to comment 2
> it isnt?
> 
> Anthony do you mind finding someone to take a look?
> 
> Thanks!

Hi Francisco, the root cause is different.

Hmmm... it seems a timing issue. Gecko tries to get ril.ecclist right after reboot. However, the property result is an empty string. If gecko queries the property later, gecko gets the right configuration. Not sure if it's gecko or vendor issue. Investigating...

    === log snippet ===
    06-18 02:54:57.560 I/Gecko   (  135): -*- RadioInterfaceLayer: XXX ril.ecclist: ""
    06-18 02:54:57.560 I/Gecko   (  135): -*- RadioInterfaceLayer: XXX ro.ril.ecclist: ""
    06-18 02:54:57.560 I/Gecko   (  135): -*- RadioInterfaceLayer: XXX rilEmergencyNumbers: ""
    06-18 02:55:09.009 I/GeckoDump(  135): XXX FIXME : Got a mozContentEvent: system-message-listener-ready
    06-18 02:55:16.129 I/GeckoDump(  135): XXX FIXME : Got a mozContentEvent: inputmethod-update-layouts
    06-18 02:55:16.139 I/GeckoDump(  135): XXX FIXME : Got a mozContentEvent: inputmethod-update-layouts
    06-18 02:55:17.189 I/GeckoDump(  135): XXX FIXME : Got a mozContentEvent: force-update-check
    06-18 02:55:40.159 I/Gecko   (  135): -*- RadioInterfaceLayer: XXX dial - ril.ecclist: "911,112,000,08,110,999,118,119"
    06-18 02:55:40.159 I/Gecko   (  135): -*- RadioInterfaceLayer: XXX dial - ro.ril.ecclist: ""
    06-18 02:55:40.159 I/Gecko   (  135): RIL Worker: XXX RIL_EMERGENCY_NUMBERS: ""
    06-18 02:55:40.159 I/Gecko   (  135): RIL Worker: XXX DEFAULT_EMERGENCY_NUMBERS: ["112","911"]
Flags: needinfo?(anthony)
(Assignee)

Updated

4 years ago
Summary: Emergency calls without SIM card are not perforemd → ril.ecclist is an empty string after boot-up
(Assignee)

Updated

4 years ago
See Also: → bug 1016853
(Assignee)

Comment 6

4 years ago
Referring to AOSP, to avoid this timing issue, we should consider get_property per each dial request.
Component: Gaia::Dialer → RIL

Comment 7

4 years ago
ril.ecclist may be changed due to different circumstances (ie: sim present/absent, different regions etc...). it is better to check every time before dial request.
(Assignee)

Comment 8

4 years ago
(In reply to shawn ku [:sku] from comment #7)
> ril.ecclist may be changed due to different circumstances (ie: sim
> present/absent, different regions etc...). it is better to check every time
> before dial request.

Thanks for the input. That's what I am going to do :)
(Assignee)

Updated

4 years ago
Assignee: nobody → htsai
Thanks Hsin-Yi for the investigation and taking care of this.
(Assignee)

Updated

4 years ago
Target Milestone: --- → 2.0 S5 (4july)
(Assignee)

Updated

4 years ago
Whiteboard: [perf-reviewed] → [perf-reviewed][ETA:6/27]
(Assignee)

Updated

4 years ago
Blocks: 959978
(Assignee)

Comment 11

4 years ago
Created attachment 8445087 [details] [diff] [review]
part 2  - test
(Assignee)

Comment 13

4 years ago
Created attachment 8446310 [details] [diff] [review]
part 0 - rename run runEmuCmd

rename run runEmuCmd because runShellCmd is going to be added in a following part. We need a more specific name.
(Assignee)

Comment 14

4 years ago
Created attachment 8446312 [details] [diff] [review]
part 1 - fix
Attachment #8443359 - Attachment is obsolete: true
(Assignee)

Comment 15

4 years ago
Created attachment 8446313 [details] [diff] [review]
part 2 - test (v2)
Attachment #8445087 - Attachment is obsolete: true
(Assignee)

Updated

4 years ago
Attachment #8446310 - Flags: review?(szchen)
Comment on attachment 8446310 [details] [diff] [review]
part 0 - rename run runEmuCmd

Review of attachment 8446310 [details] [diff] [review]:
-----------------------------------------------------------------

How about emulator.runCmdWithCallback()? We don't have to repeat 'Emu' since it's already the member function of |emulator|.
Attachment #8446310 - Flags: review?(szchen) → review+
(Assignee)

Comment 17

4 years ago
Comment on attachment 8446312 [details] [diff] [review]
part 1 - fix

Review of attachment 8446312 [details] [diff] [review]:
-----------------------------------------------------------------

Hi Aknow,

As we discussed before, in this patch I moved the check of _isEmergencyNumber from ril_worker.js to TelephonyService.js to achieve our goal - query ril.ecclist per dial request. Could you help review this? Thank you!

::: dom/system/gonk/ril_worker.js
@@ -2410,5 @@
>        return false;
>      }
>  
> -    if (this._isEmergencyNumber(mmiString)) {
> -      return false;

Remark: It's fine to remove this now because currently parsing short MMI isn't well support on gaia, and this call path is never called until Bug 889737.
Attachment #8446312 - Flags: review?(szchen)
(Assignee)

Updated

4 years ago
Attachment #8446313 - Flags: review?(szchen)
(Assignee)

Comment 18

4 years ago
(In reply to Szu-Yu Chen [:aknow] from comment #16)
> Comment on attachment 8446310 [details] [diff] [review]
> part 0 - rename run runEmuCmd
> 
> Review of attachment 8446310 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> How about emulator.runCmdWithCallback()? We don't have to repeat 'Emu' since
> it's already the member function of |emulator|.

Even better!
Comment on attachment 8446312 [details] [diff] [review]
part 1 - fix

Review of attachment 8446312 [details] [diff] [review]:
-----------------------------------------------------------------

Please remove the code related to |RIL_EMERGENCY_NUMBERS| or |DEFAULT_EMERGENCY_NUMBERS| in ril_worker.js.
They are not used any more.

::: dom/system/gonk/ril_worker.js
@@ +1598,1 @@
>      if (this._isCdma && Object.keys(this.currentCalls).length == 1) {

This part of code is also duplicated in dialEmergency(). Could we avoid it?

::: dom/telephony/gonk/TelephonyService.js
@@ +497,5 @@
>        this.notifyCallStateChanged(aClientId, parentCall);
>      };
>  
> +    let msg = this._isEmergencyNumber(aNumber) ?
> +              "dialEmergencyNumber" : "dialNonEmergencyNumber";

Cache the result of this._isEmergencyNumber(aNumber). We also use it in line 505.
Attachment #8446312 - Flags: review?(szchen)
Comment on attachment 8446313 [details] [diff] [review]
part 2 - test (v2)

Review of attachment 8446313 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/telephony/test/marionette/head.js
@@ +75,5 @@
>  
>      waitFor(function() {
>        deferred.resolve();
>      }, function() {
> +      return ((pendingCmdCount === 0) && (pendingShellCount === 0));

I think you don't need the parentheses. All of them could be removed.

::: dom/telephony/test/marionette/test_emergency_label.js
@@ +56,5 @@
>        is(outCall.emergency, emergency, "emergency result should be correct");
>      })
> +    .then(() => gRemoteHangUp(outCall))
> +    .then(() => {
> +      return list;

I don't think it's a good idea. 
The value of |list| might be modified and pass it to the next promise could introduce some side effects.
So, We don't need the return value.

@@ +62,4 @@
>  }
>  
>  startTest(function() {
> +  getEccListProperty()

Save the ecc list you got here. Then use setEccListProperty("") to test default ecc list. You should set the property you want before the test. Don't rely on the data in emulator.

ex:

let eccList;

.then(list => {
  originalList = list;
})
.then(() => {
  eccList = "";
  return setEccListProperty(eccList))
})
.then(() => testEmergencyLabel("112", eccList))

@@ +66,5 @@
> +    .then((list) => testEmergencyLabel("112", list))
> +    .then((list) => testEmergencyLabel("911", list))
> +    .then((list) => testEmergencyLabel("0912345678", list))
> +    .then((list) => testEmergencyLabel("777", list))
> +    .then(() => setEccListProperty("777,119"))

.then(() => {
  eccList = "777,119";
  return setEccListProperty(eccList))
})
.then(() => testEmergencyLabel("777", eccList))

@@ +70,5 @@
> +    .then(() => setEccListProperty("777,119"))
> +    .then((list) => testEmergencyLabel("777", list))
> +    .then((list) => testEmergencyLabel("119", list))
> +    .then((list) => testEmergencyLabel("112", list))
> +    .then(() => setEccListProperty(""))

Restore the ecclist
setEccListProperty(originalList)
Attachment #8446313 - Flags: review?(szchen)
(Assignee)

Comment 21

4 years ago
Created attachment 8447018 [details] [diff] [review]
part 0 - rename run runCmd (v2)

Addressed reviewer's comment.
Attachment #8446310 - Attachment is obsolete: true
(Assignee)

Comment 22

4 years ago
Created attachment 8447019 [details] [diff] [review]
part 1 - fix (v2)

Addressed comment 19.
Attachment #8446312 - Attachment is obsolete: true
(Assignee)

Comment 23

4 years ago
(In reply to Szu-Yu Chen [:aknow] from comment #19)
> Comment on attachment 8446312 [details] [diff] [review]
> part 1 - fix
> 
> Review of attachment 8446312 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Please remove the code related to |RIL_EMERGENCY_NUMBERS| or
> |DEFAULT_EMERGENCY_NUMBERS| in ril_worker.js.
> They are not used any more.
> 

Thanks for the catch!

> ::: dom/system/gonk/ril_worker.js
> @@ +1598,1 @@
> >      if (this._isCdma && Object.keys(this.currentCalls).length == 1) {
> 
> This part of code is also duplicated in dialEmergency(). Could we avoid it?
> 

I've tried to remove it. Please review the 2nd version.

> ::: dom/telephony/gonk/TelephonyService.js
> @@ +497,5 @@
> >        this.notifyCallStateChanged(aClientId, parentCall);
> >      };
> >  
> > +    let msg = this._isEmergencyNumber(aNumber) ?
> > +              "dialEmergencyNumber" : "dialNonEmergencyNumber";
> 
> Cache the result of this._isEmergencyNumber(aNumber). We also use it in line
> 505.

Done, thanks!
(Assignee)

Comment 24

4 years ago
Created attachment 8447020 [details] [diff] [review]
part 2 - test (v3)

Comment 20 addressed.
Attachment #8446313 - Attachment is obsolete: true
(Assignee)

Comment 25

4 years ago
Comment on attachment 8447019 [details] [diff] [review]
part 1 - fix (v2)

Review of attachment 8447019 [details] [diff] [review]:
-----------------------------------------------------------------

Hi Aknow,

I've addressed your comments. Please take a look again, thank you :)
Attachment #8447019 - Flags: review?(szchen)
(Assignee)

Comment 26

4 years ago
Comment on attachment 8447020 [details] [diff] [review]
part 2 - test (v3)

Review of attachment 8447020 [details] [diff] [review]:
-----------------------------------------------------------------

Comment 20 addressed. Thank you!
Attachment #8447020 - Flags: review?(szchen)
Attachment #8447020 - Flags: review?(szchen) → review+
Comment on attachment 8447019 [details] [diff] [review]
part 1 - fix (v2)

Review of attachment 8447019 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM. Thanks.
Attachment #8447019 - Flags: review?(szchen) → review+
(Assignee)

Comment 28

4 years ago
I don't think this is a regression. Our code has never handled this well. We may be lucky enough before to not meet this issue.
Keywords: regression
(Assignee)

Comment 31

4 years ago
Created attachment 8447842 [details] [diff] [review]
part 3 - fix xpcshell
Attachment #8447842 - Flags: review?(szchen)
Attachment #8447842 - Flags: review?(szchen) → review+
(2.0?, as I don't see why this bug should block 2.0)
blocking-b2g: 2.0+ → 2.0?
(Reporter)

Comment 35

4 years ago
(In reply to Michael Vines [:m1] [:evilmachines] from comment #34)
> (2.0?, as I don't see why this bug should block 2.0)
If this bug fixes the problem described in comment 0, then we need it to pass certification. Why do you think we do not need it in 2.0?
Flags: needinfo?(mvines)
(In reply to Beatriz Rodríguez [:brg] from comment #35)
> (In reply to Michael Vines [:m1] [:evilmachines] from comment #34)
> > (2.0?, as I don't see why this bug should block 2.0)
> If this bug fixes the problem described in comment 0, then we need it to
> pass certification. Why do you think we do not need it in 2.0?

The fix here is to a component of the software that is not used in commercial devices, so the patch effectively doesn't do anything for v2.0 beyond causing code churn.
Flags: needinfo?(mvines)
sorry had to back this out in https://tbpl.mozilla.org/?rev=ffb8b976548b for causing Bug 1032716
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

4 years ago
Depends on: 1032716
Adding qawanted to confirm if this happens on dolphin 1.4.
Flags: needinfo?(whsu)
Keywords: qawanted
(Assignee)

Updated

4 years ago
Depends on: 1032758

Comment 39

4 years ago
(In reply to bhavana bajaj [:bajaj] [NOT reading Bugmail, needInfo please] from comment #38)
> Adding qawanted to confirm if this happens on dolphin 1.4.

Thanks for your reminder, Bhavana!:)

As I tested on Buri(v1.4) and Tarako(v1.4), I noticed that only "112" and "911" can be recognized.
The other numbers cannot be allowed to make the emergency call.
So, is there something wrong on "ril.ecclist" of v1.4?
A different bug?

Attach the demo video.(WP_20140702_003.mp4)
* Note: Dolphin is not yet released. So, the demo phone is Buri.

* Build information:
 @ Buri - v1.4
   - Gaia      bf5ad311b6a14383924d6a3898c650ffa4525840
   - Gecko     https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/6817b6858ccf
   - BuildID   20140701000201
   - Version   30.0
 @ Dolphin - v1.4
   - Gaia      aa896d5db1b4929f3bf31a0f4bb7de50530222a8
   - Gecko     https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/4dc067aa0e18
   - BuildID   20140629160201
   - Version   30.0
Flags: needinfo?(whsu)

Comment 40

4 years ago
Created attachment 8449136 [details]
WP_20140702_003.mp4

Updated

4 years ago
Keywords: qawanted
(Assignee)

Comment 41

4 years ago
(In reply to William Hsu [:whsu] from comment #39)
> (In reply to bhavana bajaj [:bajaj] [NOT reading Bugmail, needInfo please]
> from comment #38)
> > Adding qawanted to confirm if this happens on dolphin 1.4.
> 
> Thanks for your reminder, Bhavana!:)
> 
> As I tested on Buri(v1.4) and Tarako(v1.4), I noticed that only "112" and
> "911" can be recognized.
> The other numbers cannot be allowed to make the emergency call.
> So, is there something wrong on "ril.ecclist" of v1.4?

Could you try the case of no sim? 

The steps would be:
1) make sure no sims are inserated
2) adb shell getprop ril.ecclist // you could see the legal emergency numbers. In buri, there should be [911,112,000,08,110,999,118,119]
3) dial out an emergency call, except 112 and 119. See if the call can be out. I tried my buri which failed.

> A different bug?
> 
> Attach the demo video.(WP_20140702_003.mp4)
> * Note: Dolphin is not yet released. So, the demo phone is Buri.
> 
> * Build information:
>  @ Buri - v1.4
>    - Gaia      bf5ad311b6a14383924d6a3898c650ffa4525840
>    - Gecko    
> https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/6817b6858ccf
>    - BuildID   20140701000201
>    - Version   30.0
>  @ Dolphin - v1.4
>    - Gaia      aa896d5db1b4929f3bf31a0f4bb7de50530222a8
>    - Gecko    
> https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/4dc067aa0e18
>    - BuildID   20140629160201
>    - Version   30.0
(Assignee)

Updated

4 years ago
Flags: needinfo?(whsu)
(Assignee)

Comment 42

4 years ago
Created attachment 8449160 [details] [diff] [review]
part 1 - fix (v3)

Removed undefined variable
Attachment #8447019 - Attachment is obsolete: true

Comment 43

4 years ago
> Could you try the case of no sim? 
> 
> The steps would be:
> 1) make sure no sims are inserated
I can sure there is no SIM was inserted while I test this case

> 2) adb shell getprop ril.ecclist // you could see the legal emergency
> numbers. In buri, there should be [911,112,000,08,110,999,118,119]
The following is related information I got.
william@tpemozilla:~$ adb shell getprop ril.ecclist
911,112,000,08,110,999,118,119

> 3) dial out an emergency call, except 112 and 119. See if the call can be
> out. I tried my buri which failed.
I cannot dial out following emergency call
- 000,08,110,999,118,119
Here is the demo video. FYI.
- https://bugzilla.mozilla.org/attachment.cgi?id=8449136

Thanks!
Flags: needinfo?(whsu)
(Assignee)

Comment 44

4 years ago
(In reply to William Hsu [:whsu] from comment #43)
> > Could you try the case of no sim? 
> > 
> > The steps would be:
> > 1) make sure no sims are inserated
> I can sure there is no SIM was inserted while I test this case
> 
> > 2) adb shell getprop ril.ecclist // you could see the legal emergency
> > numbers. In buri, there should be [911,112,000,08,110,999,118,119]
> The following is related information I got.
> william@tpemozilla:~$ adb shell getprop ril.ecclist
> 911,112,000,08,110,999,118,119
> 
> > 3) dial out an emergency call, except 112 and 119. See if the call can be
> > out. I tried my buri which failed.
> I cannot dial out following emergency call
> - 000,08,110,999,118,119
> Here is the demo video. FYI.
> - https://bugzilla.mozilla.org/attachment.cgi?id=8449136
> 
> Thanks!

Thanks, William.

Then this issue appears on v1.4 as well.

Comment 45

4 years ago
> Thanks, William.
> 
> Then this issue appears on v1.4 as well.


No problem! If there is anything I can do to help please feel free to let me know.
Have a nice day! :)
NI , Ivan to confirm if this would be a cert blocker for dolphin, in which case we will consider this code on our branches, else this will ride the trains.
blocking-b2g: 2.0? → 1.4?
Flags: needinfo?(itsay)

Updated

4 years ago
blocking-b2g: 1.4? → 1.4+
Flags: needinfo?(itsay)
(Assignee)

Updated

4 years ago
status-b2g-v1.4: --- → affected
status-b2g-v2.1: --- → fixed
(Assignee)

Updated

4 years ago
status-b2g-v2.1: fixed → affected
(Assignee)

Comment 48

4 years ago
Hi Carsten,

The patches have been pushed to b2g-inbound since last Wednesday (comment 46). Wondering why they haven't been in m-c yet. Could you help me check it out? Please let me know if anything wrong, thank you :)
Flags: needinfo?(cbook)
(In reply to Hsin-Yi Tsai [:hsinyi] from comment #48)
> Hi Carsten,
> 
> The patches have been pushed to b2g-inbound since last Wednesday (comment
> 46). Wondering why they haven't been in m-c yet. Could you help me check it
> out? Please let me know if anything wrong, thank you :)

Hi,

seems the tool that mark the bugs when they land on m-c didn't run. Fixed this now in comment #49 :)
Flags: needinfo?(cbook)
(Assignee)

Comment 51

4 years ago
(In reply to Carsten Book [:Tomcat] from comment #50)
> (In reply to Hsin-Yi Tsai [:hsinyi] from comment #48)
> > Hi Carsten,
> > 
> > The patches have been pushed to b2g-inbound since last Wednesday (comment
> > 46). Wondering why they haven't been in m-c yet. Could you help me check it
> > out? Please let me know if anything wrong, thank you :)
> 
> Hi,
> 
> seems the tool that mark the bugs when they land on m-c didn't run. Fixed
> this now in comment #49 :)

Ya, thanks for the help!
The part 0 patch here has some pretty major uplift conflicts with aurora from bug 1027996 and bug 981519. I'd like to hold off on the v2.0 uplift here until bug 981519 has approval so I can take them all in one shot and avoid the conflicts.

That said, we should probably rebase these patches for b2g30 (v1.4) uplift.
status-b2g-v2.0: --- → affected
status-b2g-v2.1: affected → fixed
Flags: needinfo?(htsai)
Keywords: branch-patch-needed
Whiteboard: [perf-reviewed][ETA:6/27] → [perf-reviewed]
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #52)
> The part 0 patch here has some pretty major uplift conflicts with aurora
> from bug 1027996 and bug 981519. I'd like to hold off on the v2.0 uplift
> here until bug 981519 has approval so I can take them all in one shot and
> avoid the conflicts.

Where does this bug have approval to land in v2.0?  v1.4+ does not imply v2.0+ anymore.
(Assignee)

Comment 54

4 years ago
Working on v1.4 patches!
(In reply to Michael Vines [:m1] [:evilmachines] from comment #53)
> Where does this bug have approval to land in v2.0?  v1.4+ does not imply
> v2.0+ anymore.

"Before 2.0 FC (Jul 21), 1.4+ blockers will be auto-landed to 2.0."  That's the latest uplift policy we have.  Before any further update made, Ryan and Hsin-Yi are doing their jobs well and correctly.
(In reply to Vicamo Yang [:vicamo][:vyang] from comment #55)
> "Before 2.0 FC (Jul 21), 1.4+ blockers will be auto-landed to 2.0."  That's
> the latest uplift policy we have.  Before any further update made, Ryan and
> Hsin-Yi are doing their jobs well and correctly.

Sry, yes quite right.  The gap is elsewhere.
(Assignee)

Comment 57

4 years ago
Created attachment 8453653 [details] [diff] [review]
[v1.4] part 0 - replace "run" with "runCmd"
Flags: needinfo?(htsai)
(Assignee)

Comment 58

4 years ago
Created attachment 8453654 [details] [diff] [review]
[v1.4] part 1 - fix
(Assignee)

Comment 59

4 years ago
Created attachment 8453656 [details] [diff] [review]
[v1.4] part 2 - marionette test case
(Assignee)

Comment 60

4 years ago
Created attachment 8453658 [details] [diff] [review]
[v1.4] part 3 - xpcshell test
(Assignee)

Comment 61

4 years ago
I've verified v1.4 patches locally. However, since v1.4 code differs seriously from master branch, to play it safe, do NOT push the v1.4 patches until try result is out.

https://tbpl.mozilla.org/?tree=Try&rev=151f2166a3a9
(Assignee)

Comment 63

4 years ago
Thanks, Ryan.

I'll provide v2.0 patches after bug 981519 is landed on mozilla-aurora.
(In reply to Hsin-Yi Tsai [:hsinyi] from comment #63)
> Thanks, Ryan.
> 
> I'll provide v2.0 patches after bug 981519 is landed on mozilla-aurora.

If it helps, keep in mind that bug 1027996 can land on aurora a=test-only. That was my intent.
(Assignee)

Comment 65

4 years ago
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #64)
> (In reply to Hsin-Yi Tsai [:hsinyi] from comment #63)
> > Thanks, Ryan.
> > 
> > I'll provide v2.0 patches after bug 981519 is landed on mozilla-aurora.
> 
> If it helps, keep in mind that bug 1027996 can land on aurora a=test-only.
> That was my intent.

We've done several improvements on telephony marionette test cases. It's not enough to cherry pick only bug 1027996. I am planning to provide a proper test case based on v2.0 code.
(Assignee)

Comment 67

4 years ago
Created attachment 8455929 [details] [diff] [review]
[v2.0] part 0
(Assignee)

Comment 68

4 years ago
Created attachment 8455931 [details] [diff] [review]
[v2.0] part 1
(Assignee)

Comment 69

4 years ago
Created attachment 8455932 [details] [diff] [review]
[v2.0] part 2
(Assignee)

Comment 70

4 years ago
Created attachment 8455933 [details] [diff] [review]
[v2.0] part 3
(Assignee)

Comment 71

4 years ago
[v2.0] patches are rebased on bug 981519. Should safely land these after bug 981519.

Comment 72

4 years ago
Great! Thanks everyone.
Verified it on v1.4 PVT build.
I can dial up following emergency calls without SIM card inserted.
- 112, 911, 08, 000, 110, 118, 119, 999.

* Build information:
 - Gaia      b7d36622c7df92c976c37520ccab25199c7ada91
 - Gecko     https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/de7ecfb00955
 - BuildID   20140715000202
 - Version   30.0
Status: RESOLVED → VERIFIED
status-firefox32: affected → wontfix
Note that per the recent rule change announced in dev-gaia, 1.4 blockers don't have auto-approval to land on v2.0. Please nominate this patch for b2g32 uplift if you feel that it needs to land there as well. Sorry for the inconvenience :(
Flags: needinfo?(htsai)
(Assignee)

Comment 74

4 years ago
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #73)
> Note that per the recent rule change announced in dev-gaia, 1.4 blockers
> don't have auto-approval to land on v2.0. Please nominate this patch for
> b2g32 uplift if you feel that it needs to land there as well. Sorry for the
> inconvenience :(

I don't see the need to land on v2.0. I will ask approval if we see it later. Thank you, Ryan!
Flags: needinfo?(htsai)
status-b2g-v2.0: affected → wontfix
You need to log in before you can comment on or make changes to this bug.