Can't use mouse to navigate in firefox-gtk3 on gtk 3.13.2

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
5 years ago
4 months ago

People

(Reporter: kxra, Unassigned)

Tracking

33 Branch
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:33.0) Gecko/20100101 Firefox/33.0 (Beta/Release)
Build ID: 20140612121001

Steps to reproduce:

Open firefox, try to click on anything. 

This has been happening on Fedora 21 (Rawhide) x86_64. It seems to have started not with an update to firefox, but an update to other software, so perhaps firefox is not working with updated gtk libraries. 


Actual results:

Nothing is clickable, and clicking on elements (any UI element or part of a web page) seems to have the same effect as clicking the title bar, as double clicking will maximize or unmaximize the window. 

After double clicking, the window will either maximize or unmaximize (whatever is possible) but the element that was being clicked on will be clicked if it is a UI element, or selected if it's part of a web page (if a text field, the text will be selected; if it's a link, it will not have been clicked, but it will have the dotted line around it indicating it is selected and can be "clicked" by hitting enter). 


Expected results:

Clicking should just click.
Reporter

Updated

5 years ago
Blocks: core-e10s, e10s, gtk3
The problem might be related to the scaling issues observed in bug 1025715.
Reporter

Comment 2

5 years ago
i filed both bugs, but they seem to be separate. 

this bug i have observed longer, and effects all firefox-gtk3 windows. it also was not revealed by an update to firefox, but an update to other software (it was a big batch so i have no way of tracking figuring out which package caused this). 

the scaling bug is only a problem in e10s windows, but i don't know if it has always been a problem, because prior to the scaling issue, e10s windows were blank due to bug 1013552
Yes, it's best to track the different symptoms separately, at least until we know the cause(s).
Component: Untriaged → Event Handling
Product: Firefox → Core
I have the exact same problem here.
I'm willing to provide more information or do some testing but I don't really know where to look.
I'm using mozilla-central tip with gtk3.
Ok, fwiw, I was running gtk 3.13.2.
3.13.3 has been released and solved the issue for me.

Comment 6

5 years ago
I can confirm this is fixed with gtk 3.13.3
Reporter

Comment 7

5 years ago
works for me with the latest update as well! the question is now whether it was a bug in firefox or a bug in gtk over which firefox could not do much to avoid. i suspect, as firefox was the only application affected, that it may not be handling something properly which that version of gtk just happened to expose
Summary: Can't use mouse to navigate on firefox-gtk3 → Can't use mouse to navigate in firefox-gtk3 on gtk 3.13.2

Updated

5 years ago
Blocks: 1034064

Updated

5 years ago
No longer blocks: 1034064
Given this was only with a development version of GTK, I don't think there is a need to do anything here.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.