Upload new version of xulrunner to tooltool

RESOLVED FIXED

Status

Release Engineering
Platform Support
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: nthomas, Assigned: jgriffin)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Similar to bug 909968, only for
 https://github.com/mozilla-b2g/gaia/commit/948e2d52ce28d30428cc533a9c99d1a9747b1f6b
(we still have that 2013-08-07-03-02-16 build on runtime-binaries).

Then update files like 
 http://mxr.mozilla.org/build/source/mozharness/configs/marionette/gaia_ui_test_prod_config.py#8

Looks like we will need to upload both mac and linux64 xulrunner. 

jgriffin, OK ?
Flags: needinfo?(jgriffin)
(Reporter)

Comment 1

3 years ago
Looks like we take the sdk specified in gaia/Makefile, download, unpack, strip all subdirs except bin, then recompress with zip (no prefix, bin/ in root of archive), and upload to tooltool.
(Assignee)

Comment 2

3 years ago
(In reply to Nick Thomas [:nthomas] from comment #1)
> Looks like we take the sdk specified in gaia/Makefile, download, unpack,
> strip all subdirs except bin, 

That's step 1.

Step 2 is to grab a copy of tests.zip from Firefox for the same version and platform (e.g., http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/30.0-candidates/build2/linux-x86_64/en-US/firefox-30.0.tests.zip) and copy ssltunnel and the components directory from there to the 'bin' directory you made in step 1.

> then recompress with zip (no prefix, bin/ in root of archive), and upload to tooltool.

Yes.

This is undeniably ugly.  Once we have Mulet builds in production, we should make a target to auto-generate these, if possible.
Flags: needinfo?(jgriffin)
Looks like this might be tickling bug 1017490.  When the current tooltool copy of xulrunner is used, there are segfaults.  When it's using the actual upstream version it doesn't segfault.

It'd be really great if the person who updates 

mozharness/configs/b2g/gaia_integration_config.py
mozharness/configs/b2g/gaia_unit_production_config.py
mozharness/configs/marionette/gaia_ui_test_prod_config.py

to point to the new tooltool bundle included a comment with the base URL that gives you that sha512.
(Assignee)

Updated

3 years ago
Assignee: nobody → jgriffin
(Assignee)

Updated

3 years ago
Depends on: 1027177
(Assignee)

Comment 4

3 years ago
Here's a new xre.zip produced by the script in bug 1027177; I'd like to test it out on cedar.  Please upload http://people.mozilla.org/~jgriffin/xre.linux-x86_64.zip to tooltool, and then pass this bug back to me.
Assignee: jgriffin → bugspam.Callek
(Reporter)

Updated

3 years ago
Blocks: 1032082
(Reporter)

Comment 5

3 years ago
I saw bug 1032082 come past so jumped in here. Uploaded using https://wiki.mozilla.org/ReleaseEngineering/Applications/Tooltool#How_to_upload_to_tooltool:

{
"size": 28306757,
"digest": "b48e7defed365b5899f4a782304e4c621e94c6759e32fdec66aa3e088688401e4c404b1778cd0c6b947d9faa874f60a68e1c7d8ccaa5f2d25077eafad5d533cc",
"algorithm": "sha512",
"filename": "xre.linux-x86_64.zip"
}
Assignee: bugspam.Callek → jgriffin
(Assignee)

Comment 6

3 years ago
Thanks Nick.

Trying this out on cedar now.
(Assignee)

Comment 7

3 years ago
(In reply to Jonathan Griffin (:jgriffin) from comment #6)
> Thanks Nick.
> 
> Trying this out on cedar now.

This looks good.  I'll now need to package and upload an OSX version.
(Assignee)

Comment 8

3 years ago
Buildduty, can you upload the mac version now?

url: http://people.mozilla.org/~jgriffin/xre.mac.zip
Assignee: jgriffin → bugspam.Callek
Component: Platform Support → Buildduty
QA Contact: coop → bugspam.Callek
[jwood@relengwebadm.private.scl3 ~]$ ls -l  /mnt/netapp/relengweb/tooltool/pvt/build/sha512/${SHA512}
-rw-r--r-- 1 jwood jwood 48083949 Jun 30 16:12 /mnt/netapp/relengweb/tooltool/pvt/build/sha512/441be719e6984d24e9eadca5d13a1cd7d22e81505b21a82d25a7da079a48211b5feb4525a6f32100a00748f8a824a341065d66a97be8e932c3a3e1e55ade0ede
Assignee: bugspam.Callek → jgriffin
Component: Buildduty → Platform Support
QA Contact: bugspam.Callek → coop
(Assignee)

Comment 10

3 years ago
Trying the osx version on cedar.
Blocks: 1029967
Blocks: 1031123
(Assignee)

Comment 11

3 years ago
These patches have been merged to production, so I'm closing this; let me know if any problems are seen.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 12

3 years ago
Btw, said patches are:

http://hg.mozilla.org/build/mozharness/rev/404dfba5c39d
http://hg.mozilla.org/build/mozharness/rev/8135cd2fdad9
(Reporter)

Updated

3 years ago
Depends on: 1035624
Duplicate of this bug: 1032082
You need to log in before you can comment on or make changes to this bug.