Closed Bug 1025770 Opened 6 years ago Closed 6 years ago

MOZ_CRASH(WebMBufferedState not thread-safe) when using MSE

Categories

(Core :: Audio/Video, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla33

People

(Reporter: kinetik, Assigned: kinetik)

References

(Blocks 1 open bug)

Details

(Keywords: crash)

Possibly caused or exposed by the async reader changes.  Crash summary: we're destroying a RequestVideoWithSkipTask, which appears to be the last reference to a WebMReader, causing the reader and its WebMBufferedState to be destroyed within the decode pool.
Duplicate of this bug: 1028606
Depends on: 1028748
Depends on: 1028144
Hopefully fixed by bug 1028144.
Keywords: crash
Fixed by bug 1028144.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
You need to log in before you can comment on or make changes to this bug.