Fix ownership of SubBufferDecoder readers

RESOLVED DUPLICATE of bug 1028144

Status

()

RESOLVED DUPLICATE of bug 1028144
5 years ago
5 years ago

People

(Reporter: kinetik, Assigned: kinetik)

Tracking

(Blocks: 1 bug)

Trunk
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Readers were made refcounted in bug 979104, but SubBufferDecoder still tries to use an nsAutoPtr to hang on to its reader.

This probably fixes bug 1028742, bug 1028642, and bug 1025770.
(Assignee)

Updated

5 years ago
(Assignee)

Updated

5 years ago
Attachment #8444169 - Flags: review?(cajbir.bugzilla)
(Assignee)

Comment 2

5 years ago
If MediaDecoderReader wasn't whitelisted (bug 1028144), this would've been caught as a compile error.
(Assignee)

Comment 3

5 years ago
Comment on attachment 8444169 [details] [diff] [review]
SubBufferDecoder needs to own its reader with an nsRefPtr.

Er, this doesn't build.  New patch shortly.
Attachment #8444169 - Flags: review?(cajbir.bugzilla)
(Assignee)

Comment 4

5 years ago
Easier to fix as part of bug 1028144.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1028144
You need to log in before you can comment on or make changes to this bug.