Closed Bug 1034399 Opened 8 years ago Closed 8 years ago

Use a Moz2D DrawTarget backed gfxContext for SVG bounds calculations

Categories

(Core :: Graphics, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla33

People

(Reporter: jwatt, Assigned: jwatt)

References

Details

Attachments

(1 file)

Bug 934183 is harder than it looks given the need to conform to SVG's requirements when degenerate paths are stroked. For now let's use a Moz2D DrawTarget backed gfxContext for SVG bounds calculations so we can move ahead with bug 933019.
Attached patch patchSplinter Review
Attachment #8450709 - Flags: review?(matt.woodrow)
Attachment #8450709 - Flags: review?(matt.woodrow) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/e91a7e542b7b

I had to wrap the screen ref surface for windows for now due to various tests being unhappy - see the comment I put in the code. (Probably the best way to deal with that is to fix bug 1034958.) As a result I also had to make sure that SVGEllipseElement::ConstructPath passes on the correct type of PathBuilder to BuildPath() so the path we get back is compatible (but then ConstructPath is going away soon, so not a big deal, but worth fixing anyway).
https://hg.mozilla.org/mozilla-central/rev/e91a7e542b7b
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
Just got this automated talos regression email - looks like this bug is the only possible candidate:

Regression: Mozilla-Inbound-Non-PGO - SVG, Opacity Row Major - Ubuntu HW 12.04 x64 - 10.4% increase
---------------------------------------------------------------------------------------------------
    Previous: avg 117.208 stddev 1.514 of 12 runs up to revision b0d36fb76f26
    New     : avg 129.375 stddev 2.247 of 12 runs since revision e91a7e542b7b
    Change  : +12.167 (10.4% / z=8.034)
    Graph   : http://mzl.la/1n0IOC5

Changeset range: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=b0d36fb76f26&tochange=e91a7e542b7b

Changesets:
  * http://hg.mozilla.org/integration/mozilla-inbound/rev/5f27f634ed58
    : Benoit Jacob <bjacob@mozilla.com> - Bug 1028588 - Fix dangerous public destructors of Mac-specific reference-counted classes - r=mstange
    : http://bugzilla.mozilla.org/show_bug.cgi?id=1028588

  * http://hg.mozilla.org/integration/mozilla-inbound/rev/e91a7e542b7b
    : Jonathan Watt <jwatt@jwatt.org> - Bug 1034399 - Use a Moz2D DrawTarget backed gfxContext for SVG bounds calculations. r=Bas
    : http://bugzilla.mozilla.org/show_bug.cgi?id=1034399

Bugs:
  * http://bugzilla.mozilla.org/show_bug.cgi?id=1028588 - Add dangerous public destructor detection to much of the rest of nsISupportsImpl.h (still not covering NS_IMPL_ADDREF_INHERITED)
  * http://bugzilla.mozilla.org/show_bug.cgi?id=1034399 - Use a Moz2D DrawTarget backed gfxContext for SVG bounds calculations
Flags: needinfo?(bas)
I believe this was fixed by JWatt's other work.
Flags: needinfo?(bas) → needinfo?(jwatt)
It was.
Flags: needinfo?(jwatt)
You need to log in before you can comment on or make changes to this bug.