Closed Bug 1036031 Opened 5 years ago Closed 5 years ago

Intermittent browser_share.js | leaked 1 docShell(s) until shutdown

Categories

(Firefox Graveyard :: SocialAPI, defect)

defect
Not set

Tracking

(firefox32 fixed, firefox33 fixed, firefox34 fixed, firefox-esr24 unaffected, firefox-esr31 unaffected)

RESOLVED FIXED
Firefox 34
Tracking Status
firefox32 --- fixed
firefox33 --- fixed
firefox34 --- fixed
firefox-esr24 --- unaffected
firefox-esr31 --- unaffected

People

(Reporter: RyanVM, Assigned: smacleod)

References

Details

(Keywords: intermittent-failure, memory-leak)

Not sure what to make of this one. It's an intermittent failure on trunk, but we were hitting this exact same leak on mozilla-beta as a perma-fail when I attempted to uplift bug 965697 to it.

https://tbpl.mozilla.org/php/getParsedLog.php?id=43359283&tree=Mozilla-Inbound

Rev4 MacOSX Snow Leopard 10.6 mozilla-inbound debug test mochitest-browser-chrome-1 on 2014-07-08 10:19:36 PDT for push ea72e2c9debe
slave: t-snow-r4-0082

11:05:36  WARNING -  TEST-UNEXPECTED-FAIL | browser/base/content/test/social/browser_share.js | leaked 1 docShell(s) until shutdown
Duplicate of this bug: 1035815
Shane, any ideas why this test would "leak" a docshell until shutdown? Something similar to the sidebar issues we were seeing long ago (lazy initialization of the share panel doc)?
Flags: needinfo?(mixedpuppy)
I've been periodically looking at this problem since it started and haven't figured out why it is occurring.  We've always lazily added an iframe for share, we also do that for other panels that other tests run, and I'm unclear why those don't also report a leak.
Flags: needinfo?(mixedpuppy)
This should be fixed by Bug 1036036
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Firefox 34
Assignee: nobody → smacleod
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.