Closed Bug 1039168 Opened 7 years ago Closed 7 years ago

FxOS Loop client app needs to reject incoming calls with a reason of "busy" if already on a call

Categories

(Firefox OS Graveyard :: Gaia::Loop, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.0 affected, b2g-v2.1 affected)

RESOLVED FIXED
Tracking Status
b2g-v2.0 --- affected
b2g-v2.1 --- affected

People

(Reporter: jaoo, Assigned: ferjm)

References

Details

Attachments

(1 file, 1 obsolete file)

Same as bug 1032700 for the FxOS Loop client app.
See Also: → 1032700
Assignee: nobody → josea.olivera
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Assignee: josea.olivera → ferjmoreno
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Duplicate of this bug: 1050279
This patch does exactly what the descriptions tells: sends the 'busy' state if we are already on a call. However we need to decide what to do on the caller side if we receive this 'busy' state from the callee. So far, we are just closing the call screen, but I guess we need to play the busy tone and show a proper screen probably allowing the user to callback. I filed bug 1054417.

As you know, I'm gonna be on PTO for the next two weeks, so feel free to modify the patch if needed. Thanks!
Attachment #8473791 - Flags: review?(borja.bugzilla)
Blocks: 1053338
Borja, I could address the review comments you might have. If so, please let me know. Thanks.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
Attachment #8473791 - Attachment is obsolete: true
Attachment #8473791 - Flags: review?(borja.bugzilla)
Attachment #8477497 - Flags: review?(borja.bugzilla)
Comment on attachment 8477497 [details] [review]
Pointer to Github PR https://github.com/mozilla-b2g/firefoxos-loop-client/pull/96

Small comment to address and ready to merge! Thanks for the patch!
Attachment #8477497 - Flags: review?(borja.bugzilla) → review+
Thanks Borja, landed at:

https://github.com/mozilla-b2g/firefoxos-loop-client/commit/fd515fea875a4d9b569abf58542bd3d54c37ff46
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.