Toolbox border still visible when all toolbars collapsed

RESOLVED FIXED in Thunderbird 34.0

Status

defect
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Mikeyy, Assigned: Paenglab)

Tracking

31 Branch
Thunderbird 34.0
Dependency tree / graph
Bug Flags:
in-testsuite -

Thunderbird Tracking Flags

(thunderbird32 fixed, thunderbird33 fixed, thunderbird34 fixed, thunderbird_esr3132+ fixed)

Details

Attachments

(3 attachments)

Posted image double_line.png
Check picture. When using Thunderbird tabs, there is only 1 line splitting tabs from rest of screen.
When using Calendar or Tasks tabs, there is double line.

It doesn't matter if I use themes or not, it's just less visible with theme.
Blocks: TB31found
Mihovil, this is with the toolbar collapsed, true?

This happens also with the main toolbar. I'll look how I can hide the toolbox border when all toolbars are collapsed.
Yes, I collapsed calendar and tasks toolbars.
Component: General → Theme
OS: Windows 7 → All
Product: Calendar → Thunderbird
Hardware: x86_64 → All
Summary: Lightning 3.3 has double line under tabs → Toolbox border still visible when all toolbars collapsed
Version: Lightning 3.3 → 31
Posted image solution1.png
There are two approaches to fix this.
1. Give the toolbox a min-height to show a remaining part of the toolbox with border (see screenshot). I think this makes too much lines which are near to other lines.

2. Hide the complete toolbox. This makes the content attach seamless to the tabs. I prefer this and my patch is implementing this approach.
Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Without the bottom border I had to adapt the margins to stay on the 42px toolbox height.
Attachment #8459296 - Flags: review?(josiah)
Comment on attachment 8459296 [details] [diff] [review]
mail-toolbox.patch

Review of attachment 8459296 [details] [diff] [review]:
-----------------------------------------------------------------

I couldn't test this because I'm still working on fixing OS X builds, but it looks fine. Sorry for the delay.
Attachment #8459296 - Flags: review?(josiah) → review+
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/c170b4a1a391
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 34.0
Do we want to backport this to TB 31? If so, please request approval.
Yes, I waited for the check-in to ask.
Comment on attachment 8459296 [details] [diff] [review]
mail-toolbox.patch

[Approval Request Comment]
User impact if declined: Still visible border
Testing completed (on c-c, etc.): is on c-c
Risk to taking this patch (and alternatives if risky): low, is only CsS
Attachment #8459296 - Flags: approval-comm-esr31?
Attachment #8459296 - Flags: approval-comm-beta?
Attachment #8459296 - Flags: approval-comm-aurora?
Attachment #8459296 - Flags: approval-comm-esr31?
Attachment #8459296 - Flags: approval-comm-esr31+
Attachment #8459296 - Flags: approval-comm-beta?
Attachment #8459296 - Flags: approval-comm-beta+
Attachment #8459296 - Flags: approval-comm-aurora?
Attachment #8459296 - Flags: approval-comm-aurora+
Depends on: 1062750
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.