Closed Bug 1042592 Opened 7 years ago Closed 7 years ago

Consolidate SHA links & buttons next to each commit (and fix broken links)

Categories

(Tree Management :: Treeherder, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: emorley, Assigned: camd)

References

Details

Attachments

(1 file)

Currently for each commit/changeset in a push, there is a:
<SHA linking to treeherder page> [button with arrow on it, linking to hg.mozilla.org]

(See screenshot)

Few things:
1) The SHA currently links to treeherder for this revision, which is redundant, since it just returns the same push as you were viewing previously, since it doesn't make sense to subdivide a push. (If someone wants a permalink to the entire push, they can just use the timestamp on the push header row).
2) For parity with TBPL (and also given #1), the SHA should instead link to hg.mozilla.org
3) If we do that, then both the SHA and the button with the arrow on it link to the same place, so we should remove one of them. For screen estate, it would be best to remove the SHA since it occupies more horizontal space - however it's useful for the sheriffs to have the revision SHA easily copy and pastable, so that would imply leaving the SHA and removing the button.
4) To compromise on #3, we could always use just the button, but have a workaround for copying and pasting (eg like those in bug 1030710 comment 0):
 * Using a pop-up and asking them to ctrl+c: http://stackoverflow.com/a/6055620
 * Using a hidden div and auto-selecting text using JS: http://stackoverflow.com/a/17528590

The above would also help with bug 1042590.

Even if we aren't able to do #4 soon, we should fix #2 and also remove the button temporarily.
Priority: -- → P2
Attached image screenshot.jpg
Duplicate of this bug: 1044320
Assignee: nobody → cdawson
Status: NEW → ASSIGNED
P1 since the SHA links (which people are familiar with using from TBPL) are currently broken.
Priority: P2 → P1
Summary: Consolidate SHA links & buttons next to each commit → Consolidate SHA links & buttons next to each commit (and fix broken links)
https://github.com/mozilla/treeherder-ui/commit/c61b048b9acfc1db6065fbcddc053ac0b3ae17bf

The links were actually fixed in another commit, but this fixes more of the sizing and layout of each revision line.  Removed the button, and made the link go to the repo (hg or git)
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.