In-content preferences "Use Current Pages" in General-Startup should not include about:preferences#general

VERIFIED FIXED in Firefox 45

Status

()

Firefox
Preferences
VERIFIED FIXED
4 years ago
2 years ago

People

(Reporter: Alice0775 White, Assigned: jaws)

Tracking

({common-issue+, regression})

34 Branch
Firefox 46
All
Windows
common-issue+, regression
Points:
---
Dependency tree / graph
Bug Flags:
firefox-backlog ?

Firefox Tracking Flags

(firefox38 wontfix, firefox38.0.5 wontfix, firefox39 wontfix, firefox40 wontfix, firefox41 wontfix, firefox42 wontfix, firefox43 wontfix, firefox44 wontfix, firefox45 verified, firefox46 verified, firefox-esr31 unaffected, firefox-esr38 affected)

Details

(Whiteboard: [qx:spec])

Attachments

(2 attachments)

Comment hidden (obsolete)
(Reporter)

Updated

4 years ago
Blocks: 738797
Keywords: regression
(Reporter)

Comment 1

4 years ago
STR
(In reply to Alice0775 White from comment #0)
> After landing in-content preferences , "Use Current Pages" in
> General-Startup includes about:preferences#general.
> This is annoyance bug for me.
> 
> Steps To Reproduce:
> 1. Open several web pages
> 2. Attempt to set them to Startup page
> 


Steps To Reproduce:
1. Open several web pages
2. Open preferences
3. Select Content pane, Select General pane
4. Attempt to set them to Startup page
(Reporter)

Comment 2

4 years ago
[Tracking Requested - why for this release]:
status-firefox33: --- → unaffected
status-firefox34: --- → affected
tracking-firefox34: --- → ?
tracking-firefox34: ? → +
in-content prefs is not shipping in 34. Dropping tracking.
status-firefox33: unaffected → ---
status-firefox34: affected → ---
tracking-firefox34: + → ---
(Reporter)

Updated

3 years ago
status-firefox38: --- → affected
status-firefox38.0.5: --- → affected
status-firefox39: --- → affected
status-firefox40: --- → affected
status-firefox41: --- → affected
status-firefox-esr31: --- → unaffected
status-firefox-esr38: --- → affected
Keywords: uiwanted
Comment hidden (obsolete)
(Reporter)

Comment 5

3 years ago
maybe you forgot step3 of comment#1


> Steps To Reproduce:
> 1. Open several web pages
> 2. Open preferences
> 3. Select Content pane, Select General pane
> 4. Attempt to set them to Startup page
Flags: needinfo?(gingerbread_man)

Comment 6

3 years ago
(In reply to Alice0775 White from comment #5)
> maybe you forgot step3 of comment#1

Since the description no longer applies, let's tag it obsolete so that it doesn't cause confusion.

Yes, I can reproduce this with the STR at comment 1.
Flags: needinfo?(gingerbread_man)

Comment 7

3 years ago
Now it is worse on 42.0a2 or above.
STR:
Start Firefox, open options and click 'Use Current Pages'.
AR:
"|about:preferences" is added.

Because of
https://hg.mozilla.org/mozilla-central/rev/1372fb8872a1
Such a code-ish(something like the code) statement must not be committed and released.
(bug 1182769 is not resolved of course, btw)

Comment 8

3 years ago
This is a common problem on SuMo recently. For example:

https://support.mozilla.org/questions/1095080 - 19 Nov
https://support.mozilla.org/questions/1094791 - 18 Nov
https://support.mozilla.org/questions/1094741 - 18 Nov
https://support.mozilla.org/questions/1094435 - 16 Nov
https://support.mozilla.org/questions/1093874 - 13 Nov
https://support.mozilla.org/questions/1093851 - 13 Nov
https://support.mozilla.org/questions/1093808 - 12 Nov
https://support.mozilla.org/questions/1093653 - 12 Nov
https://support.mozilla.org/questions/1093254 - 10 Nov

It seems that users are generally able to resolve the issue with a manual edit, but lacking a save button, may re-create the problem by clicking "Use Current Pages" thinking it refers to saving the list in the box rather than inserting the open tabs.

Comment 9

3 years ago
Left this message in the SUMO Contributors Forum:

https://support.mozilla.org/it/forums/contributors/711573?last=67399&page=2#post-67399

Updated

3 years ago
Keywords: common-issue+

Comment 10

3 years ago
It causes also a lot of support requests in the German Firefox forum (compared to other support requests)…

Comment 11

3 years ago
Is this Bug ever going to be fixed properly?

Needing to manually clear |about:preferences from the Home Page field in General is just plain silly.
This is indeed a very odd behavior which makes it impossible to only set one page via this button, which I assume would be the most used case. (Unless off course you want this 1 page to be about:preferences)

I think we should ignore about:preferences in the case of this button.(unless it is the only open tab)
This will allow for one page to be set as Home Page, and also for multiple pages, expect that then about:preferences would be omitted. Which is an edge-case we can accept to not solve.
OS: Windows 7 → Windows
Hardware: x86_64 → All
Whiteboard: [qx:spec]

Comment 13

3 years ago
We have many users who "complain" about that on the French community board since a few weeks, it's really not user-friendly.

Updated

3 years ago
Duplicate of this bug: 1231037

Comment 15

3 years ago
I've been trying out having multiple start pages for the past couple months, and it is very annoying that I can't get rid of that options tab.

Comment 16

3 years ago
(In reply to Bruce Williams from comment #15)
> I've been trying out having multiple start pages for the past couple months,
> and it is very annoying that I can't get rid of that options tab.

Bruce, you can get rid of it by editing it out in either of two places:

(1) On the Options page, General panel, click in the home page address field and delete whichever of these you find, which may be at the end:

|about:preferences
|about:preferences#general

Either tab out of, or click away from, that field to save your change.

Don't click the "Use current pages" button, or about:preferences will be added back, since it is one of the current pages. Just exiting the field is all you need to do.

(2) You can use the about:config preferences editor, as follows:

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(B) In the search box above the list, type or paste HOME and pause while the list is filtered

(C) Double-click the browser.startup.homepage preference and edit out whichever of these you find

|about:preferences
|about:preferences#general

For personal assistance with your home page and other settings, you can use the support forum: 

https://support.mozilla.org/questions/firefox

There's a link at the top of every page to ask a new question. Articles are suggested during the new question flow, and if they don't look useful, keep scrolling down to continue with the form.
Removing uiwanted as I described the preferred UX solution in comment #12
Keywords: uiwanted

Updated

3 years ago
Duplicate of this bug: 1234062
I'm surprised this has slipped under the radar so long after in-content prefs shipped. For future reference, it helps to needinfo the right people. If you don't know who that is- just ask me. ;)

Lawrence, this appears to affect all versions of Firefox from 38-45. Can we finally give it some love?
Flags: needinfo?(lmandel)

Comment 20

3 years ago
Just for refine:
firefox-esr 38.5.2 -> UNaffected
firefox 43 -> affected
firefox 44.0b4 -> affected
firefox 45.0a2 (2015-12-18) -> affected
I don't think this rises to the level of tracking but it is a papercut/polish bug that we should address.

jaws - Thought I'd start with you as you were the driver for in-content prefs. Do we have the ability to filter out about:preferences or maybe the more general about: pages from the home page field?
Flags: needinfo?(lmandel)
Flags: needinfo?(jaws)
Flags: firefox-backlog?
Blocks: 1182769
Flags: needinfo?(jaws)
Created attachment 8703647 [details] [diff] [review]
Patch

This was a mistake in bug 1182769, but I've added a test here to confirm that it works and make sure that it keeps working.
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Attachment #8703647 - Flags: review?(gijskruitbosch+bugs)

Comment 23

3 years ago
Comment on attachment 8703647 [details] [diff] [review]
Patch

Review of attachment 8703647 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/components/preferences/in-content/tests/browser_homepages_filter_aboutpreferences.js
@@ +15,5 @@
> +     "about:blank and about:home should be the only homepages set");
> +
> +  Services.prefs.setCharPref("browser.startup.homepage", oldHomepagePref);
> +  gBrowser.removeCurrentTab();
> +  gBrowser.removeCurrentTab();

Nit:

yield BrowserTestUtils.removeTab(gBrowser.currentTab);
for both of these.
Attachment #8703647 - Flags: review?(gijskruitbosch+bugs) → review+

Comment 24

3 years ago
PS: next time, please submit for review through mozreview. Thanks!
https://hg.mozilla.org/integration/fx-team/rev/33484cfc0ec5b571b057057f68438202964f113f
Bug 1043586 - Tweak how about:preferences gets filtered out of current set of tabs for homepages. r=Gijs

Comment 26

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/33484cfc0ec5
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox46: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 46

Updated

3 years ago
Duplicate of this bug: 1237510
Comment on attachment 8703647 [details] [diff] [review]
Patch

Approval Request Comment
[Feature/regressing bug #]: bug was thought to be fixed by bug 1182769
[User impact if declined]: users who set multiple pages as their home page will always have a preferences page in the list
[Describe test coverage new/current, TreeHerder]: automated test included
[Risks and why]: none expected
[String/UUID change made/needed]: none
Attachment #8703647 - Flags: approval-mozilla-aurora?
Created attachment 8707088 [details] [diff] [review]
Patch for Beta44

Approval Request Comment
[Feature/regressing bug #]: bug was thought to be fixed by bug 1182769
[User impact if declined]: users who set multiple pages as their home page will always have a preferences page in the list
[Describe test coverage new/current, TreeHerder]: automated test included
[Risks and why]: none expected
[String/UUID change made/needed]: none
Attachment #8707088 - Flags: approval-mozilla-beta?
Alice0775 White, could you verify this issue is fixed as expected on a latest Nightly build? Thanks!
Flags: needinfo?(alice0775)
Comment on attachment 8707088 [details] [diff] [review]
Patch for Beta44

I am denying this based on the more stringent Beta44 uplift criteria that allows only for fixing critical (recent) regressions, sec and stability issues. To me this fix, does not meet that bar. 

We have lived several releases with this issue and unfortunately we will have to wontfix this for Fx44 as we are about to enter RC in a week.
Attachment #8707088 - Flags: approval-mozilla-beta? → approval-mozilla-beta-
(Reporter)

Comment 32

3 years ago
(In reply to Ritu Kothari (:ritu) from comment #30)
> Alice0775 White, could you verify this issue is fixed as expected on a
> latest Nightly build? Thanks!

Verified.
No longer reproduce the problem.

https://hg.mozilla.org/mozilla-central/rev/e790bba372f14241addda469a4bdb7ab00786ab3
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0 ID:20160112030227
Flags: needinfo?(alice0775)
status-firefox38: affected → wontfix
status-firefox38.0.5: affected → wontfix
status-firefox39: affected → wontfix
status-firefox40: affected → wontfix
status-firefox41: affected → wontfix
status-firefox42: --- → wontfix
status-firefox43: --- → wontfix
status-firefox44: --- → wontfix
status-firefox45: --- → affected
Comment on attachment 8703647 [details] [diff] [review]
Patch

Taking it in aurora.
Attachment #8703647 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Comment 34

3 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/41a8d4d5521f
status-firefox45: affected → fixed

Updated

3 years ago
Duplicate of this bug: 1242136

Updated

2 years ago
Duplicate of this bug: 1253118
Duplicate of this bug: 1252429
I have reproduced this bug with Firefox Nightly 34.0a1 (Build ID: 20140724030201) on 
Windows 8.1, 64-bit with the instructions from comment 0.

Verified as fixed with Firefox beta 45.0b9 (Build ID: 20160222143322)
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0

Verified as fixed with Firefox Aurora 46.0a2 (Build ID: 20160303004038)
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
QA Whiteboard: [testday-20160304]

Updated

2 years ago
Status: RESOLVED → VERIFIED
status-firefox45: fixed → verified
status-firefox46: fixed → verified
(Reporter)

Updated

2 years ago
Duplicate of this bug: 1253587
Duplicate of this bug: 1234013
You need to log in before you can comment on or make changes to this bug.