need UI for specifying columnlist for just one query

NEW
Unassigned

Status

()

Bugzilla
Query/Bug List
P3
enhancement
17 years ago
11 years ago

People

(Reporter: Andreas Franke (gone), Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Per kiko's request, I'm filing this bug for the frontend part of bug 12284.

Updated

17 years ago
Summary: need UI for one-time custom specification of columnlist → need UI for specifying columnlist for just one query
Priority: -- → P2
Target Milestone: --- → Bugzilla 2.18
(Reporter)

Comment 1

16 years ago
Now that colchange.cgi has been templatized, attachment 52227 [details] in bug 12284 is
obsolete. 

Instead, here is the templatized version of that attachment: 

1. Insert the following line in colchange.cgi before processing the template:

$vars->{collist_string}= value_quote(join(" ", @collist));

2. Patch template/default/buglist/colchange.tmpl with the following patch.
(Reporter)

Comment 2

16 years ago
Created attachment 67596 [details] [diff] [review]
patch to colchange.tmpl

Oops, wrong attachment number. It's attachment 53227 [details] [diff] [review] that is obsoleted by this
one.
This should also be saveable with stored queries.

Comment 4

16 years ago
I agree on this, I'd like to see the column list removed from cookies.

Using different computers/browsers makes for inconsistent columns, and there are
definite advantages for having different queries show different columns.
Blocks: 173124

Comment 5

15 years ago
I agree with this request too. 

For my purposes, an even better (and perhaps easier to implement?) feature would
be: "show any column I specified in my query in addition to the normal ones".
Probably needs a checkbox to enable this, since it won't always be what you want.

But saving columns per stored query would be fine too. 

This is especially true with custom fields.
Assignee: endico → nobody
Comment on attachment 67596 [details] [diff] [review]
patch to colchange.tmpl

This is bitrotted
Attachment #67596 - Flags: review-
Target Milestone: Bugzilla 2.18 → Bugzilla 2.20
Bugzilla 2.20 feature set is now frozen as of 15 Sept 2004.  Anything flagged
enhancement that hasn't already landed is being pushed out.  If this bug is
otherwise ready to land, we'll handle it on a case-by-case basis, please set the
blocking2.20 flag to '?' if you think it qualifies.
Target Milestone: Bugzilla 2.20 → Bugzilla 2.22

Updated

12 years ago
Assignee: nobody → query-and-buglist
QA Contact: mattyt-bugzilla → default-qa
Target Milestone: Bugzilla 2.22 → ---

Updated

11 years ago
Priority: P2 → P3

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 345826

Comment 9

11 years ago
OK, reopening. Bug 12284 comment 24 explicitly asks the column list to be available on query.cgi, i.e. at the same time you choose your search criteria. Bug 345826 only works with already saved searches.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Updated

11 years ago
Status: REOPENED → NEW
You need to log in before you can comment on or make changes to this bug.