Closed Bug 12284 Opened 20 years ago Closed 18 years ago

let me specify which columns to display in a bug list

Categories

(Bugzilla :: Query/Bug List, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
Bugzilla 2.16

People

(Reporter: CodeMachine, Assigned: afranke)

References

Details

Attachments

(6 files, 3 obsolete files)

It would be nice if you could specify the initial columns on the query screen.
I've seen that change columns seems to be permanent regardless of query, this in
my experience is not what I want.  I think it would be better to put this in the
URL and allow it to be specified.

This would allow you to store or bookmark which columns you wanted to appear in
a particular query.  I think the notion of a default set of columns can already
be handled be the default query mechanism.
Status: NEW → ASSIGNED
Priority: P3 → P2
tara@tequilarista.org is the new owner of Bugzilla and Bonsai.  (For details,
see my posting in netscape.public.mozilla.webtools,
news://news.mozilla.org/38F5D90D.F40E8C1A%40geocast.com .)
Assignee: terry → tara
Status: ASSIGNED → NEW
Status: NEW → ASSIGNED
*** Bug 51097 has been marked as a duplicate of this bug. ***
Adding default QA contact to all open Webtools/Bugzilla bugs lacking one.
Sorry for the spam.
QA Contact: matty
Target Milestone: --- → Future
Blocks: 86547
Moving to new Bugzilla product ...
Assignee: tara → endico
Status: ASSIGNED → NEW
Component: Bugzilla → Query/Bug List
Product: Webtools → Bugzilla
Version: other → unspecified
Taking. This shouldn't be hard.
Assignee: endico → afranke
Target Milestone: Future → ---
This is basically a two-liner. Ok, it's just the backend, no UI yet, but I think
the UI can be added later, in a second step. The backend alone is already
useful, e.g. to embed queries in other html pages.
Keywords: patch, review
Target Milestone: --- → Bugzilla 2.16
I disagree about the UI.  HTML often requires you do that back-end in a specific
way.  We should decide whether the back end matches what we would like so we
won't have to change it later, resulting in backwards compatability cruft.

Do we want a checkbox to say "use last set of columns", and ignore the parameter
otherwise?  Or do we want no specified columns to mean that?

The former is properly more user-friendly while the latter matches the code that
is here.
I don't think backwards compatibility cruft would be a problem. You can easily
support multiple different ways to pass the columnlist information to
buglist.cgi. Even if we choose to use a different way on query.cgi, it is still
convenient to have support for a "columnlist" string: e.g. when you put a query
link in you html page, you can simply add &columnlist= and copy your COLUMNLIST
cookie value (ok, you have to change spaces to +).

Anyway, feel free to propose and implement a better UI. One alternative would be
to use checkboxes, e.g. with names "column_$i" as in colchange.cgi .

Another thing to think of is whether the user should be allowed to specify the
the of the columns. For this, we could offer multiple selectboxes, each offering
all possible columns.

However, the best UI I can think of is the following (but I can already hear you
cries): Use a long text field for the user to specify the columnlist, and offer
two select boxes to add and remove columns through JavaScript (like Myk's patch
in bug 80169 "[RFE] JavaScript-enhanced keyword editing", attachment 38530 [details] [diff] [review]; you
can test this on http://bugzilla.mathweb.org/show_bug.cgi?id=76 ).
Keywords: ui
... to specify the _order_ of the columns ...
*** Bug 99660 has been marked as a duplicate of this bug. ***
*** Bug 101173 has been marked as a duplicate of this bug. ***
Summary: Column specification support. → let me specify which columns to display in a bug list
This might be rolled in to mpt and kiko's new query.cgi interface.

Gerv
This patch is the same as the very first one (attachment 48713 [details] [diff] [review]), except that it
uses /[ ,]+/ instead of / / to split the columnlist value into parts. It is a
robust, minimal patch to support a columnlist parameter in the url.
This is essentially a two-liner, so it won't create any problems with backwards
compatibility, should we ever decide to support other ways of specifying which
columns to display.
Please review and checkin asap. If someone rewrites bugzilla, this is ok with
me, but it shouldn't hold up this simple fix.
That should be if ... elsif... else rather than if ... else { if ... else }..
Change that, and you have r=gerv.

Gerv
Comment on attachment 52930 [details] [diff] [review]
robust minimal patch, v.3 (using "elsif")

Recording r=gerv.
Attachment #52930 - Flags: review+
Attachment #52900 - Attachment is obsolete: true
Attachment #48713 - Attachment is obsolete: true
Attachment #48714 - Attachment is obsolete: true
Andreas, Gerv: I'm unsure of how this bug should be solved. I mean, the
patch looks good and all, but AFAICT this will leave us with no UI to
access the parameterlist.

My proposal: we file a bug _specifically_ for adding this UI capability
, make the query.cgi redesign bug 98707 depend on that bug, and make
this bug block on that one. That way I won't forget it nor will we lose
track of what started it all.

bug 98707 query.cgi -> new bug -> this bug 12284

If that is done, r=kiko and check this in. I would file the bugs but I
don't really know what is involved.
Status: NEW → ASSIGNED
kiko: If you need a bug for a UI in query.cgi, feel free to file one. Otherwise
we can use this bug for it.

I have attached an example patch that lets you restrict the columnlist in
colchange.cgi, but without changing the cookie. I'm not sure whether this
already counts as having a UI available, but it demonstrates that the patch to
buglist.cgi is actually useful.
Comment on attachment 52930 [details] [diff] [review]
robust minimal patch, v.3 (using "elsif")

r=kiko
Please file a new bug for the UI please, and we'll take it from there.
Attachment #52930 - Flags: review+
Filed bug 105110 for the UI.
-> default owner. (Pulling myself out.)
Assignee: afranke → endico
Status: ASSIGNED → NEW
-> patch author
Assignee: endico → afranke
checked in.

/cvsroot/mozilla/webtools/bugzilla/buglist.cgi,v  <--  buglist.cgi
new revision: 1.154; previous revision: 1.153
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.