Closed Bug 1053970 Opened 5 years ago Closed 5 years ago

Places search regressed

Categories

(Firefox OS Graveyard :: Gaia::Search, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: daleharvey, Unassigned)

References

Details

If you view a url, that url will not be shown when searching rocketbar subsequently

This was partially regressed by https://github.com/mozilla-b2g/gaia/commit/1d7ad2145af2fd9a7349e716f14a8f58670102c2, however reverting that alone doesnt fix it, there is a web components bug with |[marionette error] app://search.gaiamobile.org/shared/elements/gaia_grid/script.js:21 TypeError: this.createShadowRoot is not a function| that looks to be causing breakage

https://bugzilla.mozilla.org/show_bug.cgi?id=1049143 is a test that would have caught this but was disabled due to intermittents, need to reenable
So if I do a standalone test for createShadowRoot it works fine in nightly, but |[marionette error] app://search.gaiamobile.org/shared/elements/gaia_grid/script.js:21 TypeError: this.createShadowRoot is not a function| pretty much kills everything, having a hard time figuring out what would cause this. 

Any ideas?
Flags: needinfo?(kgrandon)
Flags: needinfo?(kgrandon)
I am unable to reproduce the issue in master. I think this was possibly solved by bug 1053976? Dale can you verify?
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(dale)
Resolution: --- → WORKSFORME
Nope as mentioned reverting / fixing that bug alone doesnt fix it, theres a web components issues

Can run |VERBOSE=1 TEST_FILES=apps/search/test/marionette/places_search_test.js make test-integration| to see the failure
Status: RESOLVED → REOPENED
Flags: needinfo?(dale)
Resolution: WORKSFORME → ---
So confirmed places was fixed by that change, but the test is still broken so tracking that in https://bugzilla.mozilla.org/show_bug.cgi?id=1049143
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.