Deleting the autofilled portion of a URL should result in the first result being the current search engine

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Unfocused, Unassigned)

Tracking

unspecified
Points:
---
Dependency tree / graph
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed by bug 1172937)

From bug 951624 comment 31:
> STR : 
> 1. type "face" in the awesomebar.
> 2. Awesomebar autocompletes to facebook.com
> 3. Hit backspace to have "face" again in the awesomebar.
> 
> CR : the first entry is still visit facebook.com
> 
> ER : the first entry change to search google for "face"

Unfortunately, I don't see a way to do with using the current autocomplete API.

We'd need to handle something here:
http://dxr.mozilla.org/mozilla-central/source/toolkit/components/autocomplete/nsAutoCompleteController.cpp#226
Flags: firefox-backlog+
Flags: qe-verify?
Flags: qe-verify? → qe-verify+
Blocks: 951624
No longer depends on: 951624
we should start by handling backspace properly... I wonder if my patch in bug 719888 would help... provided we should probably change the API and add handleBackspace rather than reusing handleNavigation like I did...
Depends on: 1067935
QA Contact: andrei.vaida
Duplicate of this bug: 1095072
I'm glad that bug 1067903 has landed, but now backspace behavior is even more broken. Since the first entry is always selected sometimes you just have "face" typed in the awesomebar (after deleting the "book.com") but on hitting enter the visited site is still facebook.com even if you wanna search "face". It wasn't broken like that before.
Depends on: 1172937
Duplicate of this bug: 1187747
bug 1187747 is about NOT LOADING the page after you delete suggested text with BackSpace and then press Enter. Nothing happens in this case.
Either change the title of this bug or reopen that bug.

Anyway, this bug already has wrong title according to bug 1187753
(In reply to arni2033 from comment #5)
> bug 1187747 is about NOT LOADING the page after you delete suggested text
> with BackSpace and then press Enter. Nothing happens in this case.
> Either change the title of this bug or reopen that bug.

it doesn't happen anything because what should happen is what is expressed in this bug. If you prefer I can dupe to bug 1173202, but nothing changes in practice, all of these are just manifestations of the same bug, bug 1172937.
fixed by bug 1172937.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Flags: qe-verify+
QA Contact: andrei.vaida
Whiteboard: fixed by bug 1172937
You need to log in before you can comment on or make changes to this bug.