[e10s] View Page Source of context menu does not work in e10s

VERIFIED FIXED in Firefox 36

Status

()

Firefox
General
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: tetsuharu, Assigned: tetsuharu)

Tracking

(Blocks: 1 bug)

Trunk
Firefox 34
x86_64
Windows 7
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox36 verified)

Details

Attachments

(1 attachment)

+++ This bug was initially created as a clone of Bug #1058539 +++
(Assignee)

Updated

4 years ago
Depends on: 1058712
(Assignee)

Updated

4 years ago
No longer depends on: 1058539
(Assignee)

Updated

4 years ago
No longer blocks: 1058701
(Assignee)

Updated

4 years ago
No longer depends on: 1058712
Comment on attachment 8479209 [details] [diff] [review]
patch

I'm pretty sure this is going to break for non-e10s windows, since gContextMenu.browser.contentDocumentAsCPOW will return undefined in that case.
Attachment #8479209 - Flags: review?(mconley) → review-
(In reply to Mike Conley (:mconley) from comment #2)
> I'm pretty sure this is going to break for non-e10s windows, since
> gContextMenu.browser.contentDocumentAsCPOW will return undefined in that
> case.

If you say so, does this code has same risk for non-e10s windows?
http://dxr.mozilla.org/mozilla-central/source/browser/base/content/browser-sets.inc#41
Hm... maybe I'm wrong on that. That code you've pointed out certainly contradicts what I said. Let me run a few experiments and get back to you.
Comment on attachment 8479209 [details] [diff] [review]
patch

Ah, yes, sorry - I was testing with an older build that didn't have billm's AsCPOW work in it, so of course it was undefined.

My apologies. Yes, this should work fine for now until we have a better solution that doesn't involve CPOWs.
Attachment #8479209 - Flags: review- → review+
Thank you r+, Mike.

At the current rule, can I land the patch after https://tbpl.mozilla.org/?tree=Try&rev=0ab627c312a1 finished?
https://hg.mozilla.org/mozilla-central/rev/11930a45d9a7
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Assignee: nobody → saneyuki.s.snyk
Target Milestone: --- → Firefox 34
Flags: qe-verify+

Comment 9

4 years ago
I can reproduce the bug on Nightly build from: 2014-08-26;

The bug is no longer reproducible on latest Nightly build 2014-11-06;
Status: RESOLVED → VERIFIED
status-firefox36: --- → verified
You need to log in before you can comment on or make changes to this bug.