Closed Bug 1060193 Opened 8 years ago Closed 8 years ago

Text selection caret appearing in wrong position in Settings - Lockscreen - Passcode

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect, P2)

x86
macOS
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1082486

People

(Reporter: mnjul, Assigned: TYLin)

References

Details

Attachments

(1 file)

Attached image 2014-08-29-11-18-38.png
In Settings - Screen Lock - Passcode lock, the newly-landed text selection caret bubble appears in the wrong position. Please take a look at the attached screenshot.

I think the bubble shouldn't be showing at all, as the passcode input boxes weren't given a "blinking caret" even before this new feature was implemented; we might need a UX's opinion here.
The root cause is, in passcode panel, there's only one actual input field on the left-top, and the other fields are just spans which display what we key, and every time we tap on the screen, it will focus on the real input field. That's why the caret shows on the top-left.
Hi Morris,
do u have any idea on this topic?
For that kinda fake input field, is it possible to disable the caret and event trigger by setting some CSS attribute?
Flags: needinfo?(mtseng)
(In reply to George Duan [:gduan] [:喬智] from comment #2)
> Hi Morris,
> do u have any idea on this topic?
> For that kinda fake input field, is it possible to disable the caret and
> event trigger by setting some CSS attribute?

George, as we discussed, please help to check visible region of that 'fake input' is empty or not? If visible region is empty, I think we could disable touch caret under this condition.
Flags: needinfo?(mtseng) → needinfo?(gduan)
Priority: -- → P2
Set it depends on bug 1059165.

I think bug 1059165 can also fix this pb, if we only show caret when the input field is focused and touched.
Depends on: 1059165
Flags: needinfo?(gduan)
Duplicate of this bug: 1068042
Duplicate of this bug: 1070129
Assignee: nobody → tlin
Setting the pass-code is from user perspective something important. You brick your phone if you set another code than you intend to. This must be super clear for the user

As the new caret is wrongly placed this bug creates a degraded user experience compared to previous versions (I assume you wouldn't launch anything like this).

Please fix for 2.1.
Tagged as Tako_Blocker so it shows up in search query
blocking-b2g: --- → 2.1?
Whiteboard: [Tako_Blocker]
Component: Gaia::System → Gaia::Settings
Hi Olof, this bug does not happen in v2.1.
blocking-b2g: 2.1? → ---
Whiteboard: [Tako_Blocker]
Touch caret is disabled in 2.1 in bug 1059061.
(In reply to howie [:howie] from comment #8)
> Hi Olof, this bug does not happen in v2.1.

Thanks, seems I've inadvertently got my Flame on 2.2 release. Sorry for the extra work I caused.

Best regards

/Olof
After Bug 1082486 was resolved, touch caret should not appear on the passcode-input anymore.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1082486
You need to log in before you can comment on or make changes to this bug.