[ALA][UI] Implementation of Panel 3 in appropriate context

RESOLVED FIXED

Status

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: marta, Assigned: marta)

Tracking

({privacy})

unspecified
All
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(feature-b2g:2.2+)

Details

Attachments

(2 attachments, 1 obsolete attachment)

495.55 KB, application/pdf
Details
46 bytes, text/x-github-pull-request
Details | Review
Assignee

Description

5 years ago
Posted file ALA workflow (obsolete) —
Panel #3 allows to choose the Level of ALA. Once user clicks on "Adjust location" in panel #2, panel #3 is loaded, allowing the user to choose the granularity of the adjustments. The method used to choose the granularity is not yet defined (slider, radio buttons, list...). Anyway the choice should be confirmed and stored in the database with appropriate context (map:blur_level = 10). Refer to attachment for more information.

Updated

5 years ago
Keywords: privacy

Updated

5 years ago
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → All
Assignee

Updated

5 years ago
Assignee: nobody → marta
QA Whiteboard: STATUS: waiting for UX decision, waiting for engineering decision
Priority: -- → P5
Assignee

Updated

5 years ago
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → INVALID
Assignee

Updated

5 years ago
QA Whiteboard: STATUS: waiting for UX decision, waiting for engineering decision
Priority: P5 → --
Assignee

Comment 1

5 years ago
Due to the changes in the UI we will in the end need panel #3. The panel should contain:
- depending on the choice from the drop down a different element should appear between the drop down and the “add exception” button
- If blur is chosen: show a slider with the options 500m, 1km, 2km, 5 km, 10 km, 15 km, 20 km, 50 km, 75 km, 100km, 500 km, 1000 km.
- If Custom location is chosen: show text and a button “set custom location” (no code)
- If Precise or No Location: show nothing
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Assignee

Updated

5 years ago
QA Whiteboard: STATUS: implementation work
Priority: -- → P5
Assignee

Comment 2

5 years ago
Attachment #8482843 - Attachment is obsolete: true
Assignee

Updated

5 years ago
Severity: normal → critical
Priority: P5 → P4
Can I suggest that the blur have fewer choices?  I think it makes sense to have 1km, 10km, 100km, 1000km.  From the user's standpoint, what's really the difference between 1km and 2km, or 50km and 75km?  I think it is too fine grained to be meaninful.
Assignee

Comment 4

5 years ago
Let's discuss it during workshop. The granularity you proposed is too small IMHO. The difference between 1 and 2 km is based on usability wrt search apps. If I look for a restaurant but still want to blur my location, then I might be fine with walking additional km but not 2. 50/75 might make less sense but that was same idea from drivers perspective.
Assignee

Updated

5 years ago
Severity: critical → normal
QA Whiteboard: STATUS: implementation work → STATUS: ready for review
Priority: P4 → --
Assignee

Updated

5 years ago
Depends on: 1068008
Assignee

Updated

5 years ago
Depends on: 1068023
Assignee

Updated

5 years ago
Depends on: 1068031
Assignee

Updated

5 years ago
Depends on: 1069144
Assignee

Updated

5 years ago
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED

Updated

5 years ago
feature-b2g: --- → 2.2+
You need to log in before you can comment on or make changes to this bug.