Closed Bug 1061894 Opened 6 years ago Closed 6 years ago

Intermittent 346258-1.html,394810-1.html,400349-1.html,616930-1.html,639737-1.html | assertion count 1 is more than expected

Categories

(Core :: ImageLib, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla35
Tracking Status
firefox33 --- unaffected
firefox34 --- fixed
firefox35 --- fixed
firefox-esr31 --- unaffected

People

(Reporter: RyanVM, Assigned: tnikkel)

References

Details

(Keywords: assertion, intermittent-failure)

Attachments

(1 file)

https://tbpl.mozilla.org/php/getParsedLog.php?id=47244413&tree=Mozilla-Central

Android 4.0 Panda mozilla-central debug test crashtest on 2014-09-02 12:15:04 PDT for push c24ec895b156
slave: panda-0151

12:34:13     INFO -  REFTEST TEST-START | http://10.26.128.22:30151/tests/js/xpconnect/crashtests/400349-1.html
12:34:13     INFO -  REFTEST TEST-LOAD | http://10.26.128.22:30151/tests/js/xpconnect/crashtests/400349-1.html | 900 / 2709 (33%)
12:34:13     INFO -  REFTEST TEST-PASS | http://10.26.128.22:30151/tests/js/xpconnect/crashtests/400349-1.html | (LOAD ONLY)
12:34:13     INFO -  REFTEST INFO | Loading a blank page
12:34:13     INFO -  REFTEST TEST-UNEXPECTED-FAIL | http://10.26.128.22:30151/tests/js/xpconnect/crashtests/400349-1.html | assertion count 1 is more than expected 0 assertions
12:34:13     INFO -  REFTEST TEST-END | http://10.26.128.22:30151/tests/js/xpconnect/crashtests/400349-1.html

From the logcat:
09-02 12:33:55.421 I/Gecko   ( 2124): [2124] ###!!! ASSERTION: Observers still registered?: '!mObserverList.mObserver && !mObserverList.mNext', file /builds/slave/m-cen-and-d-000000000000000000/build/content/base/src/nsImageLoadingContent.cpp, line 117
https://tbpl.mozilla.org/php/getParsedLog.php?id=47286252&tree=Mozilla-Inbound

Seth, these started happening pretty frequently in the last day or so. Any ideas?
Flags: needinfo?(seth)
Duplicate of this bug: 1061176
Summary: Intermittent 400349-1.html | assertion count 1 is more than expected (ASSERTION: Observers still registered?: '!mObserverList.mObserver && !mObserverList.mNext', file content/base/src/nsImageLoadingContent.cpp, line 117) → Intermittent 346258-1.html,400349-1.html,616930-1.html,639737-1.html | assertion count 1 is more than expected (ASSERTION: Observers still registered?: '!mObserverList.mObserver && !mObserverList.mNext', file nsImageLoadingContent.cpp, line 117)
Going back through inbound's history, it appears to have started shortly after bug 1008942 landed.
Blocks: 1008942
Flags: needinfo?(tnikkel)
Based on the code in that bug, it seems to be a very likely candidate indeed.
Flags: needinfo?(seth)
Attached patch patchSplinter Review
I think image/test/crashtests/ownerdiscard.html is responsible. In fact I think bug 784591 is what introduced the bug into that test, I guess bug 1008942 just exposed it.

The patch for bug 784591 was wrong. If we move on because the image never gets decoded (and hence never discarded) we also need to cleanup by removing the observer the same way as if we do get decoded and discarded.

try run
https://tbpl.mozilla.org/?tree=Try&rev=2e9e937fdb12
Assignee: nobody → tnikkel
Attachment #8483778 - Flags: review?(seth)
Flags: needinfo?(tnikkel)
Blocks: 784591
Duplicate of this bug: 1061222
Try run indicates the patch does indeed fix the problem.
Duplicate of this bug: 1062038
https://tbpl.mozilla.org/php/getParsedLog.php?id=47368987&tree=Mozilla-Inbound
Summary: Intermittent 346258-1.html,400349-1.html,616930-1.html,639737-1.html | assertion count 1 is more than expected (ASSERTION: Observers still registered?: '!mObserverList.mObserver && !mObserverList.mNext', file nsImageLoadingContent.cpp, line 117) → Intermittent 346258-1.html,394810-1.html,400349-1.html,616930-1.html,639737-1.html | assertion count 1 is more than expected
https://tbpl.mozilla.org/php/getParsedLog.php?id=47415056&tree=Mozilla-Inbound

Seth, this is currently causing great pain on TBPL. Can you please find time for a quick review? :)
Flags: needinfo?(seth)
Comment on attachment 8483778 [details] [diff] [review]
patch

Review of attachment 8483778 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good!
Attachment #8483778 - Flags: review?(seth) → review+
Flags: needinfo?(seth)
I went ahead and pushed this since the need seems to be serious:

https://hg.mozilla.org/integration/mozilla-inbound/rev/65dead1492ba
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/65dead1492ba
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
Please request Aurora approval on this when you get a chance.
Flags: needinfo?(tnikkel)
Comment on attachment 8483778 [details] [diff] [review]
patch

Approval Request Comment
[Feature/regressing bug #]: bug 1008942
[User impact if declined]: none to users, but test failures that require manual staring by sheriffs
[Describe test coverage new/current, TBPL]: the patch fixes a test
[Risks and why]: fixing a text, no risk to users, been on mozilla-central for a few days with no problems
[String/UUID change made/needed]: none
Attachment #8483778 - Flags: approval-mozilla-aurora?
Flags: needinfo?(tnikkel)
Comment on attachment 8483778 [details] [diff] [review]
patch

Aurora+
Attachment #8483778 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.