Closed Bug 1062408 Opened 7 years ago Closed 5 years ago

opening emails fails after moving an IMAP folder. error "error clearing message pane Source File: resource:///modules/errUtils.js", then errors in ClearMessagePane

Categories

(Thunderbird :: Folder and Message Lists, defect)

30 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1328814

People

(Reporter: info, Unassigned)

References

Details

(Keywords: regression, regressionwindow-wanted, reproducible, Whiteboard: [regression:TB2?])

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140825202822

Steps to reproduce:

Move email from sent to a folder and then move that folder to anther folder and then you can not open another email.

Worked perfectly before Version 30 or 31

Errors

Timestamp: 9/3/2014 12:52:07 PM
Error: [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIDOMLocation.href]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: chrome://messenger/content/msgMail3PaneWindow.js :: ClearMessagePane :: line 1103"  data: no]
Source File: resource:///modules/errUtils.js
Line: 96

--------------------------------

Timestamp: 9/3/2014 12:52:07 PM
Error: error clearing message pane
Source File: resource:///modules/errUtils.js
Line: 34

----------
Timestamp: 9/3/2014 12:52:07 PM
Error: [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIDOMLocation.href]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: chrome://messenger/content/msgMail3PaneWindow.js :: ClearMessagePane :: line 1103"  data: no]
Source File: resource:///modules/errUtils.js
Line: 35

--------------

Timestamp: 9/3/2014 12:52:07 PM
Error: [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIDOMLocation.href]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: chrome://messenger/content/msgMail3PaneWindow.js :: ClearMessagePane :: line 1103"  data: no]
Source File: resource:///modules/errUtils.js
Line: 96

----------


Timestamp: 9/3/2014 12:52:07 PM
Error: error clearing message pane
Source File: resource:///modules/errUtils.js
Line: 34

------------
Timestamp: 9/3/2014 12:52:07 PM
Error: [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIDOMLocation.href]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: chrome://messenger/content/msgMail3PaneWindow.js :: ClearMessagePane :: line 1103"  data: no]
Source File: resource:///modules/errUtils.js
Line: 35

----------


Actual results:

Errors - and have to close and restart Thunderbird
I have Teamviewer if someone wants to have look and see how to reproduce the fault
My other computer that was using Thunderbird 28 worked perfectly until the weekend until I upgraded it too by mistake and it now does the same thing.


I have reloaded Windows 7 professorial thinking it was a Windows issue and when I reloaded Thunderbird it did the same thing.

I have also removed Thunderbird and reinstalled Ver 28 and it sill has the same problem.    

Hope that info helps
Version 28 was never publicly released.
Are you using betas?
Component: Untriaged → Folder and Message Lists
Flags: needinfo?(info)
I can't reproduce this on TB34. I get a very long hang while the folder is dragged to another one. But once it finishes, everything seems to work fine, I can open other messages and folders.

Is there anything specific to be done before/between the 2 moves? Should the message be displayed (in the preview pane) before it is moved from Sent? Or something like that?
Can I show you.  Can you use Teamviwer?
Flags: needinfo?(info)
I can reproduce this over and over again on 3 different computers now.
--- Comment #4 from :aceman <acelists@atlas.sk> 2014-09-04 06:39:26 PDT ---
I can't reproduce this on TB34. I get a very long hang while the folder is
dragged to another one. But once it finishes, everything seems to work fine, I
can open other messages and folders.

Is there anything specific to be done before/between the 2 moves? Should the
message be displayed (in the preview pane) before it is moved from Sent? Or
something like that?
=============================

Nothing SPECIAL has to be done.   I can reproduce it 50 times per day.   I have 100 of sub folders inside other sub folders.   After I move a folder I have to close Thunderbird and re launch it - Or go to View / Layout and change the lay out and then it will show the next email I click on.
No  I'm not using Betas copies.   May be it was Ver 29 that I reinstalled.   It was a Twenty something version.   No difference.

I would love to show someone if they want to log into my PC with Team Viewer. 

My email is is   info@hottubcoverscanada.ca  

-- 
Thank you
Gordon Duesburry  -  Owner

Hot Tub Covers Canada - www.hottubcoverscanada.ca
Email - info@hottubcoverscanada.ca

Sun Covers Canada - www.suncoverscanada.ca
Email - info@suncoverscanada.ca

Office 1-877-544-2683    Fax 705-999-9949
I can confirm I have seen the bug in operation via Team Viewer. It does happen but it is an IMAP account. I am not sure what would chrome://messenger/content/msgMail3PaneWindow.js :: ClearMessagePane fail as it seems it expects problems on IMAP and catches them:

  1091 function ClearMessagePane()
  1092 {
  1093   // hide the message header view AND the message pane...
  1094   HideMessageHeaderPane();
  1095   gMessageNotificationBar.clearMsgNotifications();
  1096   ClearPendingReadTimer();
  1097   try {
  1098     // This can fail because cloning imap URI's can fail if the username
  1099     // has been cleared by docshell/base/nsDefaultURIFixup.cpp.
  1100     let messagePane = GetMessagePaneFrame();
  1101     // If we don't do this check, no one else does and we do a non-trivial
  1102     // amount of work.  So do the check.
  1103     if (messagePane.location.href != "about:blank")
  1104       messagePane.location.href = "about:blank";
  1105   } catch(ex) {
  1106       logException(ex, false, "error clearing message pane");
  1107   }
  1108 }

It is strange that it would fail on getting the location.href of the messagePane.

The problem is fixed if View -> Layout is changed. But not when View->Folders mode is changed.

Squib, any idea why the message pane can get stuck? Even opening the message in a new tab doesn't work. Also, in this stuck mode, also the message context menu is broken, it shows all the possible items, not only the relevant ones. The hiding of the non-relevant menuitems doesn't work/probably is interrupted by an exception which doesn't get into the error console.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(squibblyflabbetydoo)
Off the top of my head, I don't know. If this is a regression, could we find a regression window? That'd help narrow things down.
Flags: needinfo?(squibblyflabbetydoo)
There's no need to repeatedly comment on this bug. The Thunderbird developers have seen it. However, that doesn't mean that we we're working on a fix; I'm not even sure what's broken.
I use daily (nightly) 24x7 and today is the first time I've seen this. OTOH, I don't delete folders very often these days. But it is fairly reproducible.

Aceman, do you want a regression range?  If so Gordon sounds anxious to help. (I'm not in a position to regression hunt just now)
Flags: needinfo?(acelists)
Whiteboard: [regression:TB2?]
Summary: opening emails after moving a folder → opening emails fails after moving a folder. error "error clearing message pane Source File: resource:///modules/errUtils.js"
(In reply to Wayne Mery (:wsmwk) from comment #15)
> Aceman, do you want a regression range?  If so Gordon sounds anxious to
> help. (I'm not in a position to regression hunt just now)
Looks like this could help.
Flags: needinfo?(acelists)
hmm, Gordon's account is disabled.
Duplicate of this bug: 1193885
Blocks: 1083994
On 11/17/2015 3:26 PM, Richard Kuipers wrote:
> Is there anything you need from me in this regards?

Bisecting involves 
0. Backup your Thunderbird profile to protect your data
1. pick the midpoint (M) between a build (A) that is known to work, and a build (Z) that is known to not work
2. install and test build (M). 
3. repeat #1 and #2, picking a new midpoint, until you have a one-day date range indentified where build on date N works and build on date N+1-day fails

Then post your results in the bug.
(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #20)
> On 11/17/2015 3:26 PM, Richard Kuipers wrote:
> > Is there anything you need from me in this regards?
> 
> Bisecting involves 
> 0. Backup your Thunderbird profile to protect your data
> 1. pick the midpoint (M) between a build (A) that is known to work, and a
> build (Z) that is known to not work
> 2. install and test build (M). 
> 3. repeat #1 and #2, picking a new midpoint, until you have a one-day date
> range indentified where build on date N works and build on date N+1-day fails
> 
> Then post your results in the bug.

You can ease the process of bisecting using Moz Regression tool. More info here:
https://developer.mozilla.org/en-US/docs/Mozilla/Projects/Mozmill/How_to_do_regression_testing

And download the mozregression tool here:
https://github.com/mozilla/mozregression
I just encountered this again. 
Error: error clearing message pane
Source File: resource:///modules/errUtils.js
Line: 34
Error: [Exception... "Illegal value"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: chrome://messenger/content/msgMail3PaneWindow.js :: ClearMessagePane :: line 1093"  data: no]
Source File: resource:///modules/errUtils.js


bug 1120361 reports a similar issue.
Blocks: 1120361
Summary: opening emails fails after moving a folder. error "error clearing message pane Source File: resource:///modules/errUtils.js" → opening emails fails after moving a folder. error "error clearing message pane Source File: resource:///modules/errUtils.js", then errors in ClearMessagePane
I can reproduce the error message after renaming a folder.
Depends on: 916095
I am seeing this too w/ TB 45.5.1 (on Linux, Gentoo x86_64) after moving folders to Trash. Either I restart TB or a switch layout back and forth, otherwise I cannot open a single mail again in any folder and get the above mentioned error msgs in my log.
No longer blocks: 1083994
No longer blocks: 1120361
Duplicate of this bug: 1120361
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(bugzilla)
Resolution: --- → DUPLICATE
Duplicate of bug: 1083994
Summary: opening emails fails after moving a folder. error "error clearing message pane Source File: resource:///modules/errUtils.js", then errors in ClearMessagePane → opening emails fails after moving an IMAP folder. error "error clearing message pane Source File: resource:///modules/errUtils.js", then errors in ClearMessagePane
Cause of problem was found at last, and bug 1328814 was opened.
Duplicate of bug: 1328814
You need to log in before you can comment on or make changes to this bug.